Download it now!
Bug 33383 - LibreOffice QuickStart blocks system shutdown
Summary: LibreOffice QuickStart blocks system shutdown
Status: RESOLVED DUPLICATE of bug 34669
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-23 10:16 UTC by sherov
Modified: 2012-02-28 10:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sherov 2011-01-23 10:16:05 UTC
Ubuntu 10.10. The system does not react to shutdown command while QuickStart sits in tray. With QuickStart closed, the shutdown command works. The same thing for RC3 and RC2.
Comment 1 Noel Power 2011-01-26 04:59:23 UTC
can't reproduce on opensuse 11.3
how are you shutting down, from the terminal ( or from the menu gnome or kde ?)

what happens when you try to shutdown, are there any informational messages ?

cc'ing kendy who probably know more relevant questions to ask
Comment 2 sherov 2011-01-26 12:02:31 UTC
(In reply to comment #1)

The problem appears when I press the Gnome "Log Out Button" and then select "Poweroff" from the pop-up menu - and then nothing happens. If I close the QuickStart and  then repeat the operation - it works. Btw, "sudo poweroff now" works in all cases.

I also noticed that the problem does not appear if I haven't worked with documents in LO during the session. But it appears every time after I've worked with Writer or Calc.
Comment 3 Noel Power 2011-01-27 02:42:03 UTC
Radek I think you worked some on session control stuff etc. with gnome do you have any ideas ( re-assign to the list etc. if I got the wrong guy )
Comment 4 dannyleconte 2011-12-27 11:54:19 UTC
You must edit the file "main.xcd" using the text editor nano as root (Debian):

nano -w /usr/lib/libreoffice/basis3.*/share/registry/main.xcd

Ctrl + W to start the search function and search "DocumentStoreUIEnabled"
Replace the value "true" to "false"
register : crtl + O (or F3)
reboot the system.

I hope that libreoffice correct this bug in the next version.
This bug is present since at least version 3.2 of OpenOffice.
Comment 5 dannyleconte 2011-12-27 11:55:06 UTC
You must edit the file "main.xcd" using the text editor nano as root (Debian):

nano -w /usr/lib/libreoffice/basis3.*/share/registry/main.xcd

Ctrl + W to start the search function and search "DocumentStoreUIEnabled"
Replace the value "true" to "false"
register : crtl + O (or F3)
reboot the system.

I hope that libreoffice correct this bug in the next version.
This bug is present since at least version 3.2 of OpenOffice.
Comment 6 Björn Michaelsen 2012-02-28 10:24:32 UTC

*** This bug has been marked as a duplicate of bug 34669 ***