Download it now!
Bug 33562 - Paste image crashes writer
Summary: Paste image crashes writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Windows (All)
: highest blocker
Assignee: Noel Power
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-26 16:33 UTC by Dan Essin
Modified: 2011-12-22 05:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Word 2010 file (40.49 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-01-27 16:55 UTC, Dan Essin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Essin 2011-01-26 16:33:52 UTC
Open an existing .docx
Copy an image from a .docx open with word 2010
Paste the image into Libre
App crashes

Problem is reproducible.

Also this attempt would not have been necessary except that the image that was in the original word 2010 .docx disappeared when the document was opened in Libre.
Comment 1 tester8 2011-01-27 04:09:32 UTC
Please attache the problem document.
Comment 2 Noel Power 2011-01-27 04:24:34 UTC
(In reply to comment #0)
> Open an existing .docx
> Copy an image from a .docx open with word 2010
> Paste the image into Libre
> App crashes
can we have a copy of a test document containing problematic images please ? 
>
 
> Also this attempt would not have been necessary except that the image that was
> in the original word 2010 .docx disappeared when the document was opened in
> Libre.
that sounds like a different issue, could you open a separate bug for that please
Comment 3 Dan Essin 2011-01-27 16:55:46 UTC
Created attachment 42622 [details]
Word 2010 file

This document has an image and a text box at the top. When opened in Libre, the picture does not appear and the text box is empty.

Attempting to paste the picture causes Libre to crash.
Comment 4 Zack 2011-02-18 12:07:18 UTC
I can reproduce the second half of the OP's concern, but not the part that crashes writer.  I see other bugs are already open which address missing images in .docx files.
Comment 5 Katarina Behrens 2011-02-23 00:34:23 UTC
Noel, will you take over this one ? (mark as duplicate, if necessary)
Comment 6 gooly 2011-02-23 00:54:15 UTC
Seems to be a problem of all Libre-Offiversion:
Bug 32930, Bug 33562, Bug 32737, Bug 34290
Comment 7 Noel Power 2011-02-23 03:04:01 UTC
(In reply to comment #6)
> Seems to be a problem of all Libre-Offiversion:
> Bug 32930, Bug 33562, Bug 32737, Bug 34290

why do you think this is related? please don't pollute existing bugs just because they seem to have the same keywords eg. 'Paste' & 'Crash' The bugs you mention look like they are completely unrelated to this issue.
Comment 8 Noel Power 2011-02-23 03:13:33 UTC
btw the image now imports on master so probably the fix associated with issue #34305 Additionally as mentioned in there textbox docx import just isn't ( afaics ) implemented. Please open a separate issue for that. Regarding the crash still I can't reproduce that. The steps I am taking are

a) open libreoffice
b) opened the docx attached to the issue in word 2010
c) copy the image from the top of the first page
d) open a new writer doc in libreoffice
e) paste into doc ( via menu )

sorry result no crash unfortunately
so.. did I miss some step, am I doing something differently than you? 
some extra info might also be useful
what exact os are you using xp, vista etc. Do you have any extra extensions installed 
The more details the better :-)
Comment 9 Noel Power 2011-02-23 03:49:36 UTC
aha, I actually was testing against a master build, testing against 3.3.0 also works with the steps above BUT if you use cntrl-v to paste is seems to crash. But.. this is not the behaviour I observe with the master build. Need to quickly test with 3.3.1 ( which is just out ) to see if it still crashes with that
Comment 10 Noel Power 2011-02-23 04:10:02 UTC
works for me with 3.3.1 pasting with no crash. 
@Dan can you try with 3.3.1 ( note: you wont see the images with 3.3.1 docx import either )
Comment 11 Cédric Bosdonnat 2011-03-03 01:22:06 UTC
closing as worksforme according to Noel's comments
Comment 12 Björn Michaelsen 2011-12-22 05:37:23 UTC
Remove infoprovider from closed and resolved bugs.
Comment 13 Björn Michaelsen 2011-12-22 05:51:44 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.