Download it now!
Bug 33604 - "Clear formatting" fails to remove hyperlinks
Summary: "Clear formatting" fails to remove hyperlinks
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2011-01-27 09:30 UTC by davescafe
Modified: 2017-09-06 20:40 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davescafe 2011-01-27 09:30:04 UTC
The "Clear formatting" style-selection option does not remove hyperlinks. This is the case whether "Clear formatting" is selected from the style selection window, or whether the hotkey combination "<Ctrl> m" is pressed.

Formatting containing hyperlinks is not cleared unless the user manually removes them (e.g. right-click on the link and select, "Remove hyperlink"


Steps to Reproduce:
1. Open LibreOffice Writer
2. Copy-and-paste a paragraph containing hyperlinks from somewhere on the Internet (e.g. slashdot.org) into the Writer document.
3. Select the entire paragraph by pressing "<Ctrl> a"
4. Attempt to clear formatting by pressing "<Ctrl> m" or selecting "Clear formatting" from the drop-down list in the styles selection window.

Results:
Italic formatting is cleared, but not hyperlinks.

Expected behavior:
Hyperlinks will be removed along with other formatting.
Comment 1 Jorendc 2011-01-27 14:19:16 UTC
Reproduced in Mac OS X, LibreOffice 3.3.
Comment 2 Cédric Bosdonnat 2011-01-28 00:24:47 UTC
this is not a bug, but a behaviour. "Clear Formatting" resets all direct formatting to keep only the styles. To remove hyperlinks you need to select text containing the link(s) and use "Remove Hyperlink" in the context menu (right click)
Comment 3 davescafe 2011-01-28 07:27:47 UTC
I am disappointed to hear that this is a "feature." This functionality is inconsistant with OpenOffice and MS Office. I frequently copy-and-paste blocks of text with many hyperlinks into Writer documents. Tight-clicking to remove all the hyperlinks is not practical and is a step backwards for LibreOffice. I suppose I could paste the hyperlinked-text into an interm text editor like Notepad that does not allow hyperlinks, and then copy-and-paste it from Notepad into LibreOffice. This is a klugy work-around, though, for something that was working just fine in OOo.
Comment 4 ign_christian 2013-05-13 03:18:43 UTC
I think "Clear Direct Formatting" option (Ctrl-M) on Writer is differ from what on Calc. 
Because on Calc that option will remove hyperlink.

See Bug 62561