Bug Hunting Session
Bug 33639 - doesn't remember duplex settings if modifying with LO-windows
Summary: doesn't remember duplex settings if modifying with LO-windows
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: NeedsDuplexPrinter
Keywords:
Depends on:
Blocks: Printer-Settings
  Show dependency treegraph
 
Reported: 2011-01-28 02:46 UTC by Paolo Benvenuto
Modified: 2015-01-28 01:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2011-01-28 02:46:00 UTC
Suppose you print a document with duplex short edge setting.

If you print it again, you expect libreoffice remember the duplex setting.

It should remember the setting even when the document is closed and opened again.
Comment 1 cgaj 2011-08-25 12:15:33 UTC
I have this in LibO 3.3.3 & Ubuntu 11.04.

Some details here:
http://user.services.openoffice.org/en/forum/viewtopic.php?f=101&t=43438
Comment 2 Björn Michaelsen 2011-12-23 11:49:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Jim Lellman 2012-05-17 07:25:30 UTC
file>printer settings settings are still not working on the 3.5.3.2 release.
Comment 4 Paolo Benvenuto 2012-10-18 08:46:39 UTC
3.6.0 ubuntu ppa

actually the duplex setting is preserved if after setting it and printing I modify something and save the document; saving without modifying has no effect: LO isn't aware of a change.

The setting is lost if my document saved from linux is opened and saved with LO-windows: in this case duplex settings are reset, while the setting about inclusion of all/right/left pages isn't reset.

Apparently
Comment 5 Paolo Benvenuto 2012-10-18 08:48:04 UTC
Apparently the solution of the linux-windows-linux issue is simple: it seems that treating the duplex setting as the inclusion one is enough.
Comment 6 Jim Lellman 2012-10-24 15:17:26 UTC
Appears to be fixed in LibreOffice 3.6.1.2 on Windows.
Comment 7 Paolo Benvenuto 2013-05-16 18:02:50 UTC
still present in 4.0
Comment 8 Paolo Benvenuto 2013-05-16 18:04:29 UTC
present in 4.0 on linux.

If I prepare and print a doc on 4.0-linux, I pass it to a 4.0-windows LO which modifies it, and it comes back to me, setting is lost
Comment 9 Paolo Benvenuto 2013-05-16 18:04:53 UTC
apparently 4.0-windows is loosing info
Comment 10 Joel Madero 2013-10-08 00:10:23 UTC
I'm seeing the problem as well - I think there are several duplicates out there, I'm going to try to round them up and prioritize this accordingly


Ubuntu 13.04
LibreOffice 4.1.1.2 release and 4.0.6.1 rc
Comment 11 Joel Madero 2013-10-08 00:11:34 UTC
and of course now I can't reproduce it :-/ sorry for the noise, going to do some testing
Comment 12 Robinson Tryon (qubit) 2013-10-29 17:13:26 UTC
Whiteboard: NeedsDuplexPrinter
Comment 13 tommy27 2014-10-31 06:02:41 UTC
please retest with current LibO 4.3.3.2 and give an update of the bug status.
moreover tell us the exact model and brand of the affected printers.

please also take a look at:
Bug 67449 - PRINTING: Printer Settings - Double Sided - Do not stay selected (HP printers)

and tell if it's the same issue.
Comment 14 Warren Young 2014-11-22 01:20:48 UTC
This issue also affects OS X. I just upgraded to 4.3.4.1 -- latest released version as I write this -- and it's still doing it.

On OS X, the "Two-Sided" setting is independent of the printer settings.
Comment 15 Matthew Francis 2015-01-28 01:59:25 UTC
With respect to the originally reported issue in comment 0, as updated in comment 4:

Linux and Windows have entirely different printing systems, and the document specific printer settings are stored in a system-specific way. Unfortunately there's no reasonable way to deal with this - even if it's the "same" printer, it's not practical to convert between the settings expected by the two different printing systems.

-> RESOLVED WONTFIX