Download it now!
Bug 33713 - FORMATTING, FILEOPEN: Spacing above and below paragraph (.lwp)
Summary: FORMATTING, FILEOPEN: Spacing above and below paragraph (.lwp)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: LWP
  Show dependency treegraph
 
Reported: 2011-01-30 04:16 UTC by Jaxson Lee
Modified: 2019-10-08 02:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
.lwp '97 format document containing examples of paragraph spacing (23.11 KB, application/vnd.lotus-wordpro)
2011-01-30 04:16 UTC, Jaxson Lee
Details
PDF showing Lotus Word Pro '97 and LibreOffice Writer 3.3 handling of sample document (222.66 KB, application/pdf)
2011-01-30 04:17 UTC, Jaxson Lee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaxson Lee 2011-01-30 04:16:37 UTC
Created attachment 42715 [details]
.lwp '97 format document containing examples of paragraph spacing

Currently, the Lotus Word Pro import filter doesn't handle Paragraph Spacing. This would be equivalent to the information contained in <style:paragraph-properties fo:margin-top="x" fo:margin-bottom="y"/> in the .odt format.

Word Pro allows these to be set in terms of # of lines (1/2 line, 1 whole line, multiple lines) as well as custom spacings (measured in cm/points/picas). I'm not sure how these are stored internally in the .lwp format.

I've attached a sample document containing a range of different paragraph spacings, and a .pdf which provides a comparison between LWP '97 and LibO 3.3 handling of this sample document at the moment.
Comment 1 Jaxson Lee 2011-01-30 04:17:34 UTC
Created attachment 42716 [details]
PDF showing  Lotus Word Pro '97 and LibreOffice Writer 3.3 handling of sample document
Comment 2 Björn Michaelsen 2011-12-23 11:49:34 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:02:05 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:03:06 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:07:40 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:09:46 UTC Comment hidden (obsolete)
Comment 7 sasha.libreoffice 2012-08-24 05:48:45 UTC
Nobody tested yet. Changing to Unconfirmed
Comment 8 Jaxson Lee 2012-08-27 12:22:08 UTC
Paragraph spacing still doesn't happen in Writer 3.6
Comment 9 Owen Genat (retired) 2014-07-26 10:32:45 UTC
Not sure why this bug is set as an enhancement when related bug 33787 and bug 33838 are not. Severity set to normal. Import of the content in the provided example has regressed since the originally reported v3.3. All versions I have tested (3.5.7.2, 4.1.6.2, 4.2.5.2, 4.3.0.3, and 4.4.0.0alpha+) now only import unformatted text.
Comment 10 QA Administrators 2015-09-04 02:48:15 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2015-11-18 11:59:42 UTC
Yeah, unformatted text imported.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 12 roderich_mattmueller 2016-10-04 16:03:19 UTC
Compared to an older version of the OpenOffice Writer, there is a new function in the format paragraph dialogue (Format / Absatz). This is the option "No spaces between paragraphs using the same format pattern" or so - I do not know the English expression while working with the German version.

Perhaps this is a function that I proposed to the OpenOffice Project some years ago. In this case my proposition is misunderstood; the actual option has no real or senseful application. This is the bug.

My proposition was different:
The space above a heading paragraph is always correct after a text block. Like this:
---
2.1 ADVANTAGES OF LIBREOFFICE

The following advantages of ...



2.2 BUGS IN LIBREOFFICE

A list of bugs ...
---
But in the case of two heading paragraphs of different hierarchy, following directly one to the other, the space makes no sense and the layout looks badly. Like this:
---
1 The LIBREOFFICE HANDBOOK



1.1 INTRODUCTION

What I want to tell ...
---
This is no good formatting. But by suppressing the linespace above(!) a heading paragraph that is preceeded by annother heading paragraph of higher hierarchy we get something like this:
---
1 The LIBREOFFICE HANDBOOK


1.1 INTRODUCTION

What I want to tell ...
---
This means that in the case of lacking text belonging directly to the heading of the higher rank, You only get the space that is defined to come below(!) the first (higher) heading and not the space that normally is set above the second heading. This should render a better layout and this should be the sense of this option.
Comment 13 QA Administrators 2018-09-25 02:51:06 UTC Comment hidden (obsolete)
Comment 14 Christian Pietzsch 2018-10-07 14:59:34 UTC
Paragraphing still doesn"t work in:

Version: 6.1.0.3
Build ID: 6.1.0-2
CPU threads: 12; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: de-DE (en_US.UTF-8); Calc: group threaded
Comment 15 QA Administrators 2019-10-08 02:28:21 UTC
Dear Jaxson Lee,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug