Download it now!
Bug 33860 - Impress inserted video does not play
Summary: Impress inserted video does not play
Status: RESOLVED DUPLICATE of bug 32581
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-02 21:15 UTC by Christopher M. Penalver
Modified: 2011-02-04 20:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-02-02 21:15:23 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262

1) HOST:

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

GUEST:

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

2) HOST:

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.0-1maverick1
  Candidate: 1:3.3.0-1maverick1
  Version table:
 *** 1:3.3.0-1maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy totem
totem:
  Installed: 2.32.0-0ubuntu1
  Candidate: 2.32.0-0ubuntu1
  Version table:
 *** 2.32.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

 apt-cache policy virt-manager
virt-manager:
  Installed: 0.8.4-7ubuntu1.1
  Candidate: 0.8.4-7ubuntu1.1
  Version table:
 *** 0.8.4-7ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.8.4-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

GUEST:

apt-cache policy openoffice.org-impress
openoffice.org-impress:
  Installed: 1:3.2.1-7ubuntu1
  Candidate: 1:3.2.1-7ubuntu1
  Version table:
     1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one embeds a video file into a blank Impress file, or opens an Impress file with video in it via openoffice.org-impress or libreoffice-impress ( sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-impress ) via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250365/+files/test.odp && soffice -impress test.odp && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/172262/+attachment/250368/+files/instalacia.ogg && totem instalacia.ogg

it shows the first frame of the embedded video in openoffice.org-impress or libreoffice-impress, plays the video in editing mode, and plays the video in Slide Show, just as it does in totem.

4) What happens instead is that in openoffice.org-impress or libreoffice-impress you see a grey rectangle where the video file is supposed to be, clicking the play button in the right-hand pane does not play the video, nor does clicking Slide Show -> Slide Show. The embedded video file plays fine in totem.
Comment 1 NoOp 2011-02-03 09:21:09 UTC
Cannot reproduce, test.odp works for me. Note that instalacia.ogg must be in the same folder as test.odp to work properly.

$ cat /opt/libreoffice/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m19(Build:6)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=6
ProductMajor=330
ProductMinor=19
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

2.6.35-26-generic #46-Ubuntu SMP Sun Jan 30 08:10:51 UTC 2011 i686 GNU/Linux

I also cannot reproduce on Ubuntu's OOo:
$ cat /usr/lib/openoffice/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1.1
buildid=320m19(Build:9505)
ExtensionUpdateURL=http://updateext.services.openoffice.org/ProductUpdateService/check.Update
OOOBaseVersion=3.2
ProductBuildid=9505
ProductMajor=320
ProductMinor=19
ProductSource=OOO320
UpdateID=OpenOffice.org_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=Debian and Ubuntu
$ apt-cache policy openoffice.org-impress
openoffice.org-impress:
  Installed: 1:3.2.1-7ubuntu1.1
  Candidate: 1:3.2.1-7ubuntu1.1
  Version table:
 *** 1:3.2.1-7ubuntu1.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ maverick-security/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

@cp9650: you are using a PPA version of LibreOffice (500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386), please file a bug against that PPA version.
Comment 2 Christopher M. Penalver 2011-02-03 14:45:55 UTC
WORKAROUND: Keep inserted video files in the same directory as the Impress file or manually update each inserted video file via Edit -> Links.

This applies to both libreoffice-impress & openoffice.org-impress.

Changing Importance from Major to Minor as easy workaround exists.
Comment 3 Christopher M. Penalver 2011-02-03 20:05:52 UTC
Marking to Enhancement, as this is a request to embed media within a libreoffice-impress file and/or have all inserted media files move automatically when the impress file is moved to another location.
Comment 4 Christopher M. Penalver 2011-02-04 20:44:23 UTC

*** This bug has been marked as a duplicate of bug 32581 ***