Bug 33861 - PRINTING - Print driver dialog does not remember previous settings
Summary: PRINTING - Print driver dialog does not remember previous settings
Status: RESOLVED DUPLICATE of bug 33245
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-02 21:49 UTC by Chuck Evans
Modified: 2011-05-24 04:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Evans 2011-02-02 21:49:17 UTC
This is a several part problem involving the print dialog in Writer.

First problem is that the settings chosen in the print driver dialog are not remembered within the same document when printing a second or third time.  This means that the settings must be re-chosen each time.

This problem occurs on both my x86_64 Linux system (Mandriva 2010.2) and on my 32 bit Windows XP SP3 system.  Second Problem, on the Windows system I have a networked HP Laserjet printer that is capable of printing double sided, and even though I select single sided output I still get double sided.
Comment 1 Muthu 2011-02-02 23:41:32 UTC
Are you sure this is not a problem with the printer driver? Generally the printer driver dialog is displayed by the printer drivers. Have you tried setting default settings for your printer and checking?
Comment 2 joe 2011-03-04 17:49:31 UTC
I can confirm this. This is a big pain since I have to keep specifying special page sizes and options each time I print special documents (which is a lot). OOO 3.1 didn't have this problem. This is on WinXP.
Comment 3 Oblong 2011-03-24 22:53:12 UTC
Confirmed for both Writer and Draw.

Windows XP Home.

LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2

It is possible to change the printer settings:

File|Printer Settings...|Properties and change settings (eg, in my case, I can change to CD tray output etc). Those settings are remembered.

However, then doing:

File|Print...|(correct printer is selected)|Properties

does not use those settings previously set in "Printer Settings...".

Even if the properties are changed in File|Print|Properties they are not remembered even in the same session.
Comment 4 Oblong 2011-03-25 02:07:01 UTC
Workaround (tested only with Windows XP):

Create another printer instance in the Control Panel, setting the printer properties there. Then, in the document, chose that printer. The proper printer properties will then be used.

Additional comments: This problem does not occur in OpenOffice 3.2.1, but the same bug appears in OpenOffice 3.3.0 (yes, I know this is for LO bugs).
Comment 5 Jaap Stolk 2011-05-24 04:29:21 UTC
I have a similar problem with landscape/portrait selection.
I found 4 bug reports (33245,33861,36591,37064) witch all seem to be a result of the printer-dialogue loosing it's settings, So I marked the last 3 as duplicates of the first one.
Also, my problem seems to be fixed in the current Beta release (LibreOffice 3.4.0 DEV300m103 (Build:5) Windows XP 32-bit), so please check if this is still a problem in the latest beta release.

*** This bug has been marked as a duplicate of bug 33245 ***