Bug Hunting Session
Bug 33869 - FILEOPEN particular .xlsx: OLE object not shown
Summary: FILEOPEN particular .xlsx: OLE object not shown
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: (target:3.4.4)
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-03 03:12 UTC by Aurimas Fišeras
Modified: 2012-08-14 08:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
OLE picture not shown (22.42 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2011-02-03 03:12 UTC, Aurimas Fišeras
Details
File opened in OOo 3.2.1 (27.71 KB, image/png)
2011-02-03 03:13 UTC, Aurimas Fišeras
Details
File opened in OOo 3.3.0 (25.55 KB, image/png)
2011-02-03 03:13 UTC, Aurimas Fišeras
Details
File opened in LibO 3.3.0 (22.14 KB, image/png)
2011-02-03 03:14 UTC, Aurimas Fišeras
Details
File opened in LibO 3.3.1rc1 (16.27 KB, image/png)
2011-02-12 00:26 UTC, Aurimas Fišeras
Details
File opened in LibO 3.3.1rc2 (14.53 KB, image/png)
2011-02-18 06:18 UTC, Aurimas Fišeras
Details
File opened in LibO 3.6.0 (19.18 KB, image/png)
2012-08-14 08:29 UTC, Aurimas Fišeras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aurimas Fišeras 2011-02-03 03:12:49 UTC
Created attachment 42891 [details]
OLE picture not shown

Opening attached xlsx file in LibO 3.3.0 (in Windows, Linux) shows OLE icon instead of the actual picture.

Opening the same file works in OOo 3.2.1, OOo 3.3.0, OOo 3.4 DEV.
Comment 1 Aurimas Fišeras 2011-02-03 03:13:27 UTC
Created attachment 42892 [details]
File opened in OOo 3.2.1
Comment 2 Aurimas Fišeras 2011-02-03 03:13:50 UTC
Created attachment 42893 [details]
File opened in OOo 3.3.0
Comment 3 Aurimas Fišeras 2011-02-03 03:14:59 UTC
Created attachment 42894 [details]
File opened in LibO 3.3.0
Comment 4 Rainer Bielefeld Retired 2011-02-03 04:18:14 UTC
[Reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]"

The ole  object seems to be some kind of Text document containing an .EMF image. Double click on placeholder in sample document shows new WRITER document with "image1.emf".

I doubt that it's a CALC problem. When I copy /paste the object from OOo3.4-dev CALC to OOo3.4-dev DRAW, the OLE object will look as in LibO (placeholder only), and in LibO Draw the new DRAW document also will only be shown as a placeholder.

@Aurimas Fišeras:
What OS did you use for your test?
Any Idea what kind of OLE object tht might be (created with ...)?
Comment 5 Aurimas Fišeras 2011-02-03 04:42:28 UTC
(In reply to comment #4)
> @Aurimas Fišeras:
> What OS did you use for your test?
> Any Idea what kind of OLE object tht might be (created with ...)?

Document was created with Office 2007. OLE object is a Word document in which a picture is composed from shapes and text.
Comment 6 Aurimas Fišeras 2011-02-12 00:26:39 UTC
Created attachment 43283 [details]
File opened in LibO 3.3.1rc1

There is some improvement in LibO 3.3.1rc1. OLE icon is no longer shown.
However, rendered picture is incomplete - only text is shown, no borders or graphics.
Comment 7 Aurimas Fišeras 2011-02-18 06:18:44 UTC
Created attachment 43524 [details]
File opened in LibO 3.3.1rc2

With latest LibO (3.3.1 RC2) the picture is rendered almost the same as in OO. Now only top and left borders are rendered with a wrong color.
Comment 8 Björn Michaelsen 2011-12-23 11:51:52 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 9 Aurimas Fišeras 2011-12-24 01:38:19 UTC
This bug is fixed in 3.4.4, 3.5.0 beta1.
Comment 10 Aurimas Fišeras 2012-08-14 08:22:08 UTC
Regressed in LibO 3.6.0.

Picture was shown correctly in LibO 3.5.5.3
Comment 11 Aurimas Fišeras 2012-08-14 08:29:07 UTC
Created attachment 65531 [details]
File opened in LibO 3.6.0
Comment 12 Rainer Bielefeld Retired 2012-08-14 08:58:29 UTC
NOT reproducible with Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit) 

<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>
Target due to Comment 9
The bug never was FIXED, but WFM.
I will Submit a new Bug for the new problem and add reporter to CC