Download it now!
Bug 33914 - Presenter-Console duplicates (echoes) sound in video
Summary: Presenter-Console duplicates (echoes) sound in video
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: David Tardon
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords:
: 35507 40074 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-02-04 12:27 UTC by Andor Kiss
Modified: 2012-04-17 03:06 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Audio of BROKEN audio in Impress (574.21 KB, video/ogg)
2012-04-04 06:40 UTC, Andor Kiss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andor Kiss 2011-02-04 12:27:19 UTC
This bug was supposed to be fixed in OO 3.3 and has existed in OO since 3.2 rc1.

Sound is duplicated in embedded video when played using presenter-console.  Sound is played from BOTH the main screen and the preview screen.  This is terrible.


WHY CAN'T THIS BUG THAT'S BEEN AROUND FOR TWO YEARS BE FIXED ALREADY?

This make impress useless for laptop based presentations.

- CH
Comment 1 Andor Kiss 2011-02-09 20:34:12 UTC
Ok,

I've done some evaluation.

OO 3.3 and presenter-console 1.1.0 does not have this bug.

It seems that this bug is in LO 3.3 + p-c 1.1.0.

Perhaps it was introduced during the application of the GO-OO patches?

Let me know if I can help (sorry about the freak out tone of the previous post)

Current workaround is to uninstall presenter-console on Ubuntu 10.04.1
Comment 2 James King 2011-03-01 09:31:32 UTC
I experienced this bug as well with Ubuntu 10.10, LibreOffice 3.3.1, and LibreOffice presenter-console 1.1

Any embedded video will have sound repeated one second later. Sound that is present as actions attached to images is not echoed in the same fashion.

If there were a way to turn off the sound on the video in the presenter console, that would be an acceptable fix.

As it is, I can only use the presenter console whenever I do not have any embedded videos, which is unacceptable to me.
Comment 3 Vincent Mabillot 2011-11-29 08:39:49 UTC
I had duplicate this bug too.

When using presenter, LibreOffice seems to open to "application" and each one read his own sound stream.

I can stop the echo when using presenter I coould swap to audio sound controller and mute one of the two streams. But the stream channel appears only if a slide needs to stream sound. So you have to jump to your computer and swap to audio controller... It's not a real solution, but I hope it could help you to kill this unconfortable bug.
Comment 4 Vincent Mabillot 2011-11-29 08:44:24 UTC
*** Bug 35507 has been marked as a duplicate of this bug. ***
Comment 5 Vincent Mabillot 2011-11-29 08:45:25 UTC
*** Bug 40074 has been marked as a duplicate of this bug. ***
Comment 6 Björn Michaelsen 2011-12-23 11:46:44 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 mark 2012-01-16 01:18:04 UTC
Confirming this bug still exists on Linux with lodev-3.5.0 beta2.
Comment 8 Caolán McNamara 2012-04-03 14:17:53 UTC
I thought we fixed this a gadzillion years ago, i.e. https://issues.apache.org/ooo/show_bug.cgi?id=98806
Comment 9 Not Assigned 2012-04-04 05:29:07 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4b8a1c9f50bca3b557efca75100d9532a404ec6

fdo#33914 do not play sound in presenter console
Comment 10 Andor Kiss 2012-04-04 06:40:25 UTC
Created attachment 59473 [details]
Audio of BROKEN audio in Impress

This is NOT fixed.  This has been broken for F O U R  years.  On several different machines, different audio cards, different GPUs.  I will say the echo is getting closer and closer.  In about 12 years the echo will occur at the same time as the original sound, so might be a problem then  ;-)
Comment 11 David Tardon 2012-04-04 07:53:48 UTC
(In reply to comment #10)
> This is NOT fixed.

How do you know? Have you tried the patch?

> This has been broken for F O U R  years.

It was fixed in OO.o more than 3 years ago and quickly broken again by fix for another bug. It should be more future-proof now.
Comment 12 James King 2012-04-04 16:08:05 UTC

(In reply to comment #11)
> (In reply to comment #10)
> > This is NOT fixed.
> 
> How do you know? Have you tried the patch?
> 
> > This has been broken for F O U R  years.
> 
> It was fixed in OO.o more than 3 years ago and quickly broken again by fix for
> another bug. It should be more future-proof now.

David, how do I apply the patch to determine if it works? I don't see any sort of "installer" for the patch.

If I am the only person who does not know how to apply a patch to the software, then I apologize, but if I am not, then it's not really fixed for me. It's like telling me, "The problem with the car was the transaxle gear. Here's a new one, just install it and the car will be fixed." Unless I know how to install the transaxle gear, or pay someone to do it, the car isn't fixed. At the moment, LibreOffice is the same way.

I am using Lubuntu 11.10 and LibreOffice 3.5.1.2 at the moment. Please direct me to some step-by-step instructions so that I can install the patch and test it.
Comment 13 David Tardon 2012-04-04 22:36:35 UTC
(In reply to comment #12)
> 
> (In reply to comment #11)
> > (In reply to comment #10)
> > > This is NOT fixed.
> > 
> > How do you know? Have you tried the patch?
> > 
> > > This has been broken for F O U R  years.
> > 
> > It was fixed in OO.o more than 3 years ago and quickly broken again by fix for
> > another bug. It should be more future-proof now.
> 
> David, how do I apply the patch to determine if it works? I don't see any sort
> of "installer" for the patch.

Sorry, but that was just a rant evoked by the tone of comment 10. By patch I meant the commit to master referenced in comment 9. It is not "installable" in any way--you would have to build libreoffice from git for yourself.

Bugzilla is primarily a tool for developers. If I set status to RESOLVED/FIXED, it means that I think it has been fixed, not that the fix is available in any current release.

> I am using Lubuntu 11.10 and LibreOffice 3.5.1.2 at the moment. Please direct
> me to some step-by-step instructions so that I can install the patch and test
> it.

You could try a nigtly build, e.g., from http://dev-builds.libreoffice.org/daily/Linux-x86_64_11-Release_Configuration/master/2012-04-04_11.33.29/ .
Comment 14 Andor Kiss 2012-04-05 03:26:30 UTC
How do I apply the patch?
Comment 15 Cor Nouws 2012-04-15 03:48:50 UTC
(In reply to comment #14)
> How do I apply the patch?

Download the code and build it...
Maybe it's simpeler to download a daily build:
  http://dev-builds.libreoffice.org/daily/
Comment 16 Cor Nouws 2012-04-15 16:45:05 UTC
(In reply to comment #9)
> David Tardon committed a patch related to this issue.
> It has been pushed to "master":

checked in daily build from 2010-04-10 > OK, thanks!
Comment 17 Not Assigned 2012-04-17 02:02:51 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=badc3a329d5b6819e3e15ed7faf77c0e2861b076&g=libreoffice-3-5

fdo#33914 do not play sound in presenter console


It will be available in LibreOffice 3.5.3.
Comment 18 Cor Nouws 2012-04-17 03:06:21 UTC
(In reply to comment #17)
> It has been pushed to "libreoffice-3-5":

Oh, studip from me that I only checked in master.
Good that you was awake ;-)