Download it now!
Bug 33951 - Calc: Comment text defined as hyperlink doesn't display on mouseover.
Summary: Calc: Comment text defined as hyperlink doesn't display on mouseover.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks: Calc-Comments Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2011-02-05 15:42 UTC by Randy
Modified: 2019-03-24 06:28 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
example spreadsheet created in LibO Calc 4.1.0.4 (9.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-15 10:20 UTC, Christophe Strobbe
Details
Image of Issue (57.29 KB, image/png)
2018-03-27 01:27 UTC, gat
Details
bt from Got UndoManager back in SdrEndTextEdit... (6.62 KB, text/plain)
2018-03-30 17:10 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Randy 2011-02-05 15:42:53 UTC
When creating a comment for a spreadsheet cell text in the comment that is defined as a hyperlink does not display in the comment box on mouseover.  To recreate the problem perform the following:

* Right-click and select Insert Comment.

* When the empty comment box is displayed for editing, choose Insert-Hyperlink from the main menu bar. 

* After the Hyperlink window is displayed, specify the Web Target URL, the text to be displayed as the comment, and then click Apply and Close to complete the new comment.

* Click on any other cell in the spreadsheet.

* Mouseover the commented cell to display the comment.

And here's the problem: the comment box is displayed but not the comment text; however, right-clicking and choosing Show Comment, successfully displays the comment text, which correctly functions as a hyperlink.  Note that if the comment contains both normal text and hyperlink text, the normal text displays just fine, but, as before, not the hyperlink text.
Comment 1 Katarina Behrens 2011-02-23 02:29:00 UTC
Taking this one
Comment 2 Christophe Strobbe 2011-08-12 06:17:57 UTC
I reproduced this issue in LibreOffice 3.3.1 (OOO330m19, build:8) on Windows XP, so it is not a Linux-only issue.

In addition to the comment box appearing empty on hover, the comment is also represented as a gap in the Navigator.

To reproduce the issue:
* Right-click on a cell and select "Insert comment".
* Paste a URL (e.g. http://www.example.com/) and press the spacebar after the URL, so the URL becomes a hyperlink.
* Press F5 to open the Navigator and expand the list "Comments": the comment with the hyperlink is not visible. (The issue is easier to spot when you have a few normal comments in cells before and after the cell with the hyperlink comment.)
Comment 3 Aurimas Fišeras 2012-04-08 09:59:27 UTC
Still a problem in 3.6. Also reproducible in 3.5.2 on Windows.
Comment 4 bfoman (inactive) 2013-08-14 21:50:15 UTC
(In reply to comment #1)
> Taking this one

This bug has not been touched by its Assignee for a long time. To make it clearer which bugs should be fixed by someone else please take following action:
- If you are the Assignee, and you are actively working on the bug, please give it an update. 
- If you are the Assignee, and you do not plan to work on it in the near future,
please reassign it to the default assignee.
Comment 5 retired 2013-08-15 09:27:45 UTC
Resetting assignee. Thinks thats an ok move after 2 years.

Randy: Could you provide an example document? That would make testing much easier and speed up the process of getting this fixed a lot.

Also can anybody confirm this bug is still persisting in LO 4.1.1.1? http://www.libreoffice.org/download/pre-releases/
Comment 6 Christophe Strobbe 2013-08-15 10:20:27 UTC
Created attachment 84094 [details]
example spreadsheet created in LibO Calc 4.1.0.4

I uploaded a test file in LibreOffice Calc 4.1.0.4. It contains three comments:
1. A comment containing only a link.
2. A comment containing normal text.
3. A comment containing a link followed by normal text.

The links are not visible, neither in the comments themselves, nor in the Navigator.
Comment 7 Randy 2013-08-15 12:21:33 UTC
Thanks for the example document, Christophe.  As you indicated, the problem persists in 4.1.0.4.
Comment 8 Commit Notification 2014-03-01 15:24:16 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63308b1e6c5fe3450783e589df8bd588fb4ceb3e

fix OOXML validation issue, related fdo#33951



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Joel Madero 2015-05-02 15:43:20 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2015-06-21 11:07:12 UTC
Repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 11 Julien Nabet 2016-05-27 09:27:23 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 12 lorenzo.morin 2016-06-16 10:26:40 UTC
Still present in:

Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

LibreOffice Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: it-IT (it_IT)
OS: Windows 7 Home Premium SP1 x86

Versione: 5.2.0.0.beta2
Build ID: a83fc06803e11f27e95c809fdfacbbd0377ff7d0
Thread CPU: 4; Versione SO: Windows 6.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT)
OS: Windows 7 Home Premium SP1 x86
Comment 13 gat 2018-03-27 01:27:39 UTC
Created attachment 140897 [details]
Image of Issue

This is how the issue currently appears to  more easily let others see what the issue is.
Comment 14 gat 2018-03-27 02:11:02 UTC
Issue is still reproducible on OS X 10.11.6 with LibreOffice 6.0.1.1 & 6.0.2.1.

This persists when links are created in comments as text or buttons.

Hyperlinks are shown in the following conditions: edit & show.
Hyperlinks are not shown in the following conditions: mouse over, navigation pane (F5).
Comment 15 gat 2018-03-27 22:29:54 UTC
The issue seems to be that in Writer's comments containing a link that text of the URL is automatically added when the field for inputting text is blank. This behavior is not present in Calc.

It would appear that the user interface is in /core/cui/uiconfig/ui/hyperlinkdocpage.ui. That same interface is used in both Writer and Calc.

I think that https://opengrok.libreoffice.org/xref/core/sc/source/ui/vba/vbahyperlinks.cxx may be the file to edit. Could someone point me in the right direction?
Comment 16 Buovjaga 2018-03-28 17:09:39 UTC
(In reply to gat from comment #15)
> I think that
> https://opengrok.libreoffice.org/xref/core/sc/source/ui/vba/vbahyperlinks.
> cxx may be the file to edit. Could someone point me in the right direction?

I tried asking on IRC today. You could post to the development mailing list: https://wiki.documentfoundation.org/Development/Mailing_List
Comment 17 gat 2018-03-28 22:37:20 UTC
I tried the I.R.C. a couple of days. I sent an e-mail to the mentoring@. I'll try the mailing list in a day or two provided that I don't receive a reply to the e-mail.
Comment 18 Buovjaga 2018-03-29 05:55:27 UTC
(In reply to gat from comment #17)
> I tried the I.R.C. a couple of days. I sent an e-mail to the mentoring@.
> I'll try the mailing list in a day or two provided that I don't receive a
> reply to the e-mail.

Try the list right now: there is no mentor currently and even if there were, they most probably could not help you with a question as specific as that.
Comment 19 Jim Raykowski 2018-03-30 08:24:42 UTC
https://opengrok.libreoffice.org/xref/core/sc/source/ui/view/gridwin5.cxx

Set breakpoint at line 168 to catch postit display.
Comment 20 Julien Nabet 2018-03-30 17:00:52 UTC
On pc Debian x6-64 with master sources updated yesterday, I could reproduce this.
I don't know if it may help but before the break point suggested by Jim, I noticed these logs:
warn:legacy.osl:2806:2806:svx/source/svdraw/svdedxv.cxx:1395: Got UndoManager back in SdrEndTextEdit which is NOT the expected document UndoManager (!)
warn:legacy.osl:2806:2806:sfx2/source/control/shell.cxx:212: SfxShell::SetUndoManager: exchanging one non-NULL manager with another non-NULL manager? Suspicious!
Comment 21 Julien Nabet 2018-03-30 17:10:54 UTC
Created attachment 140984 [details]
bt from Got UndoManager back in SdrEndTextEdit...
Comment 22 gat 2018-03-30 18:29:40 UTC
if(pSdrUndoManager && dynamic_cast< SdrUndoManager* >(pOriginal) == pSdrUndoManager)

That is the if statement before the else statement svx/source/svdraw/svdedxv.cxx:1395: Got UndoManager back in SdrEndTextEdit which is NOT the expected document UndoManager (!).

I'll try to set the breakpoint, compile, and test to see whether I produce the same output about undo on tonight.
Comment 23 Jim Raykowski 2018-04-01 09:44:01 UTC
Here are some other places to look:

In postit.cxx ScNoteUtil::CreatTempCaption
https://opengrok.libreoffice.org/xref/core/sc/source/core/data/postit.cxx#1193

which leads to:

svdotext.cxx SdrTextObj::GetOutlinerParaObject()
https://opengrok.libreoffice.org/xref/core/svx/source/svdraw/svdotext.cxx#1420

In svdtext.hxx it states clas SdrText stores information about one text inside shape. 
https://opengrok.libreoffice.org/xref/core/include/svx/svdtext.hxx

Hope these help :)
Comment 24 elisa wise 2018-10-02 02:30:47 UTC Comment hidden (spam)