Bug 33954 - FILEOPEN .xls comment font color white in Calc but black in Excel
Summary: FILEOPEN .xls comment font color white in Calc but black in Excel
Status: RESOLVED DUPLICATE of bug 51300
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-05 18:12 UTC by Randy
Modified: 2013-04-26 12:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows how the comment is initially displayed in LibreCalc both by mouseover and Comment-Show; and, the same comment box with the background changed to gray to show the white text. (8.01 KB, image/png)
2011-02-05 18:12 UTC, Randy
Details
Sample Excel spreadsheed that demonstrates the problem (8.00 KB, application/vnd.ms-excel)
2011-06-21 22:00 UTC, Randy
Details
Small Excel file with invisible comments. (25.00 KB, application/vnd.ms-excel)
2012-09-17 18:00 UTC, Russell Almond
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Randy 2011-02-05 18:12:25 UTC
Created attachment 42982 [details]
Shows how the comment is initially displayed in LibreCalc both by mouseover and Comment-Show; and, the same comment box with the background changed to gray to show the white text.

When accessing Excel spreadsheets (.xls) created in a Mac OS-X environment with LibreCalc, all text in cell comments with the default color of black are changed to white, rendering the text virtually invisible given the near-white background color of comment boxes.

Attachment A shows how the comment is initially displayed in LibreCalc both by mouseover and Comment-Show; and, the same comment box with the background changed to gray to show the white text.

(Note that when I accessed the same comments using the spreadsheet product Gnumeric in my Ubuntu environment the comments displayed correctly.
Comment 1 Christopher M. Penalver 2011-06-21 11:57:23 UTC
Randy, could you please attach a file that demonstrates this problem?
Comment 2 Randy 2011-06-21 22:00:10 UTC
Created attachment 48265 [details]
Sample Excel spreadsheed that demonstrates the problem

The attached sample spreadsheet demonstrates the described problem.  The first cell in the example shows that the comment font color is correctly interpreted when the font color is explicitly defined, e.g., "Black".  The second cell shows the comment font color changed to white when the font color was defined as "Automatic" (black) in the Mac OS-X Excel environment.
Comment 3 Christopher M. Penalver 2011-06-21 22:45:37 UTC
Randy, this issue is confirmed in Ubuntu 11.04, 32-bit via the Terminal:

cd ~/Desktop && wget -c https://bugs.freedesktop.org/attachment.cgi?id=48265 -O example.xls && localc -nologo example.xls

notice the comments font color of cell A5 is white.

Open the same file in Excel 2003 and the font color is black.

lsb_release -rd
Description:	Ubuntu 11.04
Release:	11.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Microsoft Office Excel 2003 (11.5612.6505)
Comment 4 Björn Michaelsen 2011-12-23 11:48:21 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Christopher M. Penalver 2012-01-03 15:18:06 UTC
Unreproducible in:
LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002
Comment 6 Christopher M. Penalver 2012-06-19 04:58:28 UTC
a.jansons@gmail.com, please do not reopen bugs without providing a comment as to why. This issue is still unreproducible in:

lsb_release -rd
Description:	Ubuntu 12.04 LTS
Release:	12.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
Comment 7 Russell Almond 2012-09-17 17:58:58 UTC
I am still seeing this bug in

lsb_release -rd
Description:	Ubuntu 12.04.1 LTS
Release:	12.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.5.4-0ubuntu1.1
  Candidate: 1:3.5.4-0ubuntu1.1
  Version table:
 *** 1:3.5.4-0ubuntu1.1 0
        500 http://mirror.umd.edu/ubuntu/ precise-updates/main amd64 Packages
        500 http://mirror.umd.edu/ubuntu/ precise-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://mirror.umd.edu/ubuntu/ precise/main amd64 Packages

I'm attaching another example, this one was created with a MS-Windows version of Excel.
Comment 8 Russell Almond 2012-09-17 18:00:13 UTC
Created attachment 67292 [details]
Small Excel file with invisible comments.

Comments appear in white text and are not visible either with mousever or show comments.
Comment 9 Cédric Bosdonnat 2013-04-26 12:46:50 UTC

*** This bug has been marked as a duplicate of bug 51300 ***