Bug Hunting Session
Bug 33995 - Accessibility bug with keyboard
Summary: Accessibility bug with keyboard
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-07 10:05 UTC by Olivier Hallot
Modified: 2013-02-13 15:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2011-02-07 10:05:36 UTC
Hi,
After installing the acessibility tool "Java Access Bridge for Microsoft Windows Operating System 2.0.1" on a windows XP system, the zoom lens only works with the mouse and does not work with the keyboard.

Steps to reproduce
1) Install JAB for MSWindows 2.0.1, following the readme.txt of LibreOffice
2) Open LibreOffice 
3) activate the support to AT in Options - Accessibility
4) open a spreadsheet
5) open the lens (Start - programs - Accessoiries - acessibility - lens
6) type something in a cell.
7) move cursor with the keyboard

Results: the AT does not roll the lens with the keyboard. Only with the mouse.
Comment 1 Björn Michaelsen 2011-12-23 11:44:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 13:58:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 13:59:40 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:04:17 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:06:29 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Rainer Bielefeld Retired 2012-08-18 07:04:20 UTC
@Olivier
I did not find thementioned readme in parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 6900781]" (tinderbox: 2008R2@20, pull time 2012-08-14 09:27:23).

Can you add some hints concerning "Install JAB for MSWindows 2.0.1" so that I can try to reproduce the bug?
Comment 7 Rainer Bielefeld Retired 2012-08-18 07:18:29 UTC
An, found <http://wiki.documentfoundation.org/Accessibility>
Java Access Bridge 2.0.2
But no Idea what to do with it ...
Comment 8 V Stuart Foote 2012-08-19 17:02:21 UTC
Rainer,

The preferred way to install the Java Access Bridge seems to be using Jamal Mazrui's JWIN installer as the Oracle instructions are a bit muddled.

http://empowermentzone.com/JWin.htm

However, believe the OP's issue may not be with JAB and Java based accessibility tools, but rather with use of Microsoft Windows provided Magnifier features.

OP does not mention if they were using the commercial ZoomText Java Access Bridge based interface, but their description suggests they were only using the Windows native Magnifier.

As to cursor control of Windows Magnifier, I have to verify on an XP system, but the Start -> Accessories ->  Ease of Access -> Magnifier, Configuration - View,  Lens mode  at Windows 7 (with an Aero theme active) is a windows built in. Not a JAB extension.

At Windows 7 the "Lens" follows mouse movements in all applications.  But is also controlled by escaped cursor direction keys:

<ctrl><alt><up>
<ctrl><alt><right>
<ctrl><alt><ldown>
<ctrl><alt><left>

ref: http://windows.microsoft.com/en-us/Windows7/Keyboard-shortcuts

Close fdo#33995 as not a bug, and perhaps considere a "Lens" magnifier as an enhancement of LO Accessibility Tools as Java based AT are reworked to IAccessible2 ( fdo#39956 ).

Stuart