Bug 34000 - FORMATTING - Importing MS Word document losing footers
Summary: FORMATTING - Importing MS Word document losing footers
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on: 37013
  Show dependency treegraph
Reported: 2011-02-07 12:13 UTC by Robin
Modified: 2011-12-22 05:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

example doc file that has footers that won't save in LibreOffice. (30.00 KB, application/msword)
2011-02-07 12:13 UTC, Robin

Note You need to log in before you can comment on or make changes to this bug.
Description Robin 2011-02-07 12:13:49 UTC
Created attachment 43039 [details]
example doc file that has footers that won't save in LibreOffice.

While working on a document that has been edited by multiple people, I imported from doc and edited it.  Upon saving and re-opening the document, the footers and general formatting had changed.  I tried this multiple times with the same result.

I am uploading a shell document that was created from the *.doc file that I am having problems with.  

This problem is also occurs in OpenOffice as well.

This document, due to the various people working on it doesn't follow "Styles" as recommended but the footers should still work.

1.  Open the Footer error.doc file.
2.  Save as an odt file.
3.  Open the odt file and footers are not present and formatting has changed.
Comment 1 Rainer Bielefeld Retired 2011-02-07 21:08:05 UTC
I can not confirm that "the" footers disappear with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag]", but indeed, there seem to be some problems.

Saving sample document as .odt and reopening it, everything seems to be ok on the first page, but starting with Page 5 (Heading "Abstract"):
- Header
  -- distance to Text body has vanished
  -- height decreased
- Footer
  -- distance to Text body has vanished
  -- no contents
Comment 2 K.M. 2011-05-10 05:42:44 UTC
I can confirm Rainer's observations on Linux 32 bit

LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-

The attached file https://bugs.freedesktop.org/attachment.cgi?id=43039 does not contain contents in the header section, so the lost of contents in the header section is not show. But it is happening.

I oberserved that the header and footer section seem to be ok on the pages with style "Default".

Pages with style "Convert 1", "Convert 2", etc loose their header & footer content and other header & footer style information, like distance to body, borders, etc.
Comment 3 K.M. 2011-05-10 05:47:30 UTC
I guess this bug has something to do with https://bugs.freedesktop.org/show_bug.cgi?id=37013
Comment 4 Luboš Luňák 2011-05-11 08:17:15 UTC
I do not see a single difference between the .doc and .odt with current master. Can the problem be still reproduced using 3.4?
Comment 5 Robin 2011-05-13 10:00:16 UTC
I can only see 3.3.2 on the download page.  

I have installed 3.3.2 and the footers are partially there.  Data is missing from some footers.

I agree with Rainer's comments in Fedora 14, 64 bit.

I tested with the original document again and the problems are there as Rainer and karlsen-masur have stated it with missing data in the footer.

With 3.3.2, I have tried saving various documents and I still lose all the date in the footer on pages 5 to the end of the test document.

I will try 3.4 when I find it.  :)
Comment 6 K.M. 2011-05-15 23:56:00 UTC
@ Robin:

Goto: Download-> Pre-Releases

Comment 7 Rainer Bielefeld Retired 2011-05-16 00:37:56 UTC
A rapid test: everything seems ok with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:5)]". Might have been fixed with fix for "Bug 37013 - FILESAVE - Saving in DOC format loses all styles"?
Comment 8 Robin 2011-05-20 10:49:06 UTC
I have just tested the latest beta with both the test and original documents.

As far as I can tell, the footer issue is resolved and things work as expected with the latest beta.

I agree that this bug is fixed in the latest beta.

Pats on the back to all involved in fixing this.
Comment 9 Rainer Bielefeld Retired 2011-05-25 22:31:06 UTC
No patch reference available
Comment 10 Björn Michaelsen 2011-12-22 05:52:45 UTC