Download it now!
Bug 34147 - Writer FILESAVE: "First page" style created by Writer lose the page style
Summary: Writer FILESAVE: "First page" style created by Writer lose the page style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2011-02-10 11:02 UTC by Bruno Lambert
Modified: 2013-10-25 11:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file before losing header (19.00 KB, application/msword)
2011-02-10 11:03 UTC, Bruno Lambert
Details
file after losing header (10.50 KB, application/msword)
2011-02-10 11:03 UTC, Bruno Lambert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Lambert 2011-02-10 11:02:32 UTC
I have tested on:

* OpenOffice 3.2.1 in Windows XP 32bits
* LibreOffice 3.3 final on Windows 7 64bits
* LibreOffice 3.3 final on Ubuntu Maverick (using PPA) 64bits 

Steps to reproduce the bug:

* Create a document in Word (in my test, 2000) with:
** more than one page
** the "different first page option" (without inserting a subsection jump)
** a header for first and second page. make it different or you won't see the bug
* Open the document in LibreOffice, make a change in the document (add a few return in the first page) and save it in .doc
* Open the document in Word: The second page will have the same header as the first one
* Open in LibreOffice, same thing

Another way to do it:

* Create a file in LibreOffice
** more than one page
** F11, than click "First page" as page style
** Save as .doc
* Open in Word (in my test, 2007): the second page will lose it's style.

In some case, it is possible to only insert a manual page break at the end of the first page the first time you are in LibreOffice. However, this option is not always possible as it might cut a paragraph in two.
Comment 1 Bruno Lambert 2011-02-10 11:03:00 UTC
Created attachment 43211 [details]
file before losing header
Comment 2 Bruno Lambert 2011-02-10 11:03:19 UTC
Created attachment 43212 [details]
file after losing header
Comment 3 Björn Michaelsen 2011-12-23 11:44:56 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Cor Nouws 2011-12-28 13:17:18 UTC
Hi Bruno,
Thanks for reporting :-)
I can confirm the issue - is a very old one too. And not sure if any improvement can be reached simply.
If you would like to have a nice work for a dark winter evening: search BugZilla for Writer + page style / word etc etc.
I guess there are numerous related/duplicate issues. Alas ..
Greetings - Cor
Comment 5 sasha.libreoffice 2012-02-23 22:02:26 UTC
reproducible in 3.5.0 only this:
1.Start Writer
2. Insert title page
3. Change title page to landscape
4. Save to doc
5. verify in Word and in Writer
(FILESAVE problem)
Comment 6 sasha.libreoffice 2012-02-25 00:10:11 UTC
Similar problem:
Bug 34984 - Saving to .doc format copies first page header onto all others
Comment 7 Roman Eisele 2012-05-01 08:51:45 UTC
Added to the new container bug #48741.
Comment 8 Cor Nouws 2013-10-25 11:51:17 UTC
works fine now, thanks to the introduction of the property 'Different first page' since LibreOffice 4.0.0