Bug Hunting Session
Bug 34183 - EDITING: autocomplete word loading problem when starting to work in existing documents
Summary: EDITING: autocomplete word loading problem when starting to work in existing ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2011-02-11 08:33 UTC by Vincent Beers
Modified: 2016-10-19 23:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Beers 2011-02-11 08:33:25 UTC
I have a problem with Writer's auto complete system, that is, the system where you type a few letters and then it will suggest words you have typed before in the document. Basically, it sometimes works. And sometimes it doesn't.

I do not know the reason for this, however, I did find out the following:
- Auto complete just works on new empty files.
- Auto complete tends not to work on ODT files, but it does tend to work when opening DOC files.
- It seems to sporadically remember some words, but not others, no matter how many times I entered them before. This also seems to be random; at one point when auto complete works it will fill in a word in the document, but when I save, close and reopen the document it may suddenly not detect the exact same word.
- Newly made documents tend to take over the words from other documents in their auto complete. Kind of difficult to handle if I have two completely unrelated documents open.

It's confusing and inconvenient that I have to guess if auto complete is going to work like it's supposed to or not.
Comment 1 Vincent Beers 2011-02-11 08:35:12 UTC
Forgot to tell: this happens in both Windows and Linux (DEB) builds and also previous versions of LibreOffice.
Comment 2 Cor Nouws 2011-08-19 03:47:26 UTC
Hi Vincent.
Never experienced that.

Wrt the use of words from a different document: 
That is the check box "When closing a document, remove the words collected from it from the list"

Further: if spell checking is active, that influences the recording of words for this feature.


Would you please try (with hep from lists, fora) to make a clear discription of a possible problem, so that it can be pin-pointed and reproduced? 
If not, there is less chance that people can pick up this report.
Thanks - Cor
Comment 3 Cor Nouws 2011-09-07 13:39:41 UTC
No reply, so I intend to close this one..
Comment 4 Vincent Beers 2011-09-07 17:57:53 UTC
Hi,

Sorry, I totally forgot about this. If I was unclear, the autocomplete is when you enter a few letters and it suggests a word previously typed or shown in the document, and it seemed to work unreliably for me. After a bit of testing, I found out that word autocomplete only works in the following cases:

- Only words that are 10 letters or longer are recorded and autocompleted (fine, but should be configurable).
- Words are only added to the list if you try entering the word somewhere after the first time it appears (see below).

Here's something to test:
- Turn off spell checking first.
- Open a document containing some longer than 10 letter long words.
- Enter the first three letters of a word somewhere before the first occurrence of that word. (so "inc" for incredibly).

The word is not autocompleted. Expected behavior is that it should autocomplete, because the word is used in the document.

- Enter the first three letters again, but this time somewhere after the first occurrence of the word.

It will autocomplete, as expected. Also, any other long words from the start of the document up to the cursor position will be recognized and added to the word list. But only those words. Other (new) long words after the cursor position need to have the same thing done to them.

A fix would probably be to read through the entire document once on load and collect all the long words right away.
Comment 5 Cor Nouws 2011-09-08 15:46:29 UTC
(In reply to comment #4)

> Sorry, I totally forgot about this. 

It's OK - thanks for your reply now.

> If I was unclear, the autocomplete is when ...

I know how it works ;-)

> A fix would probably be to read through the entire document once on load and
> collect all the long words right away.

I've noticed this behaviour before yeah. But just accepted it, since in my experience itś only a few words typing, before it works fine.. (never tested it precisely though).

Would a correct description of the issue be:
  "AutoCompletion does load words in existing document with some delay" ?
Comment 6 Vincent Beers 2011-09-08 16:05:56 UTC
(In reply to comment #5)
> Would a correct description of the issue be:
>   "AutoCompletion does load words in existing document with some delay" ?

Not really, because I found it's not based on a fixed time but on if you've typed anything near the end of the document yet. So a description might be:
"AutoCompletion does not load words in existing document until something is typed after the first occurrence of the word". Still a bit long. :P
Comment 7 Vincent Beers 2011-09-08 16:07:08 UTC
I edited the summary a bit to hopefully reflect the problem a bit better.
Comment 8 Cor Nouws 2011-09-09 00:35:11 UTC
thanks - I make it a bit longer though
(and hope you don't mind that this issue does not rank as very important, IMO)
Comment 9 Vincent Beers 2011-09-09 03:07:12 UTC
(In reply to comment #8)
> thanks - I make it a bit longer though
> (and hope you don't mind that this issue does not rank as very important, IMO)

No problem, I'm sure there are more pressing issues. This is just an inconvenience. :)
Comment 10 Björn Michaelsen 2011-12-23 11:52:43 UTC Comment hidden (obsolete)
Comment 11 sasha.libreoffice 2012-02-23 21:40:18 UTC
@ Vincent Beers
In version 3.5.0 this problem still exist?
Comment 12 Vincent Beers 2012-03-05 14:12:17 UTC
(In reply to comment #11)
> @ Vincent Beers
> In version 3.5.0 this problem still exist?

Nope, it seems to be fixed, or at least for the use case I made up in comment 4.
Comment 13 sasha.libreoffice 2012-03-06 02:00:20 UTC
Thanks for additional testing
Due to last comment, changing status to WorksForMe
If problem will appear again, please, change status to Reopened