Bug Hunting Session
Bug 34186 - Can not delete Picture
Summary: Can not delete Picture
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-11 08:59 UTC by Rainer Bielefeld Retired
Modified: 2011-07-06 01:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
See Original Report (20.43 KB, application/vnd.oasis.opendocument.text)
2011-02-11 08:59 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-02-11 08:59:59 UTC
Created attachment 43255 [details]
See Original Report

"LibreOffice 3.3.1 RC1 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 7 / tag 3.3.1.1)]" does not allow to delete little picture at the left bottom end of attached sample.odt. I get message "Readonly content cannot be changed. No Modifications will be accepted.

No problem with OOo 3.4-dev
Comment 1 tester8 2011-02-13 12:04:47 UTC
Reproduced with LO 3.3 RC4 ubuntu 10.04 x86.
Comment 2 Rainer Bielefeld Retired 2011-02-13 20:58:46 UTC
Cue to Comment 1 NEW
Comment 3 Rainer Bielefeld Retired 2011-02-13 21:18:46 UTC
I am a little worried concerning  tester8's result, I can not reproduce the problem with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]"
Comment 4 Marc Kaulisch 2011-02-21 01:58:48 UTC
Reproduced with 3.3.1 RC2 on WinXP SP3
Comment 5 Marc Kaulisch 2011-02-21 02:02:43 UTC
In OO 3.3 document is marked as read-only - after save as - deleting picture works
Comment 6 Rainer Bielefeld Retired 2011-02-21 02:27:29 UTC
@Marc:
I believe the OOo effect might have to do something with the download process? Here on my PC the original document never was "Read Only".
Comment 7 Cor Nouws 2011-07-06 01:08:56 UTC
when I double click the picture, the window Picture, tab Options shows the option Protect content (or such - looking at Dutch UI) is checked.

Unchecking that allows me to delete the picture.
This in 3.4.1 final

So, following your first bug report, that is/was a bug in OOo 3.4 dev. ?!
Comment 8 Rainer Bielefeld Retired 2011-07-06 01:32:16 UTC
@Cor Nouws
Seems so. I have been used for ages to be able to delete those pictures in OOo, so I never had the idea to check the preferences.
So this one is INVALID.