Bug 34222 - FILEOPEN .docx RTL: Tables properties wrong
Summary: FILEOPEN .docx RTL: Tables properties wrong
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Ilan Kirschenbaum
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2011-02-12 21:30 UTC by Fahad Al-Saidi
Modified: 2012-05-30 13:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
a testing file docx contents a rtl table (12.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-02-12 21:30 UTC, Fahad Al-Saidi
Details
the right way in ms office (78.51 KB, image/png)
2011-02-12 21:32 UTC, Fahad Al-Saidi
Details
the wrong way in Libreoffice (109.66 KB, image/png)
2011-02-12 21:32 UTC, Fahad Al-Saidi
Details
docx file with wrong presentation of RTL table (807.50 KB, application/msword)
2012-05-23 16:35 UTC, Ilan Kirschenbaum
Details
Test file uploaded 2012-05-23 - correct way in MS Office (231.04 KB, image/png)
2012-05-23 16:39 UTC, Ilan Kirschenbaum
Details
Test file uploaded 2012-05-23 - incorrect way in LibreOffice (189.90 KB, image/png)
2012-05-23 16:43 UTC, Ilan Kirschenbaum
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fahad Al-Saidi 2011-02-12 21:30:55 UTC
Created attachment 43307 [details]
a testing file docx contents a rtl table

When I open a docx file contents RTL tables with libreOffice, it shows them in wrong way. Please see the attachments:
-  a testing file docx
- a screen shot of MS Office ( right way)
- a screen shot of LibreOffice ( wrong way)
Comment 1 Fahad Al-Saidi 2011-02-12 21:32:03 UTC
Created attachment 43308 [details]
the right way in ms office
Comment 2 Fahad Al-Saidi 2011-02-12 21:32:56 UTC
Created attachment 43309 [details]
the wrong way in Libreoffice
Comment 3 Lior Kaplan 2011-11-02 14:16:31 UTC
Confirming the bug happens on 3.4.3 (Debian 64bit). Already fixed in the past for doc files (https://issues.apache.org/ooo/show_bug.cgi?id=103357), now seem to happen in docx files - so maybe the solution is easy.

To work around the bug, in Table properties change table alignment from "From Left" to "Automatically". Worked for the doc bug in OO.org and works also for the docx problem.
Comment 4 Björn Michaelsen 2011-12-23 11:51:01 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Lior Kaplan 2011-12-24 11:25:16 UTC
Can't reproduce with 3.5.0 beta2, can someone confirm ?
Comment 6 Lior Kaplan 2011-12-24 12:30:54 UTC
Found some more test cases to verify the bug with in 3.5.0 beta2. Went over the git log and didn't notice which commit actually did the fix, but I can't complain...
Comment 7 Rainer Bielefeld Retired 2012-05-07 05:35:50 UTC
No fix is known
Comment 8 Ilan Kirschenbaum 2012-05-23 16:35:49 UTC
Created attachment 62037 [details]
docx file with wrong presentation of RTL table

Found this defect when looking for a solution for the problem, and realized it was closed.
I hope this file helps reproducing the problem
Comment 9 Ilan Kirschenbaum 2012-05-23 16:39:14 UTC
Created attachment 62038 [details]
Test file uploaded 2012-05-23 - correct way in MS Office
Comment 10 Ilan Kirschenbaum 2012-05-23 16:43:54 UTC
Created attachment 62039 [details]
Test file uploaded 2012-05-23 - incorrect way in LibreOffice
Comment 11 Rainer Bielefeld Retired 2012-05-23 22:31:14 UTC
I think tis problem is older, seems to be alreay visible in LibO 3.3.3, but there are some additional problems so that it's not easy to decide what might be this problem here and what an other one.

@Ilan Kirschenbaum:
<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>
The original bug report was about a .docx problem what still is fixed.

Please submit separate bugs for all problems you find in the sample document. There is no way to handle request "do as many fixes as necessary until my sample document looks correct". 
As a first step I submitted "Bug 50300 - FILEOPEN .doc with wrong TABLE border color"

I will obsolete your attachments because the have no relation to the original report.
Comment 12 Ilan Kirschenbaum 2012-05-23 22:49:27 UTC
Sent from my iPhone

On 24 במאי 2012, at 08:31, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=34222
> 
> Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|REOPENED                    |RESOLVED
>         Resolution|                            |FIXED
>            Summary|RTL Tables  broken when     |FILEOPEN .docx RTL: Tables
>                   |open a docx file            |properties wrong
> 
> --- Comment #11 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> 2012-05-23 22:31:14 PDT ---
> I think tis problem is older, seems to be alreay visible in LibO 3.3.3, but
> there are some additional problems so that it's not easy to decide what might
> be this problem here and what an other one.
> 
> @Ilan Kirschenbaum:
> <https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>
> The original bug report was about a .docx problem what still is fixed.
> 
> Please submit separate bugs for all problems you find in the sample document.
> There is no way to handle request "do as many fixes as necessary until my
> sample document looks correct". 
> As a first step I submitted "Bug 50300 - FILEOPEN .doc with wrong TABLE border
> color"
> 
> I will obsolete your attachments because the have no relation to the original
> report.
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are the assignee for the bug.
Comment 13 Rainer Bielefeld Retired 2012-05-23 23:02:19 UTC
Change to correct Resolution (my mistake)