Download it now!
Bug 50300 - FILEOPEN .doc with wrong TABLE border color
Summary: FILEOPEN .doc with wrong TABLE border color
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-23 22:25 UTC by Rainer Bielefeld Retired
Modified: 2014-03-30 12:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-05-23 22:25:48 UTC
Steps how to reproduce with parallel installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7e65666]" (tinderbox: Win-x86@6-fast, pull time 2012-05-22 21:46:19)

1. download (obsolete) attachment 62037 [details] of "Bug 34222 - RTL Tables broken when 
   open a docx file" and create a copy
2. open document with LibO, copy with MS WORD (or Viewer) and compare
   Expected: look equal and like attachment 62038 [details]
   Actual: Table completely destroyed as visible in attachment 62039 [details],
           especially table border color red instead of orange

A problem is that the document also is not shown correctly in MS WORD Viewer, document might be damaged? In attachment 62038 [details] the big frame with heading
"חגיגה על הראש" and showing woman + girl is not visible at all on first page, I see it at the bottom, same with WORD 2010.

So the only remaining undisputed Table problem in LibO is with obrders:
- all borders red instead of orange
- Single line thick instead of double lines thick + thin for table in table
  outer borders (except top border, what is a regression compared to 3.5 and
  a different bug, I will submit a Bug later)

NEW because confirmation by reporter's screenshot attachment 62039 [details]
  
@all:
Can you confirm my table border color observation?

@Ilan:
Please submit separate Bugs for other problems with your sample document (after you have checked that the problem has not been reported already.

@Lior
Can you please help to find RTL related bugs in this sample document?

@Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 1 Lior Kaplan 2012-05-30 13:41:38 UTC
I can confirm the border color issue you've mentioned, on Debian 64bit

LibreOffice 3.5.3.2 
Build ID: 350m1(Build:2)
Comment 2 Lior Kaplan 2012-05-30 13:51:46 UTC
Instead of duplicating this issue and attachment I would they to prioritize the problem, and I think the main one is the frame with the extra mother+child frame which cover the "real" content which is seen in the 1st page of the MS word screenshot.

The 2nd issue is the mislocation of the photos in the page, and only then the border color and thickness issues.
Comment 3 Teo91 2013-09-30 12:37:54 UTC
I can confirm the border color issue with LO 4.1.1 on Windows 7 SP1.
Comment 4 Luke Deller 2014-03-30 10:57:40 UTC
The border colour issue is fixed in 4.3 by commit ad51d4952dc30e0d1cdcc6037556cd7c66a61542

The borders are also correctly showing as thick/thin double borders, although the joins at the corners do not look right - I think that relates to work-in-progress in bug 50300.
Comment 5 retired 2014-03-30 12:24:14 UTC
So fixed as of Comment 4. Please open new bugs for remaining other issues.