Bug 34268 - FILEOPEN Writer hangs indefinitely when opening attached .doc
Summary: FILEOPEN Writer hangs indefinitely when opening attached .doc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-14 11:18 UTC by leighman
Modified: 2015-05-16 00:03 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
MS Office XP document.doc (168.50 KB, application/msword)
2011-05-12 08:51 UTC, Christopher M. Penalver
Details
Log file created by MacOS X when I had to force quit LibreOffice 3.5.2.2 (196.92 KB, text/plain)
2012-04-20 07:35 UTC, Roman Eisele
Details
bt at random (4.07 KB, text/plain)
2014-09-03 21:05 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Christopher M. Penalver 2011-02-25 22:59:04 UTC
Confirmed in Ubuntu 10.10 LibreOffice Writer 3.3.1 at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/661585/+attachment/1695911/+files/2.%20FR-APL-02%20ASSESSMEN-Mencari%20dan%20Membuat%20Paket%20Produk%20dan%20Jasa%20Pariwisata.doc && lowriter -nologo 2.\ FR-APL-02\ ASSESSMEN-Mencari\ dan\ Membuat\ Paket\ Produk\ dan\ Jasa\ Pariwisata.doc

LO hangs indefinitely.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.1-1ubuntu3~maverick1
  Candidate: 1:3.3.1-1ubuntu3~maverick1
  Version table:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
Comment 2 Christopher M. Penalver 2011-04-06 20:24:08 UTC
Confirmed in LO 3.3.2.

lsb_release -rd
Description:	Ubuntu 10.10
Release:	10.10

libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2~maverick1
  Candidate: 1:3.3.2-1ubuntu2~maverick1
  Version table:
 *** 1:3.3.2-1ubuntu2~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
Comment 3 Christopher M. Penalver 2011-05-12 08:51:17 UTC
Created attachment 46642 [details]
MS Office XP document.doc

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/401003/+attachment/630609/+files/MS%20Office%20XP%20document.doc && lowriter -nologo MS\ Office\ XP\ document.doc

hangs indefinitely.

As per downstream reporter this was exported from MS Word in XP:
https://bugs.launchpad.net/df-libreoffice/+bug/401003

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
Comment 4 Roman Eisele 2011-12-02 05:27:12 UTC
This bug is still alive:
CONFIRMED with LibreOffice 3.4.4, German langpack,
running on MacOS X 10.6.8 German,
AND with LibO-dev 3.5.0,
Build ID: 549f928-b211287-090bcba-45cf606
Build Date: 2011-12-01.

When trying to open the sample document, LibreOffice just hangs.

Changed Platform to "All", because it affects MacOS, too (not only Linux).
Comment 5 Björn Michaelsen 2011-12-23 11:43:52 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Christopher M. Penalver 2012-01-03 13:51:31 UTC
Problem reproducible in:
LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002
Comment 7 Roman Eisele 2012-04-20 07:34:24 UTC
Still [REPRODUCIBLE] with LibreOffice 3.5.2.2 (Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f), German langpack installed, running on MacOS X 10.6.8 German. When trying to open the sample document, LibreOffice just hangs.

I will attach the MacOS X log file created when I had to force quit LibreOffice.
Comment 8 Roman Eisele 2012-04-20 07:35:58 UTC
Created attachment 60395 [details]
Log file created by MacOS X when I had to force quit LibreOffice 3.5.2.2
Comment 9 Roman Eisele 2012-04-20 11:18:00 UTC
@Cédric:
I inserted your address into the CC list because this bug may be related to other Writer/.doc file bugs assignet to you.

This is an old bug, but still reproducible, and certainly of some importance, as .doc file import is very important for many people, and the bug may affect other .doc files, too, not only the sample file ...
Comment 10 Terrence Enger 2012-09-14 12:19:58 UTC
master opens the attached document without any obvious problem.

LibreOffice is id 741c56a, pulled 2012-09-13.

autogen.lastrun:
    --enable-symbols
    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-system-postgresql
    --enable-debug
    --enable-werror

Build and execution environment:
    $ uname -a
    Linux cougar-natty 2.6.38-15-generic #64-Ubuntu SMP Fri Jul 6 17:18:17 UTC 2012 i686 athlon i386 GNU/Linux
    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2

For comparison, LibreOffice supplied with ubuntu-natty (LibreOffice
3.3.4, OOO330m19 (Build:401)) has used 100% of the CPU for several
minutes without producing any visible result.

In the complete absence of any idea about what changed in the program,
I am setting bug status to RESOLVED WORKSFORME.  Can other commenters,
especially those on other platforms, please confirm the lack of crash?

Terry.
Comment 11 m.a.riosv 2012-09-18 13:51:09 UTC
Opens apparently without any problem.
Win7x64 LibreOffice Version 3.6.2.1 (Build ID: ba822cc)
Comment 12 Roman Eisele 2012-09-19 07:47:14 UTC
Tested again because of request on LibreOffice QA mailing list.

The results are simple (both tests done on Mac OS X 10.6.8, Intel):

* The hang is still REPRODUCIBLE with LibreOffice 3.5.6.2 (Build ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0).

* But the hang is no longer reproducible and the document opens well with LibreOffice 3.6.2.1 (Build ID: ba822cc).

* Also no longer reproducible with current master build: LOdev 3.7.0.0.alpha0+ (Build ID: 01e6335, pull time: 2012-09-18 04:23:03)

So the question is simple: should we leave this bug as RESOLVED/WORKSFORME because it is fixed in 3.6 and 3.7 (master), but not in 3.5.6.2? For me this way to proceed is fine, but if someone else wants to reopen this bug report, I would not resist ...
Comment 13 Terrence Enger 2012-09-19 12:10:34 UTC
Roman Eisele wrote:
> ...  fixed ..., but not in 3.5.6.2? For me this way to proceed is
> fine, but if someone else wants to reopen this bug report, I would
> not resist ...

I do not think it is possible to backport the fix to 3.5 without
knowing just what the fix is, i.e. the commit id(s).  Alas, I am 
not in a position to run bibisect.

Terry
Comment 14 Roman Eisele 2012-09-19 12:54:58 UTC
(In reply to comment #13)
> I do not think it is possible to backport the fix to 3.5 without
> knowing just what the fix is, i.e. the commit id(s).

Correct. That’s the problem ...

Therefore, and because our current development focus is 3.6 (and 3.7), while we don’t have infinite developer resources, I fear we have to live with this bug in the 3.5 branch, and just need to encourage people to move on to 3.6.x. (At the moment some people hesitate to update, because there are still some unsolved regressions in 3.6.x, but there is good progress about fixing these regressions, and in my personal experience 3.6.2.1 already works better in most situations than any 3.3.x, 3.4.x or 3.5.x version.)

So, RESOLVED/WORKSFORME is not perfect, but realistic.
Comment 15 Terrence Enger 2012-09-19 19:47:13 UTC
@leighman

I presume that ubuntu will pick up the fix in the normal course of affairs.

Will you do whatever is necessary for the bug reports at ubuntu?

Thanks,
Terry.
Comment 16 Mark Wielaard 2013-06-30 16:24:54 UTC
The attached document still doesn't open for me. Neither with LibreOffice 3.6 (libreoffice-writer-3.6.6.2-9.fc18.x86_64) nor with a local build of 4.1 (libreoffice-4.1.0.1-141-gca0bbec --enable-symbols --with-system-headers).

Could someone confirm or deny that the attached document does load for them and if so in which version/configuration?

As far as I can see with gdb the issue is that the while loop in sw/source/core/layout/tabfrm.cxx (SwTabFrm::MakeAll)
    while ( !mbValidPos || !mbValidSize || !mbValidPrtArea )
never succeeds. All values are always set to false during the loop.
Comment 17 Christopher M. Penalver 2013-06-30 18:18:57 UTC
Mark Wielaard, this report is not about your attachment, but the attachment noted in the Description https://bugs.freedesktop.org/show_bug.cgi?id=34268#c0 . If you have a bug in LibreOffice, please file a new report following http://wiki.documentfoundation.org/BugReport .

Thank you for your understanding.
Comment 18 Mark Wielaard 2013-06-30 20:10:33 UTC
(In reply to comment #17)
> Mark Wielaard, this report is not about your attachment, but the attachment
> noted in the Description
> https://bugs.freedesktop.org/show_bug.cgi?id=34268#c0

Yes, that is the one I am talking about. The attachement to this bug report you reference above. Since that one still doesn't open for me with the versions of LibreOffice I mentioned in comment #16. Is the analysis wrong or does the attachment open for you? If so please provide the libreoffice version you are using. Thanks.
Comment 19 Mark Wielaard 2013-06-30 20:12:04 UTC
Just for reference it also fails to open with another version I have around libreoffice-writer-4.0.3.3-1.el6.rhis.x86_64
Comment 20 Julien Nabet 2013-11-15 22:57:01 UTC
On pc Debian x86-64 with master sources updated today, I reproduce the hang.
So I put it at NEW.
Comment 21 Mohamed-Ali BEN MANSOUR 2014-01-14 13:42:11 UTC
Tested in LO 4.0.4 and the last release 4.1.4.2 and it also fails !!!
It seems to be not working in all versions except in 3.6.2.1 and 3.7.0.0 (#comment 12) 
Proposals are welcome to fix urgently the bug.
Comment 22 Christopher M. Penalver 2014-01-14 16:21:10 UTC
Mohamed-Ali, please do not toggle this report. For more on this, please see https://wiki.documentfoundation.org/BugReport .
Comment 23 Christopher M. Penalver 2014-01-14 16:31:13 UTC
Mohamed-Ali, as you are not the original reporter, and clearly did not read https://bugs.freedesktop.org/show_bug.cgi?id=34268#c22 please *do not* toggle this report. The fact you reproduced this in a later release, has nothing to do with the Version. The Version is ment for the *earliest* release, not the latest.
Comment 24 Cédric Bosdonnat 2014-01-14 16:40:00 UTC
Not on my plate anymore
Comment 25 Mohamed-Ali BEN MANSOUR 2014-01-14 16:51:44 UTC
Ok Christopher : thank you for the link (I've missed some details). Therefore, i've submitted a new bug:
https://bugs.freedesktop.org/show_bug.cgi?id=73616
Comment 26 tommy27 2014-06-21 19:44:34 UTC
test files still causing hang under Win7x64 using LibO 4.2.4.2 and 4.4.0.0.alpha0+
Build ID: 488f31200094d7237d45545ab227014831a1f8e6
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-15_05:02:39

both document can be opened in a few seconds using MS Word Viewer
Comment 27 Julien Nabet 2014-09-03 21:05:19 UTC
Created attachment 105706 [details]
bt at random

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 28 Julien Nabet 2014-09-03 21:06:31 UTC
Michael: I attached a bt at random. I can retrieve others if needed but it could be a infinite recursive loop. One for you?
Comment 29 MM 2015-05-15 23:13:15 UTC
This one seems fixed. Tried with v4.4.3.2 under windows 7, ubuntu 14.04 and mint 17.1 and the files load normally.
Comment 30 tommy27 2015-05-16 00:03:44 UTC
another old bug bites the dust.

works fine even with LibO 4.4.1.2 under Win8x64

status --> RESOLVED WORKSFORME