Download it now!
Bug 34375 - EDITING: 'Keep ratio' broken for Symbol Shapes
Summary: EDITING: 'Keep ratio' broken for Symbol Shapes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 RC1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Oliver Specht (CIB)
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-17 00:53 UTC by Rainer Bielefeld Retired
Modified: 2016-10-25 19:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-02-17 00:53:31 UTC
I observed that with "LibreOffice 3.3.1 RC1 – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 7 / tag 3.3.1.1)]"

Steps to reproduce:
1. open new empty WRITER document
2. Make DRAWING Toolbar visible with menu 'View > Toolbars'
4. Select "Smiley" from Toolbar 'Drawing > Symbol Shapes'
5. Draw a smiley with app. 50mm diameter into the WRITER document
6. Move mouse pointer to top middle control point 
   Mouse pointer view changes to double arrow up down
7. Press <shift>, left mouse click, drag control point down until siliy
   will have height of app. 10mm
   as expected for dragging with <shift>, aspect ration has been kept
8. Release mouse button
   expected: size remains on diameter 10mm
   actual: only height remains, widht returns to 50mm as before you dragged
           control point. That's the same result as dragging 
           control point without <shift>

You see the same bad result with all 3 other control points on the edges.
Dragging (with <shift> of the control points at the corners works a little better, but also not in a perfect way, aspect ratio also will be broken at the most attempts.

Same problem with Basic Shapes (also xtruded), Block Arrows, Stars, Callouts, Flow Chart elements, 
but not with Ellipse, Rectangle, 3D objects

Same problem with OOo 3.4-dev and 3.1.1

Works fine in DRAW and CALC.
Comment 1 sasha.libreoffice 2011-03-16 06:34:06 UTC
the same problem in LibreOffice 3.3.2.1 rc1 on Mandriva 64 bit 
and on LibreOffice 3.3.1.2 on windows XP 32 bit
Comment 2 Rainer Bielefeld Retired 2011-03-16 11:54:12 UTC
NEW due to sasha's comment.

Cédric, can you help here?
Comment 3 Rainer Bielefeld Retired 2012-11-13 05:41:19 UTC
Still [Reproducible] with "LibreOffice 3.6.3.2" German UI/ German Locale [Build-ID: 58f22d5] on German WIN7 Home Premium (64bit) 

@Thorsten:
Can you help?
Comment 4 QA Administrators 2015-01-05 17:50:56 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-01-19 10:02:51 UTC
Could repro.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46
Comment 6 Commit Notification 2015-12-11 06:36:50 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=feb59478cd3d0e81b1acbead259f3087c3434bec

tdf#34375: resizing of drawings with shift key fixed

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 manuel.defranceschi 2016-06-16 10:17:07 UTC
Not present in:

Version: 5.2.0.0.beta2
Build ID: ae12e6f168ba39f137fc110174a37c482ce68fa4
CPU Threads: 2;
UI Render: default; 
Locale: it-IT (it_IT.UTF-8)
OS: OS: openSUSE Leap 42.1 (x86_64)

Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2;
UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS: OS: openSUSE Leap 42.1 (x86_64)

I changed the bugs status to resolved fixed.