Download it now!
Bug 34409 - New document opened from File EXPLORER or Desktop without text language
Summary: New document opened from File EXPLORER or Desktop without text language
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.1 RC1
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34277 43849 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-17 10:54 UTC by Rainer Bielefeld Retired
Modified: 2012-08-31 10:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-02-17 10:54:41 UTC
During some tests for 
Bug 31422 - Spell checker does not work in Writer 
I found with "LibreOffice 3.3.1 RC1 – WIN7  Home Premium  (64bit) English UI [OOO330m19 (build 7 / tag 3.3.1.1)]", that LibO has the same problem as reported in 
<http://www.openoffice.org/issues/show_bug.cgi?id=58014>

Steps to reproduce:
1. Go to desktop
2. 'rightclick > New > "Opendocument Text"'
   New WRITER document will be put to Desktop
3. Open new Document from Desktop with double click
4. Menu 'Format > Character > Font - Language
   Expected: should show your default text language
   Actual: Language = None

For comparison:

11. Menu 'File > New > Text Document'
    New WRITER document will be opened
12. Menu 'Format > Character > Font - Language'
   Expected: should show your default text language
   Actual: as expected, for me it's "German"
Comment 1 Rainer Bielefeld Retired 2011-02-17 22:36:38 UTC
Only for competeness, I see the same problem
- for other document types created from Desktop (CALC, DRAW)
- with very old  OOo versions (1.1.4)
Comment 2 Andras Timar 2011-04-09 05:55:32 UTC
*** Bug 34277 has been marked as a duplicate of this bug. ***
Comment 3 Andras Timar 2011-04-09 06:09:28 UTC
When the user creates a new OpenDocument document in the desktop or from the file explorer, Windows copies an empty document from c:\Windows\SHELLNEW\ to that place. These empty documents are in extras\source\shellnew\ in the source code.

There is and there can be only one empty document for each type, so they are language neutral. The new OpenDocument Calc document has 3 worksheets and worksheet tab labels are in English. 

I don't know what the ideal solution would be, suggestions are welcome.
Comment 4 camellia0x 2011-06-06 13:58:41 UTC
(In reply to comment #3)
> When the user creates a new OpenDocument document in the desktop or from the
> file explorer, Windows copies an empty document from c:\Windows\SHELLNEW\ to
> that place. These empty documents are in extras\source\shellnew\ in the source
> code.
> 
> There is and there can be only one empty document for each type, so they are
> language neutral. The new OpenDocument Calc document has 3 worksheets and
> worksheet tab labels are in English. 
> 
> I don't know what the ideal solution would be, suggestions are welcome.

Shouldn't a default language be picked by the installer and copied there? Or perhaps, I don't know about the inner workings of the format, the document should specify that the writer should select a language for it? For example, instead of "none" new documents would be set with "null" as the language.
Comment 5 Björn Michaelsen 2011-12-23 11:47:10 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 sasha.libreoffice 2012-02-23 22:16:09 UTC
my be related problem:
Bug 43849 - Autocorrection non-functional in documents created from template
Comment 7 Fabian Tröster 2012-02-26 01:30:48 UTC
Not sure, if anybody will read this, since the comment I'm replying to, is old. I'll try anyway ...

Not sure whether this would be a feasible solution, but here's what I'd do:
It's perfectly understandable that the template documents, delivered by the installer, have to be language neutral! If we take that as a starting point, I would solve this problem by modifying the application (Writer, Calc, and so on) in such a way that they will check upon opening a document for language neutral document settings (which should really be language specific) and if found, set those settings to the logon language of the current user.

This should work for every platform LibreOffice is currently supported on, since Windows, Linux and MacOS all use a language setting for the logged on user. This setting can be read out by the application software.

What's more: this solution would also be transparent for the user and would work for old documents all the same.

Note:
If you just open the application -- say: Writer -- then the created empty document already has all language specific settings spot on. Personally I think it should not make any difference at all HOW exactly you created the empty document: the behaviour of the application should be the same. As it is now the user has to comb through settings to find all the language specific parts and have them set up correctly by hand. I don't think that's desireable.

I hope my English is good enough, so you can understand what I mean. :)

(In reply to comment #3)
> When the user creates a new OpenDocument document in the desktop or from the
> file explorer, Windows copies an empty document from c:\Windows\SHELLNEW\ to
> that place. These empty documents are in extras\source\shellnew\ in the source
> code.
> 
> There is and there can be only one empty document for each type, so they are
> language neutral. The new OpenDocument Calc document has 3 worksheets and
> worksheet tab labels are in English. 
> 
> I don't know what the ideal solution would be, suggestions are welcome.
Comment 8 Rainer Bielefeld Retired 2012-02-26 02:16:58 UTC
*** Bug 43849 has been marked as a duplicate of this bug. ***
Comment 9 Rainer Bielefeld Retired 2012-02-26 02:18:39 UTC
Bug 43849 - Autocorrection non-functional in documents created from template in Bug 43849#C7 reporter made some suggestions how to improve behavior, I can't tell whether that's promising.
Comment 10 Rainer Bielefeld Retired 2012-02-26 02:20:07 UTC
Arghh, HERE in C7
Comment 11 Florian Reisinger 2012-08-14 14:00:20 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:01:27 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:06:11 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Florian Reisinger 2012-08-14 14:08:12 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian