Bug 34454 - EMF+ Don't display figures (VIEWING)
Summary: EMF+ Don't display figures (VIEWING)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: backportRequest:6.0
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2011-02-18 08:16 UTC by daniel pascot
Modified: 2018-05-31 19:00 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
examples of figures that does not display (332.50 KB, application/msword)
2011-02-18 08:17 UTC, daniel pascot
Details
pdf : what should be seen (154.12 KB, application/pdf)
2011-02-23 05:14 UTC, daniel pascot
Details
Sample file converted to .docx (287.21 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-11-21 11:21 UTC, Bartosz
Details
Extracted EMF+ files from document (164.38 KB, application/zip)
2017-11-21 11:24 UTC, Bartosz
Details
Extracted EMF+ on which Ellipse transparency is not working correctly (264.48 KB, image/x-emf)
2018-04-13 12:46 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daniel pascot 2011-02-18 08:16:17 UTC
Probably the figures were done by MSWord drawing tool

Display correctly in OO 3.2
Comment 1 daniel pascot 2011-02-18 08:17:48 UTC
Created attachment 43525 [details]
examples of figures that does not display
Comment 2 daniel pascot 2011-02-23 05:14:51 UTC
Created attachment 43701 [details]
pdf : what should be seen
Comment 3 Björn Michaelsen 2011-12-23 11:49:04 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:01:45 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:02:48 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:07:22 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:09:29 UTC Comment hidden (obsolete)
Comment 8 sasha.libreoffice 2012-08-24 09:12:59 UTC
reproduced in 3.3.4, 3.5.5, 3.6.0 on Fedora 64 bit. Reopening
Comment 9 Zeki Bildirici 2013-09-30 15:10:54 UTC
Hi,

Still reproducible in 4.1.1.2

Only figure 1 and figure under 1.1 are visible. 

Best regards,
Zeki
Comment 10 Julien Nabet 2013-11-15 23:22:58 UTC
Comment on attachment 43525 [details]
examples of figures that does not display

Mimetype fixed
Comment 11 Julien Nabet 2013-11-15 23:28:03 UTC
On pc Debian x86-64 with master sources updated today, there are still some problems.
I noticed lots of this trace on console logs:
warn:cppcanvas.emf:18170:1:cppcanvas/source/mtfrenderer/implrenderer.cxx:3096: (com.sun.star.lang.IllegalArgumentException) { { { Message = "com::sun::star::uno::Reference<com::sun::star::rendering::XCachedPrimitive> canvas::CanvasBase<Base, CanvasHelper, Mutex, UnambiguousBase>::strokePolyPolygon(const com::sun::star::uno::Reference<com::sun::star::rendering::XPolyPolygon2D>&, const com::sun::star::rendering::ViewState&, const com::sun::star::rendering::RenderState&, const com::sun::star::rendering::StrokeAttributes&) [with Base = cairocanvas::CanvasBitmapSpriteSurface_Base; CanvasHelper = cairocanvas::CanvasHelper; Mutex = osl::Guard<osl::Mutex>; UnambiguousBase = cppu::OWeakObject]: verifyInput(): stroke attributes' StrokeWidth value out of range (is -8.32511911906927E-008)", Context = (com.sun.star.uno.XInterface) @25bb870 (ImplementationName = "CairoCanvas.CanvasBitmap") } }, ArgumentPosition = (short) 3 }

Fridrich: taking a look to git history of cppcanvas/source/mtfrenderer/implrenderer.cxx, one for you?
Comment 12 Alexandr 2014-02-08 12:58:35 UTC
Hello.
I reproduce the bug with LibreOffice 4.1.4.2 and 4.2.0.4 on Debian. After that I set environment variable EMF_PLUS_DISALE to 1 as described in bug 39327 comment 30. In 4.1.4.2 version all pictures became visible. In 4.2.0.4 figure 4, figure 8 ang figures in the table remain invisible. I am not sure it means 2 different issues are in this report or it is a duplicate.
Comment 13 Joel Madero 2015-05-02 15:41:28 UTC Comment hidden (obsolete)
Comment 14 Alexandr 2015-05-02 19:35:56 UTC
Reproducible with LibreOffice 4.3.3 and 5.0.0.0 alpha1 on Debian. With environment variable EMF_PLUS_DISALE=1 only figure 4 and figure 8 are invisible.
Comment 15 Bartosz 2017-11-21 11:21:25 UTC
Created attachment 137887 [details]
Sample file converted to .docx
Comment 16 Bartosz 2017-11-21 11:24:08 UTC
Created attachment 137888 [details]
Extracted EMF+ files from document
Comment 17 Armin Le Grand (CIB) 2017-11-29 09:05:42 UTC
Looks like Image6 and Image18 are mssing in orig from comment1.
Both in extracted form load well nowadays with EMF+ - change in place, also the converted doc from comment15 looks good.
So I would guess this has nothing to do with EMF+ anymore, but there seems to be an error in loading orig bug-figures.doc and how the contained WMFs are imported/bound
Comment 18 Xisco Faulí 2018-02-28 10:05:44 UTC
Dear Bartosz,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 19 Bartosz 2018-04-13 12:46:37 UTC
Created attachment 141336 [details]
Extracted EMF+ on which Ellipse transparency is not working correctly
Comment 20 Xisco Faulí 2018-05-31 19:00:15 UTC
Figure 4 and Figure 8 in the attached document are now displayed

Version: 6.1.0.0.alpha1+
Build ID: ecf50fe71596c3edba8ce437481ab80ae1cd8935
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME!!!

[Improvement found by office-interoperability-tools]