Bug 34571 - Formula Editor on Windows plus converted to equals
Summary: Formula Editor on Windows plus converted to equals
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2011-02-22 06:37 UTC by cdwright
Modified: 2015-04-20 17:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description cdwright 2011-02-22 06:37:56 UTC
In the experimental formula editor on Windows XP on a US keyboard + (shift-equals) is treated as equals.

In the old edit window below the shift-= is handled correctly.

Workaround is to use the + on the numeric keypad.
Comment 1 tester8 2011-02-22 10:07:27 UTC
Not reproduced with LO 3.3.1 RC2 Ubuntu 10.04 x86.
Comment 2 cdwright 2011-02-22 12:28:46 UTC
I forgot to mention:
This bug doesn't occur on on Ubuntu.
It occurs on two different Windows XP computers.
Comment 3 cdwright 2011-02-25 06:48:50 UTC
I've now upgraded LibreOffice.  The same problem occurs using LibreOffice 3.3.1 OOO330m19 (Build:8).

Windows XP.  US English language and keyboard.

Updated Version on the bug LibO 3.3.1 release.
Comment 4 Don't use this account, use tml@iki.fi 2011-03-08 00:16:42 UTC
(No need to add comment that a bug is still present after a micro upgrade; if there is no comment that a bug would have been fixed, one can assume it is still present.)

Assigning to Jonas, feel free to assign back to list if you don't want this bug...
Comment 5 Jonas Finnemann Jensen 2011-03-08 03:50:14 UTC
This sounds likely, keyboard input is slightly hardcoded at the moment... See:

I should probably try to track down another place where KeyInput is handled correctly...

(I'm current occupied with school projects, so I'm not going to make any promises with regards to when I'll get around to take a look at this, but thanks for reporting it)
Comment 6 bfoman (inactive) 2013-08-15 14:34:16 UTC
This bug has not been touched by its Assignee for a long time. To make it clearer which bugs should be fixed by someone else please take following action:
- If you are the Assignee, and you are actively working on the bug, please give it an update. 
- If you are the Assignee, and you do not plan to work on it in the near future,
please reassign it to the default assignee.
Comment 7 Jonas Finnemann Jensen 2013-08-15 16:42:09 UTC
Sorry about that. I never got around to fix this. And judging from my current workload, I won't get around to it anytime soon.

So please, anybody, go a head a work on this. You're welcome to ask me questions, but it's been a while since I worked on the experimental visual formula editor.

Again, sorry about not reassigning sooner. I'll check if I'm assigned other bugs too...
Comment 8 QA Administrators 2015-04-01 14:40:01 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 9 Buovjaga 2015-04-20 17:27:44 UTC
Tried this in the forumula editor with US keyb layout and I get + when shift-pressing the button where it should be (I have a Finnish keyboard).
Closing as WFM.

Win 7 Pro 64-bit Version: (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI