Bug Hunting Session
Bug 34587 - Cannot save file in Microsoft Office format
Summary: Cannot save file in Microsoft Office format
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-22 18:39 UTC by agforsyth
Modified: 2011-03-04 00:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
This document with crash LibreOffice if saved as a .doc (13.10 KB, application/vnd.oasis.opendocument.text)
2011-02-22 18:39 UTC, agforsyth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description agforsyth 2011-02-22 18:39:03 UTC
Created attachment 43688 [details]
This document with crash LibreOffice if saved as a .doc

I opened a file in .doc format previously saved with OpenOffice and attempted to save it again in the same format after editing, and LibreOffice crashed. It saves successfully in .odf Open Document Format, but attempting to then convert this file back to .doc crashes LibreOffice.

Attached is a stripped down version of the file which will crash LibreOffice when saved as a .doc.
Comment 1 Rainer Bielefeld Retired 2011-02-22 22:13:00 UTC
NOT Reproducible with "LibreOffice 3.3.1 RC2 – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]"

agforsyth@gmail.com:
Thank you for your report, but it's much to imprecise. 
For example:
- what does "save as" mean? Form file menu or icon in toolbar?
- "As .doc"? WORD98? WOR95? WORD6?

May be hints on <http://wiki.documentfoundation.org/BugReport> can help to improve information?
Additional please:
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) 
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected
  -- concerning your PC
  -- concerning your OS
  -- concerning your LibO version and localization
  -- how you launch LibO
  -- everything else crossing your mind after you read a.m. URL

Can you please file Bug reports with status UNOCNFIRMED if your are not absolutely sure that the problem will be reproducible with information you can provide?
Comment 2 tester8 2011-02-23 07:48:25 UTC
Not reproduced with LO 3.3.1 RC2 Ubuntu 10.04 x86 while trying to save into every of available doc formats.
Comment 3 agforsyth 2011-02-23 11:25:56 UTC
3.3.0 Release. Two computers, one running Windows 7, one running Windows Vista. Will retest with 3.3.1.
Comment 4 agforsyth 2011-02-23 11:28:38 UTC
Using any method of saving triggers the crash for me.

By .doc I mean 97/2000/XP.
Comment 5 Rainer Bielefeld Retired 2011-03-03 20:59:52 UTC
@agforsyth:
Anything new?
I'm afraid this can't be fixed without much more efforts to find out the reason. As long as nobody can reproduce the bug, you will have to find yourself what the reason for the crash might be. Your graphic card, an Extension, anything else. Any suspect concerning characteristics that might be the same on your 2 computers and that might differ from other PC?
Comment 6 agforsyth 2011-03-03 23:30:48 UTC
Fixed by 3.3.1. Forgot to update.
Comment 7 Rainer Bielefeld Retired 2011-03-04 00:44:42 UTC
That's good news.
Due to
<https://bugs.freedesktop.org/page.cgi?id=fields.html#status>
we should used FIXED only if a known fix has solved the problem; if the problem only disappeared without known reason, please use WORKSFORME.