Download it now!
Bug 34591 - HTML import: table borders set to paragraphs instead of cells
Summary: HTML import: table borders set to paragraphs instead of cells
Status: CLOSED DUPLICATE of bug 41796
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-02-22 22:36 UTC by sasha.libreoffice
Modified: 2012-05-22 02:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
table renders in Writer incorrect (2.05 KB, text/html)
2011-02-22 22:36 UTC, sasha.libreoffice
Details
origin of HTML table (9.46 KB, application/vnd.oasis.opendocument.text)
2011-02-22 22:37 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-02-22 22:36:53 UTC
Created attachment 43691 [details]
table renders in Writer incorrect

This document has table with blue borders and black text. When I save it as HTML it looks in browser ok. But when I opened it with Writer table becomes with no borders and text becomes with blue borders.
Comment 1 sasha.libreoffice 2011-02-22 22:37:52 UTC
Created attachment 43692 [details]
origin of HTML table
Comment 2 sasha.libreoffice 2011-02-24 06:57:05 UTC
on Libreoffice 3.3.1.problem still exist
Comment 3 Cédric Bosdonnat 2011-03-03 01:42:58 UTC
With master I had blue borders and black text here... but the borders are set to the paragraph instead of the table cells. The HTML is broken on this side.

This is an easy hack: the HTML tables import code is located in this file:
http://opengrok.libreoffice.org/xref/writer/sw/source/filter/html/htmltab.cxx
Comment 4 Bálint Dózsa 2011-03-09 09:58:11 UTC
I'm taking this one.
Comment 5 XieWen 2011-07-25 00:37:36 UTC
on Libreoffice 3.4.1.problem still exist
Comment 6 Björn Michaelsen 2011-12-23 11:50:42 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Björn Michaelsen 2011-12-23 12:57:11 UTC
An EasyHack should have been checked by developers and thus is confirmed regardless of age. Moving back to NEW from NEEDINFO again. Sorry for the hassle.
Comment 8 Florian Reisinger 2012-05-18 08:22:42 UTC
Removed EASYHACK from summary
Comment 9 Michael Stahl (CIB) 2012-05-22 02:59:25 UTC
this is a duplicate of bug 41796, which is about the problem from the
other direction, i.e. the Writer export was changed to write
STYLE attributes on TD instead of BORDER attributes on TABLE,
and the import incorrectly assigns STYLE on TD to paragraphs.

*** This bug has been marked as a duplicate of bug 41796 ***