Bug 34599 - Paste special sometimes does not work with plain text
Summary: Paste special sometimes does not work with plain text
Status: RESOLVED DUPLICATE of bug 65606
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 42093 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-23 01:32 UTC by Kami
Modified: 2014-10-04 20:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
shadow appears around page after inserting "Formatted text RTF" (106.68 KB, image/png)
2012-01-20 03:48 UTC, sasha.libreoffice
Details
paste special dialog (5.21 KB, image/png)
2013-10-24 04:53 UTC, tommy27
Details
paste special dialog (11.21 KB, image/png)
2013-10-24 05:09 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kami 2011-02-23 01:32:10 UTC
When someone copy a non plain text (ctrl+c) then paste special (ctrl+shift+v) it sometimes not working at all (no paste special dialog brings up). In this case if someone copy and paste special a non plain text the "Paste special" dialog appear but the "Unformatted text" option is in the list changed to "" in Writer and "*" in Calc. Then something happen and the function works correctly. I investigate this error to provide more precise reproduction steps, but I hope others may also able to reproduce this error.

Ubuntu 10.10 / 64 bit

Thanks,
KAMI
Comment 1 Kmarz 2011-08-06 03:00:05 UTC
I have this problem (it drives me crazy), especially when pasting from PDF to LibreOffice Writer. A workaround = Copy a some text in the Writer document and hit "paste-special" to activate the paste special dialog box. Then paste-special should work with the PDF. But this only works intermittently with Libre Office (after a short period of time, I will have to repeat the workaround process). The workaround used to function for protracted periods with OpenOffice Writer but seems even more buggy with LibreOffice.

KM
Comment 2 Andras Timar 2011-10-24 01:26:02 UTC
*** Bug 42093 has been marked as a duplicate of this bug. ***
Comment 3 Björn Michaelsen 2011-12-23 11:49:30 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 sasha.libreoffice 2012-01-20 03:42:21 UTC
Steps to reproduce on Windows (LibO 3.5.0):
0. Start Writer
1. Type some text
2. select text and press Ctrl-C
3. place cursor on new line and press Ctrl-Shift-V
we see now variant "Insert as DDE"
4. choose "Formatted text RTF"
5. do step 3 again
now variant "Insert as DDE" disappears

If locale is Russian, then in step 3 first line (LO Writer) is empty
Comment 5 sasha.libreoffice 2012-01-20 03:48:59 UTC
Created attachment 55827 [details]
shadow appears around page after inserting "Formatted text RTF"

On Linux when we insert "Formatted text RTF" first time, shadow appears around page (screenshot in attachment) and disappears after scroll page. To reproduce this again, we need restart Writer.
Insert as DDE also disappears on Linux
Comment 6 Mark L 2012-10-26 19:30:57 UTC
Same issue here, LibreOffice 3.6.2.2 on Ubuntu 12.10 64-bit.

Paste Special works for a while but suddenly the dialog box will no longer appear when Paste Special is selected from the Edit menu.  Restarting LibreOffice makes it work again for a while but eventually it stops working again.
Comment 7 tommy27 2013-10-24 04:53:46 UTC
Created attachment 88066 [details]
paste special dialog
Comment 8 tommy27 2013-10-24 04:55:14 UTC
(In reply to comment #4)
> Steps to reproduce on Windows (LibO 3.5.0):
> 0. Start Writer
> 1. Type some text
> 2. select text and press Ctrl-C
> 3. place cursor on new line and press Ctrl-Shift-V
> we see now variant "Insert as DDE"
> 4. choose "Formatted text RTF"
> 5. do step 3 again
> now variant "Insert as DDE" disappears
> 
> If locale is Russian, then in step 3 first line (LO Writer) is empty

did the same steps in LibO 4.1.2.3 under Win7 64bit Italian localization.
I do not reproduce issue.

if you see my screenshot the paste special dialog looks the same any time and there's no missing item after second Ctrl-Shift-V

do you still see this issue or it has been fixed meanwhile?
Comment 9 tommy27 2013-10-24 05:09:48 UTC
Created attachment 88067 [details]
paste special dialog


sorry, forget my previous comment and see my new screenshot...
you are right... the "DDE" item disappears when you select "formatted text [RTF]" and then reopen again the paste special dialog.

you have to to exit LibO to revert it to normal.
Comment 10 Yajo 2013-12-02 15:23:18 UTC
Also affects me.

Workaround to paste only text: do a normal paste. Then select it, right-click and choose "remove direct format".
Comment 11 dE 2014-04-29 16:17:13 UTC
This's an old bug migrated from OpenOffice.

Shouldn't this be given more priority?
Comment 12 tommy27 2014-07-20 07:46:13 UTC
I do not reproduce issue anymore in LibO 4.2.5.2.
I set status to RESOLVED WORKSFORME
feel free to reopen if you think the bug is still there.
Comment 13 dE 2014-08-26 08:49:39 UTC
Yes, 4.2.5.2.

This bug appears to be fixed.
Comment 14 dE 2014-09-02 03:15:46 UTC
No, it's still there.
Comment 15 anna 2014-09-03 16:18:20 UTC
I have this bug with Fedora and LO Version: 4.2.5.2
Build ID: 4.2.5.2-10.fc20Version: 4.2.5.2
Build ID: 4.2.5.2-10.fc20

It happens when pasting from a plain test email (which has been encrypted during transmission) into an odt document.

Anyway, before I started writing this it was not working for ages (enough for me to want to come and file a bug). Then I copied and pasted the verion info above. Next I decided to re-test the text from the email in a newly created document, I selected the same phrase again and it worked in the new document and then it worked fine in the origional one too.

I can't seem to isolate if it is a specific character or situation causing the problem, I have tried a few variables and it's still working fine. So no idea what is going on, only that the probelm is internmittent and hightly annoying!

Can someone tell me what info I can gather for you next time I have the problem, to help solve this issue?
Comment 16 sasha.libreoffice 2014-09-04 13:11:29 UTC
Thanks for additional testing of this bug.
Sorry, but "version" is where bug appears. Not a current version. If bug disappears we just close bug.
Changing back to 3.3.1
Comment 17 anna 2014-09-04 13:13:03 UTC
Hi, the bug is still in current version, so I just assumed.
Comment 18 anna 2014-09-04 13:13:47 UTC
(In reply to comment #17)
> Hi, the bug is still in current version, so I just assumed.

but thanks for changing back :)
Comment 19 dE 2014-09-10 08:49:07 UTC
As a work around, if you want to paste unformatted text or whatever in the paste special dialog, you may assign it a shortcut key.

Works for me every time.
Comment 20 Jean-Baptiste Faure 2014-10-04 16:38:11 UTC
If the problem occurs when copying from another program like email client, web browser or pdf reader, it may be possible that the problem is on the side of the program which does the copy.

When the problem happens (ctrl+maj+V does not work), does the paste work if you do it in another program like a plain text editor?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 21 Jean-Baptiste Faure 2014-10-04 20:30:37 UTC
The same bug as been reported : bug 65606 with a more clear and reproducible description.

Set duplicate of bug 65606.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 65606 ***