Download it now!
Bug 34638 - Inconsistent Localisation of CTRL key abbreviation
Summary: Inconsistent Localisation of CTRL key abbreviation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 50415
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 13:37 UTC by Nino
Modified: 2012-06-05 12:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nino 2011-02-23 13:37:51 UTC
In some LibO installtions, the UI displays the letters "CTRL" when referencing the CTRL key in menus and tooltips (e.g. "CTRL+X" tooltip over cut symbol in standard toolbar). However, the help contains key abbreviations in their localized form (e.g. "STRG" in German help). So this is inconsistent. 

Display of non-localized CTRL key abbreviations seems independant of the Language settings, at least in my 3.3.1RC2 installation on my linux/RPM x86 KDE 3.5 machine with German langpack and helppack installed and activated.

Suggestion: The same rules should be used for both the help and the tooltips for localized/non-localized display of key abbreviations. Maybe, if non-localized key abbreviations are displayed, the help could even mention both variants (i.e. speak about e.g. "Ctrl+X (Strg+X)" to avoid understanding difficulties.

(Although the bug seems minor in my eyes, nevertheless the choice criteria for localized vs. non-localized tooltip/menu display should be documented somewhere)
Comment 1 Björn Michaelsen 2011-12-23 11:45:43 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Nino 2011-12-23 13:46:30 UTC
As I have only one LibO installation at the moment (Linux-x86-rpm) which displays identical (correct) key abbreviations in tooltip & help, I cannot reproduce this bug (which does not mean it has gone as i had seen it only in /some/ installations I did while testing different laptops). 

Also I remember somebody told me the behavior depends on the keyboard used (unfortunately I didn't find this mail). 

So I'm leaving this bug at NEEDINFO - maybe somebody adds info to it - otherwise it also can be closed and later reopened if necessary?