Bug Hunting Session
Bug 34641 - Start focus in Print dialog inconsitent
Summary: Start focus in Print dialog inconsitent
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) All
: low minor
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-23 14:58 UTC by Michael Galyuk
Modified: 2011-12-17 00:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The wrong focus in Print dialog (19.90 KB, image/gif)
2011-02-23 14:58 UTC, Michael Galyuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Galyuk 2011-02-23 14:58:37 UTC
Created attachment 43732 [details]
The wrong focus in Print dialog

Hi developers!
There is some trouble in LibreOffice as compared with OpenOffice.

When I have printed in OpenOffice in former times
focus was in "Number of copies" field and I did:
1) Ctrl+P
2) 2 (number of copies)
3) Enter
and 2 copies were printed.

Now focus is on "Print" button in LibreOffice and I am forced to do:
1) Ctrl+P
2) to use mouse to move a focus!
3) 2
4) Enter
and 2 copies print.

Please, move the focus to old place - in "Number of copies" field.
("Enter" works anytime, it don't play a role when you print one copy)
Thanks.
Comment 1 Rainer Bielefeld Retired 2011-02-23 21:39:03 UTC
[Reproducible] with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]"

The request is well fonded, indeed <enter> always will work, and so focus / caret should be somewhere in the dialog for modifications.

Additionally I believe it's a bug and not an enhancement request, because the behavior and design is inconsistent compared to other dialogs.

Compare with menu 'File > Save as' (Writer), what shows the behavior I'm used to.
After opening 'Save As' dialog
1. File name is selected, I can immediately start to type a different name
2. Button 'Save' has a blue border to show "happens when Enter"
3. none of the texts in the button has a dotted frame to show 
   "Focus on this button". Press some <TAB>, and you will see such a frame 
    around active items.

Differences in Print dialog:
1. Different behavior, no input pane selected
2. as expected
3. Different behavior, <enter> is marked with dotted frame as active
   function.

Additionally LibO behavior of print dialog differs from behavior in other WIN application. In some other ones I tested (Acrobat Reader, Seamonkey, ...) the focus is on printer selection (not on "No of copies"), so that I can select an other printer with arrow up / arrow down.

I do not know how the behavior of print is under other OS. If no arguments will be found against this, I would prefer to open print dialog with focus on printer selection as in other programs.
I agree, start focus on "No of copies" might be useful, but I would prefer consistence.

It's the same in OOo3.4-dev
Comment 2 Rainer Bielefeld Retired 2011-02-23 22:49:12 UTC
Only for the records:
OOo 1.1.4 Print dialog (WIN XP) behaved due to OS-standard
OOo 3.1.1 Print dialog (WIN XP) behaved as reported (start focus No. of copies).
Comment 3 Michael Galyuk 2011-02-24 02:48:19 UTC
Just press "Ctrl+P" in OpenOffice.org Writer and you will immediately understand what I mean.
Comment 4 Michael Galyuk 2011-02-24 03:09:36 UTC
> I would prefer to open print dialog with focus on printer selection as in other programs.

If you want to choose other printer, you may change default printer in OS.
The case of changing printer is more seldom. Usually typical user has one printer or has a necessary printer choosed as default (for instance, check you print setup right now!).

On the contrary the setting "Number of copies" is more routine situation.
Me and my colleagues checked it in many practical cases at the work.
Comment 5 Ivan Timofeev (retired) 2011-11-30 10:16:43 UTC
The focus moved to the printer selection for now, I will discuss this issue with the UX team. Changes will be in the LibreOffice 3.5.
Comment 6 Ivan Timofeev (retired) 2011-12-17 00:07:13 UTC
The focus is now on "Number of copies":
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=6e7299d31a604e58c3f27e5d00eda1210cac6d2a