Download it now!
Bug 34675 - Impress Font fuzzy in presentation mode when Use hardware acceleration enabled
Summary: Impress Font fuzzy in presentation mode when Use hardware acceleration enabled
Status: RESOLVED DUPLICATE of bug 47432
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Linux (All)
: lowest trivial
Assignee: Thorsten Behrens (CIB)
URL: https://bugzilla.novell.com/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-24 10:27 UTC by Christopher M. Penalver
Modified: 2012-11-09 12:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
BoldTechnicalFontTest.zip (70.72 KB, application/zip)
2011-02-24 10:27 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-02-24 10:27:36 UTC
Created attachment 43763 [details]
BoldTechnicalFontTest.zip

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/585910

In Ubuntu 10.10 LibreOffice Impress at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/585910/+attachment/1405216/+files/BoldTechnicalFontTest.zip && file-roller -h BoldTechnicalFontTest.zip && cd BoldTechnicalFontTest/.fonts && sudo mv TECHNICI.TTF /usr/share/fonts && sudo mv TECHNICN.TTF /usr/share/fonts && sudo fc-cache -f -v && sudo reboot

Upon restart at the Terminal:

loimpress -nologo ~/Desktop/BoldTechnicalFontTest/Desktop/BoldTechnicalFontTest.odp

Click F5 notice the font is fuzzy -> Esc -> click Tools -> Options -> LibreOffice -> View -> Uncheck Use hardware acceleration checkbox -> OK button -> F5

Notice the fuzziness is no longer present.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-impress

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.0-1maverick1
  Candidate: 1:3.3.0-1maverick1
  Version table:
 *** 1:3.3.0-1maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
Comment 1 Christopher M. Penalver 2011-02-24 10:29:27 UTC
Add https://bugzilla.novell.com/show_bug.cgi?id=594111 in URL as OOo upstream reference.
Comment 2 Christopher M. Penalver 2011-02-26 00:24:46 UTC
Reproduced in Ubuntu 10.10, LibreOffice Impress 3.3.1

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.1-1ubuntu3~maverick1
  Candidate: 1:3.3.1-1ubuntu3~maverick1
  Version table:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
Comment 3 Björn Michaelsen 2011-12-23 11:52:34 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Christopher M. Penalver 2012-01-04 01:12:12 UTC
Michael Lueck, unreproducible in:
LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

Please reopen this bug if reproducible in LOdev 3.5.0beta2+.
Comment 5 Marcel Stimberg 2012-01-28 00:06:07 UTC
This bug seems to be Linux specific, it is still reproducible with LibreOffice 3.5.0beta2 (1:3.5.0~beta2-2ubuntu4 in Ubuntu 12.04)
Comment 6 Michael Meeks 2012-01-28 02:04:27 UTC
We have an internal duplicate of this:

https://bugzilla.novell.com/show_bug.cgi?id=681110

And Thorsten is working on it; reproduced in 3.5 and master  looks like cairo using slightly different (and wrong) font substitutions / settings. Our sample - using "Nimbus Roman No9 L" is very obviously a different font.
Comment 7 Christopher M. Penalver 2012-01-28 03:20:35 UTC
Marcel Stimberg, please do not toggle the version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 8 Jan Holesovsky 2012-11-09 12:46:18 UTC
I very much believe this is a duplicate of a now fixed bug.

*** This bug has been marked as a duplicate of bug 47432 ***