Bug Hunting Session
Bug 34693 - FILESAVE: Particular .doc destroyed after saved as RTF file
Summary: FILESAVE: Particular .doc destroyed after saved as RTF file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) All
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-24 20:41 UTC by Kino
Modified: 2012-06-16 02:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Documet (1.57 MB, application/x-7z-compressed)
2012-06-15 23:48 UTC, Rainer Bielefeld Retired
Details
RTF file exported by LO 3.6.0beta1+ (1.60 MB, application/x-7z-compressed)
2012-06-16 00:51 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kino 2011-02-24 20:41:58 UTC
1. Download the following doc file:

http://classiques.uqac.ca/classiques/gaudefroy_demombynes_maurice/mahomet/gaudefroy_demombynes_mahomet.doc

2. Open it in LibreOffice Writer;

3. Save it in RTF format;

4. Close the document;

5. Open the rtf file saved at the step 3.

LibreOffice fails to open it with an error message: "General Error. General input/output error". TextEdit.app cannot open it either.

(OS X 10.6.6, Core 2 Duo 2 GHz)
Comment 1 Rainer Bielefeld Retired 2011-02-24 21:37:23 UTC
[Reproducible] with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]"
NO other application (OOo3.4-dev, OOo1.1.4, MS WIN Viewer) can open the new document, it's damaged, so FILESAVE problem.
I opened saved sample document with OOo 1.1.4 and saved it als .rtf, that file can be opened with all mentioned applications.

Saving Sample document with OOo1.1.4 I observed:
- OOo saves attidional image files 
  "gaudefroy_demombynes_mahomet114_rtf_7fdd423e.png"
  "gaudefroy_demombynes_mahomet114_rtf_m6de01be.jpg"
  "gaudefroy_demombynes_mahomet114_rtf_m198ab51f.jpg"
   (what ever that might have to do with the problem)
- Opening .rtf created with LibO OOo1.1.4 gave an useful error message expecting
  the problem at Position 86374,147(Row/Column)

@Cédric:
Can you help?
Comment 2 Jean-Baptiste Faure 2011-12-17 15:32:21 UTC
I do not reproduce the problem with LO 3.5.0 beta-1 (LibreOffice 3.5.0beta1+ 
Build ID: 6e7299d-7f15fca-8eae9f1-ca8e46d-5bcbce4) under Ubuntu 10.04 x86_64.

The new RTF filter of LO 3.5 produces a RTF file which is opened by LO 3.5 even if that costs a lot of RAM and CPU.
Abiword (version 2.8.2 provided by Ubuntu 10.04) opens the RTF too, but more quickly.

Best regards. JBF
Comment 3 Rainer Bielefeld Retired 2012-06-15 23:39:03 UTC
No fix is known, was reproduced wiht several OS.

@Jean-Baptiste Faure:
May be your good result was only lucky chance? Or Mac-Related?
I still see the problem with 3.5.5 and Master 3.7

Attached you find an rtf I created from linked source with "LibreOffice 3.5.5.1  German UI/Locale [Build-ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8] on German WIN7 Home Premium (64bit), what can'
t be opened with LibO or MS WORD VIEWER. New Bug? I am tending to reopen this bug.
Comment 4 Rainer Bielefeld Retired 2012-06-15 23:48:24 UTC
Created attachment 63102 [details]
Sample Documet

The .rtf has been created with "LibreOffice 3.5.5.1  German UI/Locale [Build-ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8] on German WIN7 Home Premium (64bit) and can't be opened with any software
Comment 5 Jean-Baptiste Faure 2012-06-16 00:51:15 UTC
Created attachment 63103 [details]
RTF file exported by LO 3.6.0beta1+

Hi Rainer,

I can't open your file with LO 3.6.0 beta1+ (Version 3.6.0beta1+ (Build ID: 70ed7be)) : general IO error message. With LO 3.5.6rc0+ and 3.5.4.2 crash  by seg-fault. 

But if I save as RTF the original ODT file I get a file that I can reopen with LO 3.6.0. The rendering is far better than in my previous tests with LO 3.5.0.

LibreOffice 3.5.4.2 and LibreOffice 3.5.6rc0+ (Version ID : c61881d-a73d29c-33cdb70-f269e46-d162a5a) opens the RTF file too.

Abiword 2.8.6 opens this RTF file too.

Tests done under Ubuntu 11.10 x86_64 with gnome-shell

Best regards. JBF
Comment 6 Rainer Bielefeld Retired 2012-06-16 02:11:22 UTC
(In reply to comment #5)
So my problem seems to be a new one, WIN related. I will submit a new Bug