Bug Hunting Session
Bug 34706 - Impress ppt missing some special characters and general error when clicking on equation
Summary: Impress ppt missing some special characters and general error when clicking o...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-25 02:55 UTC by Jiri Vyskocil
Modified: 2014-07-16 04:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
One slide from the file, fails as well (85.00 KB, application/vnd.ms-powerpoint)
2011-02-25 02:55 UTC, Jiri Vyskocil
Details
GDB backtrace from OOo 3.2.something (8.30 KB, text/plain)
2011-02-25 03:08 UTC, Jiri Vyskocil
Details
Result of PDFcreator from PPV 14 (18.21 KB, application/pdf)
2013-06-22 02:25 UTC, ign_christian
Details
Screenshot from LO 4.0.4.2 (46.14 KB, image/png)
2013-06-22 02:27 UTC, ign_christian
Details
Screenshot from LO 3.6.6.2 (84.01 KB, image/png)
2013-06-22 06:49 UTC, ign_christian
Details
Wrong symbols in LO 4.0.4.2 (56.18 KB, image/png)
2013-06-23 04:53 UTC, ign_christian
Details
Formula Shown Correct (93.64 KB, application/pdf)
2013-06-23 05:00 UTC, Joel Madero
Details
Correct rendering in MSO PPT viewer (51.68 KB, image/png)
2013-07-14 15:18 UTC, Jiri Vyskocil
Details
Incorrect rendering - LO 4.2.0.0.alpha0+ (73.60 KB, image/png)
2013-07-14 15:19 UTC, Jiri Vyskocil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Vyskocil 2011-02-25 02:55:49 UTC
Created attachment 43788 [details]
One slide from the file, fails as well

Impress 3.3.1 doesn't show some math related symbols in a ppt file. When I double click any of the equations in the file, it shows a 'General error' (Oracle's OOo v. 3.2 just dies without any info when I try to do the same)

Ths is on Gentoo amd64. I don't know which version of MSO was used to create the file.
Comment 1 Cédric Bosdonnat 2011-02-25 03:07:19 UTC
Radek, could you have a look at this one or reassign if needed?
Comment 2 Jiri Vyskocil 2011-02-25 03:08:23 UTC
Created attachment 43789 [details]
GDB backtrace from OOo 3.2.something

Since OOo 3.2 exited with a segfault, I could get a backtrace. LibreOffice just shows a 'General error' dialog box - I have no idea how to get debugging information from it.
Comment 3 Jorendc 2011-02-25 04:16:38 UTC
Reproducible with 'LibreOffice 3.3.1, Mac OSX 10.6.6, Dutch UI'. Think this is an 'all platform' bug.
Comment 4 Thomas Arnhold 2013-02-08 12:36:29 UTC
Clicking on the math formulas in impress works well with Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows 7. Is this still a problem on Linux?

MS Office 2010 says this presentation file is corrupted.
Comment 5 Jiri Vyskocil 2013-02-10 11:39:47 UTC
In LibreOffice 4.0.0.3 compiled on gentoo amd64, Impress no longer throws an error while I click on the equation. 

However:
1. Several equations are still rendered with math symbols replaced by some nonsense characters
2. It is not possible to edit the equations - double clicking does nothing.

I don't know if those are bugs or some missing features.

The attached file is one slide from a PPT presentation made with MSO (unknown version) and then saved with LO 3.3.1. Original slides were shown to us using MSO and I've never seen any error while our professor opened them. Also the equations were rendered correctly. I'm probably not allowed to upload the original file, but I can send it by email if that could help.
Comment 6 ign_christian 2013-06-04 10:34:16 UTC
Same as comment 0 :
Clicking & moving equations works well. But double clicking generates: General OLE  error.

Tested on LO 4.0.4.1 (Win7 32bit)
Comment 7 ign_christian 2013-06-05 16:20:52 UTC
Set Platform : All -> per comment 3 & comment 6
Comment 8 Joel Madero 2013-06-21 16:13:24 UTC
Maybe I'm missing something but with 4.2 master on Bodhi Linux - all equations look fine to me & no errors are thrown out when I double click -- although it asks me what I want to use to open it which I find to be slightly weird.

If not - a PDF of the original document for comparison purposes would be nice.

Marking as NEEDINFO just until we get clarification of what the issues still are on 4.0.3 (or even better, 4.1 beta2 or RC)

Once it's clarified what the problem now is mark as UNCONFIRMED again - if it's related to symbols having a document that shows what the PPT is supposed to look like would be nice. Even a jpeg of the single slide.
Comment 9 ign_christian 2013-06-22 02:25:01 UTC
Created attachment 81190 [details]
Result of PDFcreator from PPV 14

I've just check that with PPV 14 (see attached). Indeed we can see some symbol/character that incorrectly shown using LO 4.0.4.2.
Comment 10 ign_christian 2013-06-22 02:27:10 UTC
Created attachment 81191 [details]
Screenshot from LO 4.0.4.2
Comment 11 ign_christian 2013-06-22 06:49:34 UTC
Created attachment 81195 [details]
Screenshot from LO 3.6.6.2

I've just check again using LO 3.6.6.2 Ubuntu 12.04 32bit.

Symbol & character correctly shown (see attached). As far as I remember, 4.0.3 also produced same result (correct).

So it's regression on 4.0.4 release
Comment 12 Joel Madero 2013-06-22 23:48:48 UTC
So is it still NEEDINFO or can we mark as NEW?
Comment 13 ign_christian 2013-06-23 03:03:47 UTC
Perhaps you could decide. I tested that 4.0.4 showing incorrect symbols & double clicking also generated something weird.

But you said that symbols correct with 4.2 master. Maybe that symbols could be corrected on 4.0.5?
Comment 14 Joel Madero 2013-06-23 03:32:32 UTC
Or I'm just an idiot and missed the incorrect symbols ;) Is there any way that we can get a document that highlights (circled or some such) the errors?
Comment 15 ign_christian 2013-06-23 04:53:44 UTC
Created attachment 81238 [details]
Wrong symbols in LO 4.0.4.2

Of course not :) it's not invisible to the eye among lot of symbols there. Please see attached file with red circled, that symbols replaced by "big dot".
Comment 16 Joel Madero 2013-06-23 04:59:42 UTC
Interesting - yeah looks good with 4.2 master so marking as WFM

@Jiri - you should see a fix in 4.2 and probably 4.1 RC (available now on pre-release page)

Attached pdf of what I see
Comment 17 Joel Madero 2013-06-23 05:00:00 UTC
Created attachment 81239 [details]
Formula Shown Correct
Comment 18 Jiri Vyskocil 2013-07-14 15:16:10 UTC
I can still reproduce the bug using 4.2.0.0.alpha0+, but it might be some Linux specific problem. Joel's screenshot looks almost right, but there are still some rendering glitches - the dots in the centre of closing parentheses.

I attached screenshot form LO 4.2.0.0.alpha0+ and MS PowerPoint viewer.
Comment 19 Jiri Vyskocil 2013-07-14 15:18:24 UTC
Created attachment 82412 [details]
Correct rendering in MSO PPT viewer
Comment 20 Jiri Vyskocil 2013-07-14 15:19:54 UTC
Created attachment 82413 [details]
Incorrect rendering - LO 4.2.0.0.alpha0+
Comment 21 ign_christian 2013-07-15 01:55:28 UTC
Looks like inconsistency in rendering with LO 4.x.x:
- LO 4.0.4.2 (comment 10) -> some symbols replaced by dots
- LO 4.2 master (comment 17) -> middle of right parenthesis replaced by divider mark
- LO 4.2 alpha0+ (comment 20) -> many symbols & parenthesis replaced by wrong characters (so it's the worst result)

Best result (correct) produced by LO 3.6.6.2 (comment 11)

So we should reopened it right? Can we mark regression against 3.6?
Comment 22 tommy27 2014-07-16 04:06:41 UTC
I see correct rendering in LibO 4.2.5.2 under Win7x64
feel free to reopen if you still reproduce the bug