Bug Hunting Session
Bug 34792 - Field labels truncated in Bibliography database dialog
Summary: Field labels truncated in Bibliography database dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-27 05:23 UTC by Fabian Rodriguez
Modified: 2013-05-28 18:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Rodriguez 2011-02-27 05:23:32 UTC
The labels for several fields in the column layout configuration dialog of the Bibliography tool are truncated. Tested in Ubuntu 10.10 and Windows XP.

The Windows version doesn't show this problem which doesn't seem to be language-specific (tested French & English) but it's worse in languages where strings are longer.

Steps to reproduce:

1- Open LibreOffice Writer
2- Go to Tools > Bibliography database
3- Go to Edit > Column arrangement
4- Notice how the user defined fields are truncated. More fields appear truncated in French

Workaround:

In Ubuntu 10.10, make your system font smaller in System > Preferences > Appearance > Fonts.
Comment 1 Fabian Rodriguez 2011-02-27 05:28:39 UTC
Pierre-Yves Samyn suggested going to:
Tools > Options > LibreOffice > View 
and unchecking "Use system font for user interface" but this only truncates a bit less of the field labels.
Comment 2 Björn Michaelsen 2011-12-23 11:49:14 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-01-20 05:40:58 UTC
IMHO if this dialog window will be resizeable, all described problem disappears.
another bugreport about resize:
Bug 34559 - Complex Dialogs should be resizable
Comment 4 Florian Reisinger 2012-08-14 14:01:48 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:02:51 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:07:25 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:09:32 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 sasha.libreoffice 2012-08-16 08:40:40 UTC
reproduced in 3.6.0. Reopening.
IMHO problem may be fixed also by reducing font size.
Comment 9 Not Assigned 2012-09-17 08:04:37 UTC
sagar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b079fd5a1be6628ac15b443a67698771dd716b83

fdo#34792 - Fix for truncated field labels in Bibliography database dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 sasha.libreoffice 2012-09-17 11:05:44 UTC
Thanks for fixing this bug
Comment 11 Björn Michaelsen 2013-05-28 18:18:46 UTC
Seems to be fixed as per comment 9.