Bug 34873 - AutoFilter - Not showing count
Summary: AutoFilter - Not showing count
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Dennis Francis
URL:
Whiteboard: target:5.2.0
Keywords:
: 103007 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-01 08:03 UTC by Martijn
Modified: 2019-04-12 09:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
autofilter count (50.59 KB, image/gif)
2011-03-01 08:03 UTC, Martijn
Details
autofilter2 (140.54 KB, image/gif)
2011-03-02 01:30 UTC, Martijn
Details
Screenshot of OOo autofilter (58.12 KB, image/png)
2011-06-13 01:33 UTC, Stephan Zietsman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martijn 2011-03-01 08:03:19 UTC
Created attachment 43971 [details]
autofilter count

When applying an AutoFilter to a spreadsheet there's no way to see the row-count of the selection. 
Both Excel and Symphony show the count on the bottom statusbar. In LB there is a 'count' option in the status bar, but it remains on "0". In OOo this is working as it should.
Comment 1 Cédric Bosdonnat 2011-03-01 08:45:40 UTC
This is not a bug. The count on the status bar is just showing the number of selected numeric values. On the screenshot you selected only one cell containing "b"... that is not a numeric value.
Comment 2 Martijn 2011-03-01 09:01:03 UTC
thx for the reply, but if it isn't a bug then it must be a missing feature, since all other spreadsheet editors can show the row count of a selected filter. 
I don't have a OOo installation at hand, but there is definately an option to see this.
Comment 3 Martijn 2011-03-01 09:07:02 UTC
additional info, looks like in OOo this is called "Number" or "Number2", and not "Count" (so let me apologize for the confusion) but in the same selection menu as on the screenshot, and seems to be missing in LB.
Comment 4 Cédric Bosdonnat 2011-03-02 00:13:29 UTC
(In reply to comment #3)
> additional info, looks like in OOo this is called "Number" or "Number2", and
> not "Count" (so let me apologize for the confusion) but in the same selection
> menu as on the screenshot, and seems to be missing in LB.

In your screenshot, these are corresponding to "Count" and "CountA". CountA counts the number of values numeric or not in the selected cells.

The "Feature" you are requiring is already implemented by this: I don't see the point in adding anything more to count rows.
Comment 5 Martijn 2011-03-02 01:30:36 UTC
Created attachment 44008 [details]
autofilter2

see bug desciption
Comment 6 Martijn 2011-03-02 01:41:43 UTC
Yes, what you're saying is that Count is for the 'selected cells', correct. But that is in-depended from the AutoFilter selection, and not the intention of this report. 

What I miss is one that tells me how many rows there are in the selected criteria of the autofilter, see the new screenshot attached: https://bugs.freedesktop.org/attachment.cgi?id=44008

True in the example above I could select all cells to get the count, but the sheets I'm working with daily are more like; 2690 out of 12000, manually selecting is no real option here. 

OOo used the be able to show that too, possibly with the Number or Number2 function, but unfortunately I can't test that right now. 

(The Symphony version 3.0 I'm using is based on OOo 3.0.0 code afaik, so it has been done before..).
Comment 7 Cédric Bosdonnat 2011-03-02 01:47:18 UTC
Kohei, could you evaluate that feature?
Comment 8 Stephan Zietsman 2011-06-13 01:33:47 UTC
Created attachment 47883 [details]
Screenshot of OOo autofilter

The attachment shows no such "x out of y records found" in OOo.
Comment 9 Stephan Zietsman 2011-06-13 01:35:10 UTC
(In reply to comment #8)
> Created an attachment (id=47883) [details]
> Screenshot of OOo autofilter
> 
> The attachment shows no such "x out of y records found" in OOo.

Screenshot was taken of OOo 3.2.0, on a Win7 x64 system
Comment 10 Joel Madero 2014-11-04 03:00:44 UTC
I haven't seen this confirmed by anyone - REOPENED is incorrect regardless as the bug isn't assigned to anyone. Also removing feature from whiteboard as that's incorrect.

Marking as UNCONFIRMED so QA team can have a fresh look at it.
Comment 11 raal 2014-11-05 07:56:38 UTC
Setting as NEW, valid enhancement. Workaround select filtered data and in the bottom toolbar select "number of selected", but this is useful only in small count of selected items.
Comment 12 Dennis Francis 2015-11-23 20:13:46 UTC
Submitted a patch for review at https://gerrit.libreoffice.org/#/c/20134/
Comment 13 Commit Notification 2016-01-21 20:50:12 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3536fe8f4cdbacf5702e743407f34d918b6f4d38

tdf#34873 : Show autofilter row count in status bar

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2016-02-03 13:25:44 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e619fdf9e79cb49895d83fe7f5a1f373495b915

tdf#34873 : Better way to show autofilter count

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 raal 2018-06-12 20:02:30 UTC
*** Bug 103007 has been marked as a duplicate of this bug. ***