Bug 34911 - FILEOPEN MSO2007 .docx TABLE does not have page break before row exceeding page bottom
Summary: FILEOPEN MSO2007 .docx TABLE does not have page break before row exceeding pa...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2011-03-02 03:36 UTC by leighman
Modified: 2015-12-15 11:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problem file (99.45 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-03-02 03:36 UTC, leighman
Details
How the file should look - Word 2007 (160.99 KB, image/png)
2011-03-02 03:37 UTC, leighman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leighman 2011-03-02 03:36:27 UTC
Created attachment 44014 [details]
Problem file

Upstreaming from https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/726454

When opening the attached file in LibreOffice in Linux the table is stretched downwards and takes up much more space than when viewed in Word 2007.

The file was produced in Word 2007.
Also apparently displays correctly in OpenOffice on Windows
Comment 1 leighman 2011-03-02 03:37:25 UTC
Created attachment 44015 [details]
How the file should look - Word 2007
Comment 2 Cédric Bosdonnat 2011-03-02 07:04:08 UTC
Noel, for you?
Comment 3 Rainer Bielefeld Retired 2012-05-07 06:03:57 UTC
After having deleteted picture (invisible with MS WORD Viewer), what seems to be the main problem here, I see a problem that in WRITER Row with 
"LIBRARY Ms Evelina And I" is additionally shown on first page, while in MS WORD viewer that "main row" will be shown on next page.
My knowledge is not sufficient to decide whether that's a general WRITER limitation or related to docx import.

No reaction within a year, so reassigned to List.

@leighman
Such a Multi problems Bug will never be fixed (as you see), we will have to divide into separate bugs for each problem.
<https://wiki.documentfoundation.org/BugReport#General_information>

Please feel free to submit additional Reports (with reference to this sample document) for separate problems you see (and to add me to CC).
Comment 4 Teo91 2013-09-29 19:12:15 UTC
I confirm some mistakes with LO 4.1.1 on Windows 7: 
- pages 2 and 3 are lost
- on page 1, the table appears "cut" at the bottom of the page
Comment 5 Alexandr 2014-08-11 17:39:24 UTC
I reproduce the issue described in comment 4 with LibreOffice 4.2.5 and 4.3.1.1 on Linux.
Comment 6 Alexandr 2014-11-21 19:32:14 UTC
The issue is reproducible in LibreOffice 4.4.0.0-beta1 the same way as in 4.3
Comment 7 Matthew Francis 2015-04-10 07:50:16 UTC
The issues mentioned in comment 4 postdate this report. The original issue does not seem to be relevant to the current rendering.

-> RESOLVED WORKSFORME

(Most likely there is a duplicate report for the later issue - I will find/create it and comment the bug number here later)
Comment 8 Matthew Francis 2015-04-10 11:06:23 UTC
Bug for floating tables not splitting across pages: bug 61594
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:51:44 UTC
Migrating Whiteboard tags to Keywords: (filter:docx)
[NinjaEdit]