Bug Hunting Session
Bug 35020 - Find & Replace changes case of sheet name in formulas Windows XP
Summary: Find & Replace changes case of sheet name in formulas Windows XP
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-04 08:45 UTC by Bill Kirby
Modified: 2019-01-01 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of error (232.85 KB, image/jpeg)
2011-03-04 08:45 UTC, Bill Kirby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Kirby 2011-03-04 08:45:05 UTC
Created attachment 44131 [details]
screen shot of error

When using a multi-sheet spreadsheet that has a formula on one sheet that retrieves data from another sheet. Using find & replace to make change in cell number will change the case of the sheet's name from uppercase to lowercase causing the formula to fail. I've included a screen shot to help explain what I'm seeing. If you look at the formula bar you will see the sheet name is lowercase. If you look at the tabs at the bottom of the spreadsheet you will see that the sheet name is actually uppercase. Before I do the find & replace, the formula contains uppercase letters for the sheet name. This happens on Windows XP but not in Ubuntu 10.10
Comment 1 Don't use this account, use tml@iki.fi 2011-03-07 01:32:14 UTC
For Kohei?
Comment 2 Cor Nouws 2011-05-13 06:21:36 UTC
Cannot reproduce this in LibreOffice 340 beta5, with simple formula e.g
  =A6+NAMESECONDSHEET.C$16

Could you pls check in this version too?
Thanks, Cor
Comment 3 Rainer Bielefeld Retired 2011-07-15 06:54:18 UTC
Also NOT reproducible with own test document and "LibreOffice 3.4.1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]".

@reporter:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport> (especially BugReport Details)!
Comment 4 Commit Notification 2019-01-01 13:09:47 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2c7b0030b40de00e8c9ab997bdfe83631861968a%5E%21

uitest for bug tdf#35020

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.