Bug Hunting Session
Bug 35021 - DOC TabOverMargin doesn't work for Left or Center margins
Summary: DOC TabOverMargin doesn't work for Left or Center margins
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-04 08:49 UTC by Ekeis
Modified: 2018-04-26 12:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example Word document (20.00 KB, application/msword)
2011-03-04 08:49 UTC, Ekeis
Details
This is what I want to have (17.82 KB, image/png)
2011-03-04 08:51 UTC, Ekeis
Details
This is what I get (17.77 KB, image/png)
2011-03-04 08:51 UTC, Ekeis
Details
word_tabOverMargin.doc: is this what you were trying to accomplish? (10.50 KB, application/msword)
2016-12-26 05:20 UTC, Justin L
Details
Different behaviour of Word an LO Writer (113.96 KB, image/png)
2016-12-30 10:19 UTC, Ekeis
Details
Different behaviour of Word an LO Writer (DOC-document) (23.00 KB, application/msword)
2016-12-30 10:20 UTC, Ekeis
Details
tabOverMarginDemo.doc: test document exhibiting various tab situations (11.00 KB, application/msword)
2016-12-31 15:55 UTC, Justin L
Details
tabOverMarginDemo_w2013.pdf: how the demo looks in MS Office (5.27 KB, application/pdf)
2016-12-31 15:59 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ekeis 2011-03-04 08:49:15 UTC
Created attachment 44132 [details]
Example Word document

I want to format a paragraph with before-text=0,76 / after-text=3,62 / first-line=-0,76 / tab=16,68. The important thing is that the tab is NOT within the area which is delimited by the before- and after-text limits. The behaviour of Writer is that the tab is ignored and the text after the tab is placed at the after-text-border.

It seems to be an systematic problem. If you edit a word document with the upper indents it works fine. The tab-text is placed outside the delimited area. If you open this document with LibreOffice the text is shown on the right limit of the after-text.

I added an attachment of the example word document and two screenshots of what I want (it's edited with a graphic program) and what I get in LibreOffice.
Comment 1 Ekeis 2011-03-04 08:51:15 UTC
Created attachment 44133 [details]
This is what I want to have
Comment 2 Ekeis 2011-03-04 08:51:56 UTC
Created attachment 44134 [details]
This is what I get
Comment 3 Ekeis 2011-03-06 05:53:24 UTC
Comment on attachment 44133 [details]
This is what I want to have

Edited by GIMP ;-)
Comment 4 Ekeis 2011-03-06 05:54:03 UTC Comment hidden (duplicate, obsolete)
Comment 5 Don't use this account, use tml@iki.fi 2011-03-07 01:14:19 UTC
For Cedric?
Comment 6 Ekeis 2011-07-12 12:10:47 UTC Comment hidden (no-value)
Comment 7 Ekeis 2012-06-05 08:35:58 UTC Comment hidden (no-value)
Comment 8 Ekeis 2012-09-21 07:59:10 UTC Comment hidden (no-value)
Comment 9 QA Administrators 2015-04-01 14:42:17 UTC Comment hidden (obsolete)
Comment 10 Ekeis 2015-04-01 15:27:35 UTC
The bug still remains in
Version: 4.4.1.2
Build-ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Gebietsschema: de_DE
Comment 11 tommy27 2016-04-16 07:28:30 UTC Comment hidden (obsolete)
Comment 12 Ekeis 2016-04-16 08:09:51 UTC
The bug still remains in
Version: 5.1.2.2
Build-ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
Gebietsschema: de_DE

Reported more than five years ago. Tested in almost every version since then. Still the same thing...
Comment 13 Justin L 2016-12-26 05:20:37 UTC
Created attachment 129940 [details]
word_tabOverMargin.doc: is this what you were trying to accomplish?

I think that this has been fixed since LibreOffice 4.3 by:

author	Miklos Vajna <vmiklos@suse.cz>	2013-01-08 10:57:13 (GMT)
commit	bdfc6363d66aa079512cc8008996b633f693fed1
   n#793998 sw: add TabOverMargin compat mode

Please note that if you are creating this document from scratch in Libreoffice, likely you would need to save as .doc format, exit, and then reload before you are able to have the tab go past the margin, since this is a valid setting only for something Writer knows is a .doc or .docx.

If you still think that this is not fixed, please attach a new sample document that works in MSWord, but doesn't work in LO.  (The document provided in the description looks the same in Word as in LO to me.  Unfortunately, your sample pictures do not match your provided word.doc)
Comment 14 Ekeis 2016-12-30 10:19:56 UTC
Created attachment 130024 [details]
Different behaviour of Word an LO Writer
Comment 15 Ekeis 2016-12-30 10:20:58 UTC
Created attachment 130025 [details]
Different behaviour of Word an LO Writer (DOC-document)
Comment 16 Ekeis 2016-12-30 10:21:19 UTC
Version: 5.2.3.3
Build-ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU-Threads: 4; BS-Version: Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE);

In my opinion it still doesn't work (see NEW screenshot and associated  word-example).

For example, in technical documents it is often not possible to have short headings in a table of content. So, if it worked, I think the behaviour would really makes sense.

For example if you want to make a table of content 
- with headings spanning two lines or more 
- and left- and right alignment 
- and having the chapter number out of the block on the left side (negative indent of first line)
- and having the page number out of the heading-block on the right side.
Comment 17 Justin L 2016-12-30 12:41:37 UTC
(In reply to Ekeis from comment #15)
> Created attachment 130025 [details]
> Different behaviour of Word an LO Writer (DOC-document)

Thanks for the example document.  So, currently tabOverMargin works for right and decimal tabs, but not for left and centered tabs (which I notice are dangerous [in MSWord] because long text will just disappear off of the end of the page since it doesn't wrap).

But yes, it is a compatibility issue.
Comment 18 Justin L 2016-12-31 15:55:35 UTC
Created attachment 130057 [details]
tabOverMarginDemo.doc: test document exhibiting various tab situations
Comment 19 Justin L 2016-12-31 15:59:40 UTC
Created attachment 130059 [details]
tabOverMarginDemo_w2013.pdf: how the demo looks in MS Office

proposed fix for center/decimal tabs - https://gerrit.libreoffice.org/#/c/32534/
proposed fix for left tab - https://gerrit.libreoffice.org/32539
Comment 20 Ekeis 2017-01-02 09:07:47 UTC
I can confirm the TabOverMargin-behaviour works if you save the document as DOC an reopen the DOC-document as it was described earlier. However if you save it as ODT text on TabsOverMargin will fall back to the right limit. This is sad.

Do you think it is possible to bring this (Word-)functionality to LO? I'd really appreciate this way of treating TabsOverMargin because I want to use the ODT format.
Comment 21 Justin L 2017-01-02 09:18:00 UTC
(In reply to Ekeis from comment #20)
> Do you think it is possible to bring this (Word-)functionality to LO?
Don't hold your breath waiting for that.  I highly doubt anyone would change this.  TabOverMargin is there for compatibility with MSOffice, but it would break ODT compatibility if it was changed.

> I want to use the ODT format.
I believe that once the compatibility setting is inside of the document, that it will remain.  So, a trick would be to start a blank document, save as .doc, close, and reopen, and then save as .odt.  That would set the compatibility setting, but also give you the stability of proper ODT file structure.
Comment 22 Commit Notification 2017-01-17 08:32:15 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a9367c1b39600d5a5e2d0067113f06ad59cc37a1

tdf#35021 TabOverMargin: support center and decimal tabs also

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2017-01-18 09:07:41 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=441d7e046df36900bbf14b37277b15d615f67641

tdf#35021 TabOverMargin: support LEFT tabs also

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2017-01-19 04:12:38 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c817d73402583f1b077d31a695c565a53468887

tdf#35021 TAB_OVER_MARGIN pdf support for left/center/dec

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Justin L 2017-01-19 04:16:23 UTC
added print/pdf support for tab over margin as described in bug 93637