Bug 35041 - Improve 'Link to External Data' concerning CGI
Summary: Improve 'Link to External Data' concerning CGI
Status: RESOLVED DUPLICATE of bug 35040
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL: http://www.saia-pcd.com/en/products/p...
Whiteboard:
Keywords:
Depends on: 35040
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-05 11:17 UTC by Rainer Bielefeld Retired
Modified: 2013-05-12 13:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-03-05 11:17:36 UTC
Currently a disadvantage of LibO comparing to EXCEL is that cgi import does not work. This function for example can be used to read data via net from a Programmable Logic controller or other devices.

Further information for real applications you can find on a. m. URL
or German:
<http://www.saia-pcd.com/en/products/plc/it/Pages/cgi.aspx>

That currently will not work for several reasons

Normally you can use Menu
'Insert > Link to External Data' , you can test with 
<http://finance.yahoo.com/q/cq?s=INTC,SCHW>, what was a test URL
<http://openoffice.org/bugzilla/show_bug.cgi?id=103964>

With this URL function works, When I enter it an press Enter, after few  moments Language selection appears and after that I get a selection with several html items. All will work.

Now I found a real existing PLC to test the function with LibO
You can use 
<http://s-web-demo.sbc-support.ch/Start_de.html>
alternatively
<http://81.6.54.125/>
You find the PLC's Webserver showing process in a web browser (using JAVA).
URL 
<http://s-web-demo.sbc-support.ch/cgi-bin/readVal.exe?PDP,,R2348,d>
will show the real time clock time in the browser

The first problem: Bug 35040 - No Link to particular External Data

Inserting 
<http://s-web-demo.sbc-support.ch/cgi-bin/readVal.exe?PDP,,R2348,d>
Into the URL pane, a data link will be established, but strange, no available range will appear, but the insert plain text dialog will open. In the dialog you will see the correct Value for current time, but I failed to insert the value into cell. Even if that would be possible, for my needs data has to be update every xx seconds, a static value would be useless.
Comment 1 Rainer Bielefeld Retired 2011-03-05 11:19:21 UTC
I believe this one can not be fixed before
Bug 35040 - No Link to particular External Data
Comment 2 Joel Madero 2012-08-02 21:36:14 UTC
Rainer, can we move this to NEW (is it confirmed)?
Comment 3 sasha.libreoffice 2012-11-23 12:27:17 UTC
currently all 4 links mentioned in this bugreport not working.
May be exist something another for testing?
Comment 4 Rainer Bielefeld Retired 2012-11-23 14:32:04 UTC
Indeed, currently the examples do not work.

I will check this next week, contribute links to working demos and "relaunch" this bug ;-)
Comment 5 Rainer Bielefeld Retired 2012-12-31 12:42:52 UTC
Still no "live demos" with documentation available.
Comment 6 Niklas Johansson 2013-05-12 11:30:41 UTC
I did some testing with LibreOffice 4.0.3.3 and part of these examples does work, at least on Win7 64-bit Swedish. 

> Further information for real applications you can find on a. m. URL
> or German:
> <http://www.saia-pcd.com/en/products/plc/it/Pages/cgi.aspx>
This link seems to have expired. 

> 
> Normally you can use Menu
> 'Insert > Link to External Data' , you can test with 
> <http://finance.yahoo.com/q/cq?s=INTC,SCHW>, what was a test URL
> <http://openoffice.org/bugzilla/show_bug.cgi?id=103964>
> 
> With this URL function works, When I enter it an press Enter, after few 
> moments Language selection appears and after that I get a selection with
> several html items. All will work.

As you state, it works, still does.

> 
> Now I found a real existing PLC to test the function with LibO
> You can use 
> <http://s-web-demo.sbc-support.ch/Start_de.html>

So I can't even get this one to work in Excel 2010. Might be due to all the security warnings I get though. But I do get it up and running in the web browser.

> alternatively
> <http://81.6.54.125/>
This works as expected for me. 

> You find the PLC's Webserver showing process in a web browser (using JAVA).
> URL 
> <http://s-web-demo.sbc-support.ch/cgi-bin/readVal.exe?PDP,,R2348,d>
> will show the real time clock time in the browser

So this does not work since OK button is grayed out. See Florian Birchers comment on bug 35040: https://bugs.freedesktop.org/show_bug.cgi?id=35040#c2

I think Birchers comment zooms in on the current bug. That bug exists in Apache OpenOffice as well.
Comment 7 Florian Reisinger 2013-05-12 13:21:08 UTC
Hi,

As zhis is a duplicate of a different bug changing to RESOLVED DUPLICATE

*** This bug has been marked as a duplicate of bug 35040 ***