Download it now!
Bug 35063 - File properties change doesn't mark document as modified
Summary: File properties change doesn't mark document as modified
Status: RESOLVED DUPLICATE of bug 32177
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Windows (All)
: medium minor
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-06 09:18 UTC by Federico Del Bene
Modified: 2011-03-24 05:51 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Del Bene 2011-03-06 09:18:18 UTC
The changes to the properties of a .odt file are not recognized as a document change and will not activate the save button.

To save these changes one need to do a change in the document, revert it, and save.
Comment 1 Don't use this account, use tml@iki.fi 2011-03-06 23:47:23 UTC
This bug report is mostly useless. Please describe in much greater detail what you do, what happens, and what you expect to happen. What is especially confusing is that you talk about changing the properties of a *file*. Do you really mean that, changing the properties of the file that is being edited in LibreOffice? Or do you mean changing the properties of the document inside LibreOffice?
Comment 2 Federico Del Bene 2011-03-07 08:04:19 UTC
I thought it was clear that I was referring to the menu File -> Properties.

If you open a file by double clicking on it, wait until the file open in LibO, move the mouse to the menu "File", click on it, move the mouse over the "Properties" entry ("Proprietà..." in Italian) and click it, it will open a new window where you can edit the file's properties.

For example you can add a personalized property, or add a comment to the file.

Whatever you do, if you click OK and close the window, you'll will NOT have the possibility to save the file (the entry "Save" in the file menu, and the "Save" button are greyed out).

If you now close the file you will lose your changes.

To save them you'll have to edit the file by, in example, typing a letter and cancelling it, and then save the file.

What I expect to happen is that after a change to the file properties you'll have the possibility to save the file as it happens in LibO Calc.
Comment 3 Federico Del Bene 2011-03-07 08:48:11 UTC
Upgrading from

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

to

LibreOffice 3.3.1 
OOO330m19 (Build:8)
tag libreoffice-3.3.1.2

didn't solve the problem.

I'm using Windows 7 Sp1 x64. Both Windows and LibO are Italian version.
Comment 4 Don't use this account, use tml@iki.fi 2011-03-07 10:05:23 UTC
> I thought it was clear

Nothing is clear, our mind-reading capabilities are somewhat broken at the moment.
Comment 5 Federico Del Bene 2011-03-07 10:14:03 UTC
Dear Tor, if you just want to polemize go ahead (without me).
I didn't accuse your comments to be useless (or rude), nor I accused you of not switching on the brain for a simple comprension task.

If you care to help, do it, otherwise your comment are just driving me away from reporting other bugs.

Thank you.
Comment 6 Don't use this account, use tml@iki.fi 2011-03-07 23:11:52 UTC
Sorry if you were offended. Please don't go away, but do try to be more detailled in the future when reporting bugs. You should realize that developers actually use LibreOffice much less than users do, so it was not clear at all that you meant the File:Properties menu entry. (In fact, I would not have known that LibreOffice has such a menu entry.)
Comment 7 Don't use this account, use tml@iki.fi 2011-03-07 23:24:08 UTC
For Cedric? I guess this is mostly a policy question; whichever way it is done somebody will complain.
Comment 8 Federico Del Bene 2011-03-08 02:26:34 UTC
Tor, Cédric, consider to mark this bug as a duplicate of older bug report 32177.
Comment 9 Thomas M. 2011-03-24 05:51:22 UTC

*** This bug has been marked as a duplicate of bug 32177 ***