Bug 35065 - Bullets changing to different character when converted to Word in Windows
Summary: Bullets changing to different character when converted to Word in Windows
Status: RESOLVED DUPLICATE of bug 34814
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Noel Power
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-06 11:22 UTC by westley52
Modified: 2013-11-24 18:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip file containing documents and png of the issue (30.91 KB, application/zip)
2011-03-06 11:22 UTC, westley52
Details

Note You need to log in before you can comment on or make changes to this bug.
Description westley52 2011-03-06 11:22:46 UTC
Created attachment 44180 [details]
Zip file containing documents and png of the issue

I have an original document with a few bullet points saved as a .odt.  The file is then saved as Word 97/2000/XP .doc in a Windows XP or 2007 environment.  When the .doc is opened in LibreOffice the bullet character changes to what appears to be a 0xF1 character.  I have attach some pictures and the documents to demonstrate.
Comment 1 Don't use this account, use tml@iki.fi 2011-03-06 23:41:08 UTC
Please, if you have a couple of files to attach, in the future just attach each one separately. No need to package them into a zip archive.

Also, please describe in greater detail what you did. What application (what version) did you use to read the original .odt document and save it as .doc? What does "Windows XP or 2007 environment" mean? There is nothing called "Windows 2007", and why the "or"? Do you mean Microsoft Office 2007 on Windows XP?
Comment 2 westley52 2011-03-07 09:58:38 UTC
(In reply to comment #1)
> Please, if you have a couple of files to attach, in the future just attach each
> one separately. No need to package them into a zip archive.
> 
> Also, please describe in greater detail what you did. What application (what
> version) did you use to read the original .odt document and save it as .doc?
> What does "Windows XP or 2007 environment" mean? There is nothing called
> "Windows 2007", and why the "or"? Do you mean Microsoft Office 2007 on Windows
> XP?


Thanks for the reply.  The reason that I zipped the file was that it seemed as I could only load one file before hitting the "confirm" link.  I will load files separately next time.

As to the application that I used - I only used: 

LibreOffice 3.3.1 
OOO330m19 (Build:8)
tag libreoffice-3.3.1.2

I tested this problem using the same version of LibreOffice on a Windows XP machine and on a Windows 7 machine ( I did not mean 2007 - my fingers did not type what I meant - sorry ).  I do not have MS Office 2007 loaded at all.

Hope this helps clarify my earlier post.
Comment 3 westley52 2011-03-07 17:41:19 UTC
Following are steps to recreate the problem

1.  Start a new text document in LibreOffice.
2.  Create a document with bullets.  ( I am using Times New Roman 12 points )
3.  Save the document in Microsoft Word 97/2000/XP ( .doc ) format.
4.  Close LibreOffice.
5.  Reopen LibreOffice.
6.  Open previously saved document, and the bullets are not the same character.
Comment 4 Don't use this account, use tml@iki.fi 2011-03-07 23:26:36 UTC
Thanks for the clear reproduction instructions!
Comment 5 Raymond 2011-04-13 08:34:59 UTC
I am alao having the EXACT same issue.  When I change a document to Microsoft Word format, I am getting the same changes in the bullet characters.
Comment 6 voraxor 2011-05-05 03:54:20 UTC
Same issue still exists in LibreOffice 3.3.2 final release version.

This is quite an important issue if interoperability with word users is needed.
Comment 7 Raymond 2011-05-06 13:29:38 UTC
Please fix this as soon as possible.  Before trying LibreOffice, I was using OpenOffice.org.  This bug did not exist in OpenOffice.
Comment 8 Noel Power 2011-05-09 02:41:29 UTC
still in 3.4 beta, not just windows either but also linux ( although for some reason seems to display correctly on linux ) - guess I could try and have a look at this
Comment 9 westley52 2011-05-10 06:47:14 UTC
(In reply to comment #8)
> still in 3.4 beta, not just windows either but also linux ( although for some
> reason seems to display correctly on linux ) - guess I could try and have a
> look at this


I would be fantastic it you could look at this.  I can see where this type of bug could very quickly stop new people adopting LibreOffice and leaving the MS offering behind.
Comment 10 westley52 2011-06-29 05:04:04 UTC
Last night, my wife had to send out a resume written using LibreOffice to a company in Word format.  The bulletpoints looked great in LibreOffice, but when saved in any Word format the bulletpoints would convert to the triangle shaped object.  This meant that she has to use MS Word for fix this problem as the company would only accept Word formatted resumes at this time.  I sincerely hope that this issue can be resolved easily and soon.  Thanks.
Comment 11 sergey 2011-07-06 02:08:38 UTC
I give another confirmation of existence of this bug.

This is serious flaw in MSOffice interoperability.
The bug affects MS Word formats 6.0-2007 and does not affect RTF
Comment 12 Rainer Bielefeld Retired 2011-07-14 22:59:19 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 13 sergey 2011-07-14 23:20:31 UTC
3.4.1 version affected
Comment 14 sergey 2011-07-14 23:22:04 UTC
(In reply to comment #13)
> 3.4.1 version affected

LibreOffice 3.4.1 
OOO340m1 (Build:103)
Windows XP/Intel x32
Comment 15 westley52 2011-07-15 03:15:14 UTC
For me, this bug showed up either in the first version of LibreOffice, or very shortly thereafter.  The bug is definitely not in the last version of OpenOffice that was released by Sun.
Comment 16 sergey 2011-07-24 22:39:59 UTC
There are workaround (checked for versions 3.3.3 and 3.4.1):

when right-click on selected text and choose "Numbering/Bullets..." go to options and select button labeled "Character". There are already selected U+2022 - just click on it and press OK. Nothing seems changed but afterwards the bullet symbol remains in MSO-format files.

And, only "small disk" bullet symbol is affected, black or colored.
Comment 17 Cor Nouws 2011-07-25 15:22:21 UTC

*** This bug has been marked as a duplicate of bug 34814 ***