Bug 35154 - export to PDF with notes : slides are printed twice
Summary: export to PDF with notes : slides are printed twice
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2011-03-09 07:15 UTC by Laurent Godard
Modified: 2017-11-28 18:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test data (11.10 KB, application/vnd.oasis.opendocument.presentation)
2011-03-09 18:32 UTC, Yifan Jiang
Details
pdf export result (18.91 KB, application/pdf)
2011-03-09 18:33 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2011-03-09 07:15:04 UTC
consider a presentation with slides and notes on them

exporting to PDF with the option notes leads to a PDF file that contain
- all the slides, alone on each page
- all the slides + notes

Usually, when printing notes to PDF, user do not care about the slides in the PDF alone.

The PDF export in case of notes ares selected in options should only print the second set of pages : the slide itself on half a page and the notes
Comment 1 Laurent Godard 2011-03-09 07:32:50 UTC
this behaviour was correct before OOo 3.3
Comment 2 Yifan Jiang 2011-03-09 18:32:59 UTC
Created attachment 44293 [details]
test data
Comment 3 Yifan Jiang 2011-03-09 18:33:25 UTC
Created attachment 44294 [details]
pdf export result
Comment 4 Yifan Jiang 2011-03-09 18:33:41 UTC
Confirmed reproducible on Libreoffice 3.3.1 SLED 11 sp1.

When I use evince to open the produced pdf, the pages containing Slide+Notes seem not indexed well. Namely, I can only navigate through Slide only pages via the Index link on the left side Index panel. I attached testing files here as well.
Comment 5 Yifan Jiang 2011-03-09 18:35:14 UTC
(In reply to comment #4)

> When I use evince to open the produced pdf, the pages containing Slide+Notes
> seem not indexed well. Namely, I can only navigate through Slide only pages via
> the Index link on the left side Index panel. I attached testing files here as
> well.

To eliminate misunderstanding, the above is an additional problem besides author's report :)
Comment 6 Rainer Bielefeld Retired 2011-03-09 21:46:28 UTC
Effect is Reproducible with "LibreOffice 3.3.1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (build 8 / tag 3.3.1.2)]", but only if "Export Note Pages" ix checked in export dialog. I cant decide whether that might be the intended behavior? The text for the checkbox is "Export note pages", not "export notes". But I have no idea for what such a feature might be useful.

It's the same with OOo 3.4-dev

I can confirm Yifan's additional observation concerning PDF navigation with AR10, and I also think that that might be a different problem. Let's wait until we will have found all details concerning the reported problem.

@Kendy:
Help Items do not match with dialog, can you please check that? May be so we can get additional information concerning intended behavior.
Comment 7 mathog 2011-10-21 10:12:32 UTC
It is still like that on Windows XP for versoin

LibreOffice 3.4.3 
OOO340m1 (Build:302)

The thing is, the second page (the one with the notes) corresponds to
PowerPoint's 
  Print what: -> Notes pages
option in the print dialog.  

That is NOT what I want to do with notes.  They should show up in the "comments" section of the PDF which is produced, but they do not.  They do not even if "tagged PDF" is selected in the PDF, or for any combination of "notes" and "comments" in the same dialog.

Here is a discussion of the sort of functionality this should provide, starting
with Acrobat X (full version) and then doing the same thing with a PPT script
and inserting the notes into a PDF after the fact using PDF XChange Viewer

  http://saf.bio.caltech.edu/pdfnotes/#pptnotes

Since LibreOffice has "Export as PDF..." it really should be able to do this directly.
Comment 8 Björn Michaelsen 2011-12-23 11:45:18 UTC Comment hidden (obsolete)
Comment 9 sasha.libreoffice 2012-03-28 02:30:54 UTC
Thanks for bugreport
In current formulation it is not a bug. We selected export to PDF slides AND notes. As result both are exported.

On Linux we can use File->Print instead of export. Notes will exported to PDF correctly.

We can ask developers to add option "Export slides", so we will can to disable exporting slides itself, allowing only notes exporting.
Comment 10 Thorsten Behrens (CIB) 2012-04-12 03:25:30 UTC
Confirming this works as designed - though it's a valid feature request. Setting importance to medium, since it's relatively easy to cut down the generated pdf.
Comment 11 bugquestcontri 2013-03-06 03:14:09 UTC
the pdf-export for notes producing slides and notes is quite an annoyance. I only found accidentally that the notes are behind the slides.

Besides this, printing out the notes (not pdf-export) works only if landscape format is selected.If landscape format is selected. In portrait format parts get cut off.

Version 3.6.5.2 (Build ID: 5b93205)
Comment 12 narayanaras 2015-06-24 05:44:32 UTC
The Print command works fine in Windows also (it can export only the notes pages; without the Slides pages preceding it). Indeed it is easy to select a virtual printer that creates a pdf file instead of actually printing it.

But that would be a workaround: The bug is still valid.

To clean up the GUI, provide an additional "Export slides" check  box in the Export dialog, just above the "Export Notes" check box; like this:

[] Export slides pages
[] Export notes pages

BTW this is a fairly annoying thing. Why is it not tackled for 4 years?
Comment 13 paulystefan 2017-11-28 18:08:41 UTC
solved in 5.3.7.2 

optional 

printing notes pages option is available in 5.3.7.2

now all three possible: 

only slides
notes pages also
notes pages only
Comment 14 paulystefan 2017-11-28 18:19:29 UTC
also solved in 5.4.3.2 x64 win10