Bug 35215 - in Writer in table formulas behaves somewhat strange
Summary: in Writer in table formulas behaves somewhat strange
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-11 07:29 UTC by sasha.libreoffice
Modified: 2013-11-28 06:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-03-11 07:29:38 UTC
to reproduce this problem in Writer create table 3x3 and enter there:
1 2
3 4
in top left four cell, so that bottom row and right-hand column remain empty.
then place cursor in first cell of bottom row and press tool Sum on toolbox Table (like Greek sigma). Then select cells with numbers. Appears 
=sum<A1:B2>
and press enter. Appears 10. It is ok. So should be.

Then place cursor in second cell of bottom line and press Sum and select cells with numbers. Appears this:
=sum(<A3>)<A1:B2>
it is strange, but works ok when press enter.

Then place cursor in 3-th cell of bottom line and press Sum and select cells with numbers. Appears this:
=sum(<A3>|<B3>)<A1:B2>
it is yet more strange, but works ok.

Then select two cells with formulas and press Del. Content disapears, but when we place cursor in other cell, instead of deleted formulas appears 0. It is character, not formula
Comment 1 sasha.libreoffice 2011-03-11 07:37:24 UTC
And then Undo several time to return formulas. But instead of formulas appears 100, but it is not formula, but simple text. Undo and redo works strange.

Then select first row in table and press button Delete Row on toolbox. Row disappears, but in formula appears:
=sum<?:B1>
if delete others lines, not first or insert line, range corrects in formula properly.

produced on Mandriva 64 bit and windows 32 bit on LibreOffice 3.3.1.2 and 3.3.2.1rc1
Comment 2 Björn Michaelsen 2011-12-23 11:51:03 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2011-12-29 23:15:38 UTC
all reproducible in LibO 3.5.0 beta 1
Comment 4 tester8 2012-02-14 11:43:53 UTC
NEW due to previous comment.
Comment 5 Mike Kaganski 2013-11-28 06:37:41 UTC
I'm sorry to say this, but this issue is INVALID.
1. It contains three different problems in one. Each one should have its own dedicated report.
2. The first problem is not a bug. The Sum operation (as it is implemented in LO now) works horizontally, i.e. it automatically fills the arguments for "sum" with cells to the left of current cell. If there are no cells to the left, the arguments stay empty. But, as it is pointed out in bug 61228, the sum is the default function in LO formula, so you may even omit the function name and simply write "=<A1:B2>", and it will give you correct answer.

If you enter a formula that contain of consecutive values (like in "=sum(<A3>)<A1:B2>", that expand into "=sum(A3) sum(<A1:B2>)", and then to two values "10 10"), the result is the last value, i.e. the last "10".

Actually, when you use the "Sum" (Sigma) button, you are not expected to fill the argument list manually (or, if you need so, you should _modify_ the automatically filled argument list). Thus, your actions in your cells B3 and C3 are incorrect (you needed to replace rather than add).

Closing this as INVALID. But I filed two follow-up bugs (concerning deletion of formula resulting in 0 -> Bug 72100, and incomplete undo -> Bug 72101) myself, because I suffer from these myself.

If you think that the first issue is not resolved, please file another report for it, maybe an enhancement request. I believe tracking it here would be difficult for a developer (taking into account the considerations above).

Thank you for reporting!