Download it now!
Bug 35266 - FILESAVE: Page border FORMATTING is saved inaccurately to .doc file format
Summary: FILESAVE: Page border FORMATTING is saved inaccurately to .doc file format
Status: RESOLVED DUPLICATE of bug 126567
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOC-Page
  Show dependency treegraph
 
Reported: 2011-03-13 03:08 UTC by shumisha
Modified: 2020-04-24 07:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shumisha 2011-03-13 03:08:34 UTC
Hi

1 - Create an empty new file. 
2 Add a Page border, for instance a 1 Pt wide instead of the default width, and add a shadow (default values: color grey), using Format/Page and the Borders tab
3 - Save as a Microsoft Word 97/2000/XP (.doc) document
4 - Close and then reopen the file

The 1 pt wide border is gone, replaced by the default width (have not checked whether other attributes are reset as well, but likely).
The shadow width has been reduced to default value, and the color has been reset to black

Thanks for any input
Comment 1 Björn Michaelsen 2011-12-23 11:51:05 UTC Comment hidden (obsolete)
Comment 2 Roman Eisele 2012-05-01 10:03:34 UTC
Partially [REPRODUCIBLE] with LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80), German UI, running on MacOS X 10.6.8 German.

Following the steps given by shumisha in his/her original description, I can report that the results are better now: if you open the .doc file again (step 4), the 1pt wide border is still present now. But two issues remain and should get fixed:

1) The shadow has the wrong color (it is black now, like the border, instead of grey). Also, if I manually change the shadow color to any color, this setting is lost after saving and opening again the .doc file: the color is black now again.

2) The 'Distance' setting for the shadow has changed (from 0.18cm, which was the default setting when I created the document, to 0.07cm). Also, if I manually change the 'Distance' setting to some other value, e.g., 0.5cm, this setting is lost after saving and opening the .doc file again: the value is 0.07cm again.

I have also tried the other settings for the border. The border width and the border color (even if you use another color than black) are still correct after saving the file as .doc, closing and opening it again. The distance of the border from the contents are still present, too, but there are some rounding problems or like that: if I enter 0.4cm, 0.5cm, 0.6cm, 0.7cm, close and open then document again, the values are now 0.39cm, 0.49cm, 0.6cm, 0.67cm. The last value is, hm, a bit too different from the 0.7cm I entered ... So:

3) The distance of the page border from the page contents is saved inaccurately to .doc files.
Comment 3 Roman Eisele 2012-05-01 10:09:37 UTC
Changed Summary in order to reflect the kind of problems more accurately.
Comment 4 Roman Eisele 2012-05-02 04:10:04 UTC
I forgot to mention:

-- I checked the .doc files created by my tests with MS Word 2010 on Windows 7; the wrong settings (wrong shadow color, wrong shadow distance/width, wrong distance of the page border from the page contents) are visible there. This confirms that the problem already happens when LibreOffice saves to .doc file format, not when it reads the files again. This is why I added the FILESAVE keyword to the Summary.

Some further remarks after sleeping one night over this issue:

-- Can someone tell us if it is possible to save the shadow color, shadow distance/width etc. into the .doc (Word 97/2000/XP/2003) file format? Both the original reporter and me just assumed that this is possible. But if it is NOT possible at all, then the problem looks different. Then issues 1 and 2 in my comment #2 would be no bugs in LibreOffice, just a shortcoming in the .doc file format.

But even if it was so, there remains issue 3 from my comment #2. And the 'distance'/width setting for the shadow of 0.07cm is IMHO a bit too low; if someone wants a shadow, it should be visible ;-). Therefore, if there is no 'distance'/width setting for the shadow in .doc files, IMHO LibO should insert a more reasonable default value when reading them, e.g. 0.2cm.
Comment 5 Michael Stahl (allotropia) 2012-05-23 05:17:46 UTC
border works in LO 3.5.4 and OOo 3.3 but not OOo 3.4beta so
it looks like there was a regression that was fixed.

the shadow doesn't work in LO 3.5.4, OOo 3.4beta, OOo 3.3, OOo 3.0.1,
so this isn't a regression, not setting "regression" keyword.
Comment 6 A (Andy) 2014-12-25 12:14:20 UTC
Reproducible with LO 4.4.0.0.beta1 (Win 8.1).
Comment 7 QA Administrators 2016-01-17 20:03:52 UTC Comment hidden (obsolete)
Comment 8 Telesto 2016-11-18 20:37:44 UTC
Confirming with:
Version: 5.3.0.0.alpha1+
Build ID: 43b5ca69aa545cf93eded55258d92d651917815f
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-18_05:27:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 QA Administrators 2018-10-01 02:53:38 UTC Comment hidden (obsolete, spam)
Comment 10 Justin L 2020-04-24 07:04:07 UTC
From everything that I can see, MS Word basically does not support any kind of 
shadow configuration. It is an on/off option.  Therefore anything like colour or distance simply cannot be specified when saving into a Microsoft format.

I can be convinced otherwise if you can provide a Word-authored document where these features are not round-tripped by LibreOffice. (for example, it sounds like a red border ought to create a red shadow, and perhaps a very thick border creates a very big shadow....)

*** This bug has been marked as a duplicate of bug 126567 ***