Bug 35278 - SLIDESHOW VIEWING: Custom animation ends with filled rectangle
Summary: SLIDESHOW VIEWING: Custom animation ends with filled rectangle
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 RC1
Hardware: All All
: high major
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard: target:3.7.0
Keywords:
: 33020 37248 39772 45015 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-13 11:25 UTC by Rainer Bielefeld Retired
Modified: 2012-10-11 19:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document, see Comment (107.12 KB, application/vnd.oasis.opendocument.presentation)
2011-08-02 11:39 UTC, Rainer Bielefeld Retired
Details
SLIDESHOW: Custom animation ends with filled rectangle (59.50 KB, application/vnd.ms-powerpoint)
2012-10-10 05:39 UTC, Edmund Laugasson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-03-13 11:25:10 UTC
With "LibreOffice 3.3.2RC1  – WIN7  Home Premium  (64bit) English UI [OOO330m19 (Build:201 / tag 3.3.2.1)]" I found during ma tests for 
Bug 34506 - Animation 'increase font size' will blur character:

Several custom animations for characters are broken, anemation ends with completely filled text box. I checked without hardware acceleration and without anti aliasing, but I believe it does not matter.

You can see the problem also if you only use automatic preview for "Emphasis" animations for my test document from a.m. bug report:
Fill color, Blast, Flicker, Teeter, Color Blend, Complementary color, Complementary color2, Contrasting color, Darken, Desturate, Lighten, 

Other problem "Test box borders appear" for animations:
Change line color (also might be intended?), Lithten 

I also saw the problem for s smiley shape.

That's serious, even might be a blocker!

@Andreas Mantke:
Can you please try to reproduce the problem?
Comment 1 Rainer Bielefeld Retired 2011-05-13 01:02:28 UTC
With "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) English UI [DEV300m103 (Build:5)]" I still see some problems in priview, but only after I added the first animation, after changes the filled box problem will no longer appear.
Situation has been improved
Comment 2 Rainer Bielefeld Retired 2011-08-02 11:39:12 UTC
Created attachment 49843 [details]
Sample Document, see Comment 

Steps to reproduce problem with sample.odp:

1. open Document
2. On slide 1 click into text "abcdefg"
3. <Esc>, so that control points appear
4. Task area -> Custom Animation -> Add -> Emphasis - Exciting - Blast
   Make sure, that 'Automatic Preview' has been checked
   Expected: some animation
   Actual: you see letters starting to be blown away, but then the complete 
           text box becomes filled blue (see screenshot on slide 2)

Also other Animations from original report still show the problem
Comment 3 Jacqueline Rahemipour 2011-08-02 13:07:35 UTC
I checked this issue with LibO 3.3.3 and LibO-dev 3.4.5 on Win 7, in both versions still reproducible. In some cases only the first preview is affected, the slideshow plays the animation correctly.
Comment 4 Rainer Bielefeld Retired 2011-08-02 14:19:27 UTC
@Thorsten:
Please feel free to reassign if it’s not your area; please set Status to ASSIGNED if you accept this Bug.
Comment 5 Rainer Bielefeld Retired 2011-08-17 06:39:00 UTC
*** Bug 39772 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2011-12-09 23:56:21 UTC
*** Bug 33020 has been marked as a duplicate of this bug. ***
Comment 7 Thorsten Behrens (CIB) 2011-12-16 02:01:06 UTC
Yeah. Seems everything that involves changing the shape color hides text.
Comment 8 Thorsten Behrens (CIB) 2011-12-16 02:58:36 UTC
Hah, looking a bit closer, this seems to be an artifact of some drawing layer change - the rectangles all have a hidden, transparent polygon *in front of the text* - that gets the override fill color assigned & hides the text. Doing that with a free-form bezier curve instead e.g. does not expose the bug...
Comment 9 Rainer Bielefeld Retired 2012-01-20 23:20:07 UTC
*** Bug 45015 has been marked as a duplicate of this bug. ***
Comment 10 Rainer Bielefeld Retired 2012-08-31 17:48:26 UTC
*** Bug 37248 has been marked as a duplicate of this bug. ***
Comment 11 Edmund Laugasson 2012-10-10 05:39:05 UTC
Created attachment 68376 [details]
SLIDESHOW: Custom animation ends with filled rectangle

SLIDESHOW: Custom animation ends with filled rectangle - impossible to use this kind of files with LibreOffice Impress 3.6.2 but teachers at schools have a lot of such files
Comment 12 Edmund Laugasson 2012-10-10 05:45:28 UTC
I have same problem with Ubuntu 12.04 LTS version (all updates to current) and using LibreOffice 3.6.2.2 release 64-bit DEB-version - so I changed, that this does affect not only Windows but also Linux versions and not 3.3.1 but still in 3.6.2.2 release. Teachers at schools have plenty of such files and they cannot use them, because LibreOffice won't show them on slideshow. What shall we do? There is needed to use custom animation, because teachers want to show not all slide at once but teaching process requires to show each row separately and between each row there will be questions asked from students before the next row will be shown. Due to fact, that there are a lot of such files, it is quite impossible, that teacher will recreate them all naturally in Impress - it takes too much time. Instead of this teachers asking MS PowerPoint back but this is also impossible, because there is no money to buy it for so many computers. So - a lot of schools are stuck and don't know, what to do... So I kindly ask - please find a solution for that bug!
Comment 13 Rainer Bielefeld Retired 2012-10-10 06:04:33 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 14 Not Assigned 2012-10-11 19:34:12 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df99bb3d0de567fa34f7f6edfca4f736abb0efa2

Fix fdo#35278 - don't generate hidden primitive rectangles



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Thorsten Behrens (CIB) 2012-10-11 19:35:32 UTC
Fixed that on master, should show up in daily builds for everybody to verify. There's a slight chance for regression on export filters using metafiles (.svm, .eps, etc.) - tested that, but may break for more complex documents.