Bug Hunting Session
Bug 35294 - Calc autofilter function: column header drop-down box contents isn't sorted correctly
Summary: Calc autofilter function: column header drop-down box contents isn't sorted c...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-14 07:12 UTC by montini
Modified: 2013-12-17 12:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The screenshot of the bug (34.56 KB, image/png)
2011-03-14 07:12 UTC, montini
Details
Autofilter entries dropdown (22.38 KB, image/png)
2013-02-16 13:59 UTC, Johnny Rosenberg
Details
Also the Data → Validation thing sorts incorrectly. (28.39 KB, image/png)
2013-02-16 14:01 UTC, Johnny Rosenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description montini 2011-03-14 07:12:11 UTC
Created attachment 44436 [details]
The screenshot of the bug

When using Calc autofilter function (Data/Filter/Autofilter), data column header drop-down box contents isn't sorted correctly, when column contents includes words of native (lithuanian) letters. Word entries of native letters are placed in the beginning of the list, and the entries of remaining latin alphabet letters are placed afterwards, in correct order.

The correct order of the lithuanian alphabet is here:

Aa Ąą Bb Cc Čč Dd Ee Ęę Ėė Ff Gg Hh Ii Įį Yy Jj Kk Ll Mm Nn Oo Pp Rr Ss Šš Tt Uu Ųų Ūū Vv Zz Žž.

When using autofilter function the letters <Ąą Čč Ęę Ėė Įį Šš Ųų Ūū Žž> are placed in the beginning of the list.

This behavior doesn't occur when using the Data/Sort function.
Comment 1 Yifan Jiang 2011-03-15 03:09:12 UTC
reproduced in 3.3.1.

Hi Kohei, please help mark if it is an easy hack :) Thanks!
Comment 2 Björn Michaelsen 2011-12-23 11:47:23 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 14:00:28 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:01:35 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:06:18 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:08:20 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Johnny Rosenberg 2013-02-16 13:52:29 UTC
The bug persists in 3.6.5.2.
The bug is also valid for validated cells.
This is a very annoying bug for us non English natives.

See screenshots.
Comment 8 Johnny Rosenberg 2013-02-16 13:59:51 UTC
Created attachment 74937 [details]
Autofilter entries dropdown

In my language (called ”Swedish” for some reason), the alphabet looks like this:
A-ZÅÄÖ

As you can see in this image, not only does the ÅÄÖ end up at the beginning of the list, Å and Ä are in reverse order.

A-ZÅÄÖ is correct for Sweedish and Finnish. In Danish and Norwegian, the alphabet looks like:
A-ZÆØÅ (Æ is Danish/Norwegian for Ä and Ø is Danish/Norwegian for Ö).

Same with non capitals, of course, a-zåäö in Swedish/Finnish, a-zæøå in Danish/Norwegian.

Also note that when sorting cells works correctly.
Comment 9 Johnny Rosenberg 2013-02-16 14:01:43 UTC
Created attachment 74938 [details]
Also the Data → Validation thing sorts incorrectly.

Again, incorrect sorting, but this time åäö at least ends up at the end, but still å and ä are swapped.
Comment 10 Johnny Rosenberg 2013-02-16 14:03:00 UTC
I hope all this will be sorted out quickly… :P
Comment 11 Kohei Yoshida 2013-02-16 16:21:16 UTC
I believe I've fixed this in 4.0.  Please give 4.0 a try.
Comment 12 Kohei Yoshida 2013-02-16 16:33:13 UTC
Actually, I lied.  The fix didn't make it into 4.0.0.  But it will be fixed in 4.0.1.

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-0&id=b82da7a6681494de0cb9a1009b0de59250ba0533