Bug Hunting Session
Bug 35323 - The standard date format for Swedish is wrong
Summary: The standard date format for Swedish is wrong
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Albert Thuswaldner
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-15 02:21 UTC by fredrik
Modified: 2012-08-14 17:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fredrik 2011-03-15 02:21:00 UTC
The Swedish standard for writing and showing dates should be following the ISO 8601 standard, with four digits representing the year, not two digits as it is now.
Comment 1 Yifan Jiang 2011-03-15 22:28:03 UTC
Hi fredrik, a screenshot or a more specific description of the issue is preferred. I am not quite clear which part of the UI the bug report is focused on. Thanks!
Comment 2 Yifan Jiang 2011-03-15 22:32:00 UTC
I guess maybe you mean the default Format when choosing to 'Format Cells->Numbers->Date->Format', the default format should be YYYY-MM-DD rather than YY-MM-DD when Sweden is selected as language?
Comment 3 fredrik 2011-03-15 23:53:44 UTC
Yifa(In reply to comment #2)
> I guess maybe you mean the default Format when choosing to 'Format
> Cells->Numbers->Date->Format', the default format should be YYYY-MM-DD rather
> than YY-MM-DD when Sweden is selected as language?

Yifan: Exactly. Sorry for bein unclear.
Comment 4 Yifan Jiang 2011-03-16 03:15:06 UTC
Hi Kohei, is it an Easy Hack? :)
Comment 5 Kohei Yoshida 2011-03-21 19:05:39 UTC
Probably not an easy hack per se since the number format code is a bit convoluted.

I'll give this to Bubli, as she's worked on something in this neighborhood recently.
Comment 6 Not Assigned 2012-08-14 12:14:11 UTC
Albert Thuswaldner committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=789b162cce8ad306861344e8497eab460983440b

fdo#35323 - fix for The standard date format for Swedish is wrong