Bug 35376 - Windows 7 taskbar-pinning integration incomplete
Summary: Windows 7 taskbar-pinning integration incomplete
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Windows (All)
: low minor
Assignee: Jesus Corrius
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-16 19:42 UTC by Jared
Modified: 2013-07-30 10:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Taskbar pinning fail screenshot (194.88 KB, image/png)
2011-04-04 16:27 UTC, Zack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jared 2011-03-16 19:42:18 UTC
The general "white" LibreOffice icon can be pinned to the Win7 taskbar, and files opened through this shortcut stay bundled to the taskbar icon.  But files opened from the Desktop do not bundle themselves to the LibreOffice icon, instead they create a new program-specific icon.

However if Writer or Calc are pinned to the taskbar no grouping happens as all.

Running Win7.SP1 32-bit
Comment 1 Zack 2011-04-04 16:27:51 UTC
Created attachment 45248 [details]
Taskbar pinning fail screenshot

I can confirm this bug.  The OP's comment is a little confusing but hopefully this screenshot clears up the problem.  When LO is pinned to the taskbar and any file that opens in LO is opened in explorer a new tab of LO is created in the taskbar rather than expanding the pinned LO icon.  If this is at all confusing please look at the attached screenshot.

Of note: this behavior does NOT occur when quickstarter is enabled.
Comment 2 Zack 2011-04-04 16:30:59 UTC
(In reply to comment #1)
> Created an attachment (id=45248) [details]
> Taskbar pinning fail screenshot
> 
> I can confirm this bug.  The OP's comment is a little confusing but hopefully
> this screenshot clears up the problem.  When LO is pinned to the taskbar and
> any file that opens in LO is opened in explorer a new tab of LO is created in
> the taskbar rather than expanding the pinned LO icon.  If this is at all
> confusing please look at the attached screenshot.
> 
> Of note: this behavior does NOT occur when quickstarter is enabled.

In the screenshot it shows my quickstarter is enabled, but this is only because I had disabled it just for this test.  As soon as I opened the document quickstarter was re-enabled.  For those not using quickstarter this bug occurs all the time.
Comment 3 Rainer Bielefeld Retired 2011-04-24 09:18:25 UTC
[Reproducible] with "LibreOffice 3.4Beta2  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:1)]"

This one might be related to 
"Bug 36430 - TaskBar icon doesn't change under Windows 7"

@Tor:
Your area?
Comment 4 Rainer Bielefeld Retired 2011-06-12 00:35:18 UTC
I modified Status to Assigned due to facts.
Comment 6 Björn Michaelsen 2011-12-23 11:42:59 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Marc Kaulisch 2011-12-29 01:32:14 UTC
this bug appears as well in LODev beta2 on Win7 64bit
Comment 8 Jared 2011-12-29 12:10:24 UTC
This is still present in LODEV-3.5-Beta2 for Win7_32-bit.

I can pin Writer and Calc separately to the Taskbar.  But they do not cluster correctly to the separate attached icons, rather they cluster to the icon initially accessed.

This is most visible when opening Calc attached to the taskbar, and then opening Writer either from within Calc or from the Writer icon on the taskbar.  Both LO windows appear clustered under the Calc icon.
Comment 9 Rainer Bielefeld Retired 2012-08-01 12:49:40 UTC
Effect is reproducible] with Server Installation of  "LibreOffice 3.6.0.4 rc  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit) 

this one is related to or DUP of 
Bug 53019 - Unable to pin the application to the taskbar (Windows 7)
Bug 45468 - : Windows 7 Pinned Items in Taskbar not working as expected -- no multiple items
Bug 50913 - Will not open files pinned to start bar
Comment 10 Ben 2012-12-06 02:59:25 UTC
This bug is still present in LibreOffice 3.6.3.2.

Frankly, the fact that this was reported nearly two years ago and has not been fixed is less than flattering.

Needless to say, this issue affects Windows 8 in precisely the same way that it affects Windows 7.
Comment 11 khopf 2013-07-18 07:28:43 UTC
I don't want to create a new bug report, so I'd like to add another annoying aspect to this bug:

If you reinstall your LibreOffice due to updates, all pinned documents are lost and the taskbar icon is not working anymore (link broken). You have to add the icon again to the taskbar and then all pinned documents.
Comment 12 ign_christian 2013-07-18 08:54:03 UTC
Not reproducible on LO 4.0.4.2 (Win7 32bit), perhaps it's been fixed before.
 
> If you reinstall your LibreOffice due to updates, all pinned documents are
> lost and the taskbar icon is not working anymore (link broken). You have to
> add the icon again to the taskbar and then all pinned documents.
@khopf, please open new bug report against that different issue. Please also search bugzilla first, perhaps it's been reported by someone.
Comment 13 ign_christian 2013-07-18 09:21:24 UTC
@Jared, if you see changing behavior, actually I know nothing about that. But, perhaps, this commit changing previously reported behavior:
https://bugs.freedesktop.org/show_bug.cgi?id=35785#c43
Comment 14 ign_christian 2013-07-22 03:00:09 UTC
I'm sorry, behavior on comment 1 still happen if we open a file for the first time from Windows Explorer.

But that's not happen if LO start center has been opened previously.

Tested on LO 4.0.4.2 (Win7 32bit)
Comment 15 Jesus Corrius 2013-07-25 15:43:48 UTC
This will be fixed in LibreOffice 4.1.1.
Comment 16 Jared 2013-07-25 16:16:03 UTC
(In reply to comment #11)
> I don't want to create a new bug report, so I'd like to add another annoying
> aspect to this bug:
> 
> If you reinstall your LibreOffice due to updates, all pinned documents are
> lost and the taskbar icon is not working anymore (link broken). You have to
> add the icon again to the taskbar and then all pinned documents.

I agree this is an annoyance that could be cleaned up.  It's not smooth to upgrade LibreOffice, even between minor releases, and have a pinned app on the task bar that is invalid, and then the steps to repin it.
Comment 17 Jesus Corrius 2013-07-30 10:54:40 UTC
Let's close it as RESOLVED FIXED. We will reopen it if we find any regression during the testing process of LibreOffice 4.1.1.