Bug 35480 - Curves have round control points with black background
Summary: Curves have round control points with black background
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.2 RC1
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Not Assigned
URL: http://nabble.documentfoundation.org/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-20 23:00 UTC by clio
Modified: 2011-11-01 08:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (34.58 KB, image/png)
2011-03-20 23:00 UTC, clio
Details
Screenshot with GIMP save as PNG settings (25.48 KB, image/png)
2011-03-22 18:16 UTC, clio
Details
screenshot of a curve (without zoom) (4.70 KB, image/png)
2011-03-25 10:17 UTC, clio
Details
Screenshot Indexed Color Conversion Settings (40.09 KB, image/png)
2011-03-26 13:55 UTC, clio
Details
import png and convert to ppm - illustration of the bug (48.07 KB, application/vnd.oasis.opendocument.graphics)
2011-03-30 11:44 UTC, clio
Details
Draw screenshot with transparent Bezier handles (34.56 KB, image/png)
2011-05-25 16:46 UTC, Bernhard Dippold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2011-03-20 23:00:09 UTC
Created attachment 44645 [details]
Screenshot

See screenshot.
Comment 1 clio 2011-03-22 18:16:08 UTC
Created attachment 44734 [details]
Screenshot with GIMP save as PNG settings

The problem is in the file markers2.png. If saved (in GIMP) as illustrated on the screenshot (RGB Mode applied before saving it), then all looks fine in Draw. In hg.services.openoffice.org the file markers2.png have size 4.3kB, the newly saved file has the same size around 4.3kB, but the former file in LibO had 2.2kB size. Here is the screenshot with GIMP save as PNG settings.
Comment 2 Thorsten Behrens (CIB) 2011-03-24 06:03:43 UTC
Cannot reproduce - for me, the handles look perfectly round (and w/o black background). The different size is due to an optimization run over all png with "optipng"
Comment 3 Thorsten Behrens (CIB) 2011-03-25 07:13:58 UTC
From the list:

> I can't check this with master, I have only dev-build 3.3.1. The
> screenshot is made with LibO 3.3.2 Final + Ubuntu 10.04 x86, and the
> problm exists on Windows XP virtual machine with 3.3.2(rc1?) (maybe
> the videocard matters? Intel GMA 900). With dev-build 3.3.1 with
> differently saved markers2.png, sometimes I see grey background (not
> black). But with the file posted here the round markers are
> transparent. With the markers2.png file from
> hg.services.openoffice.org they are transparent too. If the problem is
> not reproducible or already fixed in master, then never mind.
>

So, does not happen with 3.3.2 here, too. Tor, any chance to quickly check win32 is looking ok? Open Impress, draw a bezier curve, enable the "edit points" toolbar button, press ctrl-A to display all control points.
Comment 4 clio 2011-03-25 09:38:43 UTC
On a different notebook with Windows Vista (with NVidia GeForce 7000M if it matters), the controls have black background too. I use Galaxy theme with small icons (but it seems that this behavior doesn't depend on themes - checked on Linux).
Comment 5 Thorsten Behrens (CIB) 2011-03-25 09:52:12 UTC
Checked on windows - does not happen here. Clio, you're sure you're not looking onto a bezier control point that's *exactly* on top of a normal (rectangular) curve point? can you try moving that bezier point away?
Comment 6 clio 2011-03-25 10:17:08 UTC
Created attachment 44859 [details]
screenshot of a curve (without zoom)

Here is how the curve looks like (Linux) (without zoom)
Comment 7 clio 2011-03-25 11:04:12 UTC
>Open Impress, draw a bezier curve, enable the "edit
points" toolbar button, press ctrl-A to display all control points.

Draw, not Impress. I got why you can't reproduc it. Open Draw, not Impress. In Impress and Writer there another markers used (markers.png).
Comment 8 clio 2011-03-26 13:55:14 UTC
Created attachment 44900 [details]
Screenshot Indexed Color Conversion Settings

It is not necessary to have image in RGB mode. It can be converted to indexed colors as shown in this screenshot. The size decrease to 3.0 kB (PNG compression is 6).
Comment 9 Thorsten Behrens (CIB) 2011-03-30 02:50:21 UTC
Eh. Indeed. Sorry for that - and actually having two marker designs for the two apps is, err, surprising and suboptimal.

For the bug: markers2.png *does* contain transparency, so I'd rather fix the png filter, than the file.
Comment 10 clio 2011-03-30 11:44:49 UTC
Created attachment 45068 [details]
import png and convert to ppm -  illustration of the bug

Here is another bug that seems can be fixed along with this. Look at the attached file. There are 2 png's saved in GIMP with and without option "Save color values for transparent pixels". They are imported correctly. But if you export them to PPM, you will notice that the transparency of the first PNG turned into black.
Comment 11 clio 2011-04-01 07:04:15 UTC
Sorry, but the latest screenshot is invalid (and the second patch on the list too), because saving with these options will result in White background (not transparent) and I didn't notice that first because the background of the paper is white too. Hardly I can fix the bug with the filter, so if there someone who could fix it then it's great. IMHO, in case the bug itself is not fixed before 3.4 release, we should fix at least the picture markers2.png.
Comment 12 ape 2011-05-10 07:56:02 UTC
Bug is present in 13_LibO-3.4.0_beta4_win
Comment 13 Björn Michaelsen 2011-05-24 02:43:30 UTC
discussion as per:
http://nabble.documentfoundation.org/PATCH-Bug-35480-Curves-have-round-control-points-with-black-background-Draw-if-confirmed-td2718487.html#a2736894

@Bernhard: Could you confirm its ok to apply this patch? Looks great to me, but I'd like to have a design guy having it seen at least.

Reassign as appropriate.
Comment 14 clio 2011-05-24 12:13:50 UTC
Please, note that the second variant of the patch (mailed on Mar 26, 2011; 5:23pm - see above link) is wrong. It causes white background (see comment#11 in this bug report). You can use either the patch from Original Post on the maileng list (see http://nabble.documentfoundation.org/PATCH-Bug-35480-Curves-have-round-control-points-with-black-background-Draw-if-confirmed-tp2718487p2718487.html) or (better and more reliable - because you don't need to review it) just take the picture from hg.services.openoffice.org - here:
http://svn.services.openoffice.org/opengrok/xref/DEV300_m106/default_images/svx/res/markers2.png
Comment 15 Bernhard Dippold 2011-05-25 16:46:40 UTC
Created attachment 47166 [details]
Draw screenshot with transparent Bezier handles

@ Thorsten: Sorry, I'm short in time, thus not as deeply involved in this bug to understand the underlying problem.
Here (LibO 3.3.2 on Ubuntu) I don't see the black background in Draw Bezier handles - see screenshot.

Is there an easy way for me to reproduce the bug and to verify the patch?
Comment 16 Björn Michaelsen 2011-10-01 06:54:29 UTC
Disowning this bug until there is a clear way to reproduce/implement.
Comment 17 Thorsten Behrens (CIB) 2011-11-01 08:38:17 UTC
Fix from Michael via commit 54c7480a6cdb049a5b0c907fa86af42068dcae16 to master - this was alpha channel lost somewhere in the code, not broken png.