Download it now!
Bug 35505 - Using autoformat removes date-formatting in certain circumstances
Summary: Using autoformat removes date-formatting in certain circumstances
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-AutoFormat
  Show dependency treegraph
 
Reported: 2011-03-21 06:21 UTC by Larsen
Modified: 2020-07-04 09:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File to reproduce the problem (9.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-03-21 06:21 UTC, Larsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Larsen 2011-03-21 06:21:28 UTC
Created attachment 44670 [details]
File to reproduce the problem

Steps to reproduce using the attached file:
1. Select A1 to G5
2. Format > AutoFormat
3. Add new template
4. Click ok to apply the template

Result:
The dates in the column "birthday" are converted to numbers.

Though, when you first delete column C, the dates are preserved.
Comment 1 Rainer Bielefeld Retired 2011-05-03 00:10:30 UTC
I can confirm the reported effect with "LibreOffice 3.4Beta3  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:3)]", but I know too few about auto format to decide whether it's a bug and what the reasons might be.

But the result is unexpected, or course.
Comment 2 Björn Michaelsen 2011-12-23 11:46:19 UTC Comment hidden (obsolete)
Comment 3 Larsen 2011-12-24 02:37:02 UTC
Tested with LOdev 3.5.0: now crashes LO and the Windows error reporting shows up. No further information is visible.
Comment 4 Rainer Bielefeld Retired 2011-12-24 03:03:58 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Thank you for 3.5 Review!
Comment 5 A (Andy) 2013-12-28 16:51:46 UTC
I have tested it and I could reproduce it with LO 4.1.4.2 (Win8). The date category of the cells was changed to numbers, so that they lost the dates. This was done without a crash of LO.
Comment 6 QA Administrators 2015-04-19 03:22:18 UTC Comment hidden (obsolete)
Comment 7 Larsen 2015-04-19 10:16:57 UTC
Problem is still present in the same way as before in LO 4.4.2.2, Win 7 SP1
Comment 8 QA Administrators 2016-09-20 09:32:37 UTC Comment hidden (obsolete)
Comment 9 Larsen 2016-09-20 10:30:08 UTC
Problem is still present in the same way as before in LO 5.1.5.2 (x64), Win 10 (1607)
Comment 10 Xisco Faulí 2017-09-29 08:52:11 UTC Comment hidden (obsolete)
Comment 11 Larsen 2017-10-03 17:10:03 UTC
Problem still exists with 5.2.6.2 (and pretty sure the current 5.3 that I don't use due to serious performance problems while scrolling).
Comment 12 QA Administrators 2018-10-18 02:49:29 UTC Comment hidden (obsolete)
Comment 13 Larsen 2018-10-18 07:53:16 UTC
Still present in 6.0.6.2
Comment 14 QA Administrators 2019-10-19 02:42:12 UTC Comment hidden (obsolete)
Comment 15 Larsen 2019-10-21 08:55:48 UTC
Still present in 6.2.7.1
Comment 16 Zaida Vargas 2020-04-20 13:49:42 UTC Comment hidden (spam)
Comment 17 Justin L 2020-07-04 09:23:50 UTC
There is an checkbox ability already in LO 3.5 (and perhaps earlier) to NOT apply number format while applying the autoformat, and that of course takes care of the problem.