Bug Hunting Session
Bug 35666 - toolkit.UnoControlDialogModel::com::sun::star::io::XPersistObject fails
Summary: toolkit.UnoControlDialogModel::com::sun::star::io::XPersistObject fails
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: unoapitest
Keywords:
Depends on:
Blocks: subsequenttest-failures
  Show dependency treegraph
 
Reported: 2011-03-25 08:12 UTC by Björn Michaelsen
Modified: 2012-08-31 10:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2011-03-25 08:12:11 UTC
The unoapi test toolkit.UnoControlDialogModel::com::sun::star::io::XPersistObject fails
in toolkit. To reproduce, remove the test from the blacklist at:
 toolkit/qa/unoapi/knownissues.xcl
and run:
 cd smoketestoo_native && build --all
 cd toolkit && make -sr subsequentcheck
Comment 1 Björn Michaelsen 2011-03-26 04:06:59 UTC
Make all bugs with whiteboard status "unoapitest" and "complextest" block the 35690 subsequenttests metabug.
Comment 2 Björn Michaelsen 2011-03-26 04:10:23 UTC
All subsequenttest bugs now block their own subsequenttests metabug:

 https://bugs.freedesktop.org/show_bug.cgi?id=35690

=> Removing 35657, 35660, 35661, 35661, 35662, 35663, 35666, 35667 as blockers from 35673

35668 stays as it is a reproducable crasher.
Comment 3 Björn Michaelsen 2011-05-22 04:16:40 UTC
Error: File /home/bjoern/.jenkins/jobs/fix-subsequenttests/workspace/toolkit/source/controls/unocontrolmodel.cxx, Line 763: UnoControlModel::write: don't know how to handle a property of type 'com.sun.star.container.XNameContainer'.
(Currently handling property 'AllDialogChildren'.)

Error: File /home/bjoern/.jenkins/jobs/fix-subsequenttests/workspace/toolkit/source/controls/unocontrolmodel.cxx, Line 966: UnoControlModel::read: don't know how to handle a property of type 'com.sun.star.container.XNameContainer'.
(Currently handling property 'AllDialogChildren'.)

The AllDialogChildren property contains a com.sun.star.container.XNameContainer which cannot be serialized by the unocontrolmodel.cxx code, thus breaking the 
XPersistObject for this class.

@noel: any idea where we introduce this and if this could be problematic in the long run?
Comment 4 Noel Power 2011-05-23 02:27:50 UTC
(In reply to comment #3)
> Error: File
> The AllDialogChildren property contains a com.sun.star.container.XNameContainer
> which cannot be serialized by the unocontrolmodel.cxx code, thus breaking the 
> XPersistObject for this class.
> 
> @noel: any idea where we introduce this and if this could be problematic in the
> long run?

yes, I introduced this, it is for vba interoperability, in 'normal' operation this property isn't used, when importing vba userforms ( converted to libreoffice dialogs ) the vba code uses this property. So.. it is a hack if you like. In anycase this is really a transient property, not sure about the (unit?) test code maybe there is some way to define the property so it doesn't try to persist is and hence won't complain ? do you know ?
Comment 5 Björn Michaelsen 2011-12-23 11:51:34 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Florian Reisinger 2012-08-14 14:03:26 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:04:22 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:08:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 Florian Reisinger 2012-08-14 14:10:55 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian