Download it now!
Bug 35689 - LibO should propose an "export to pdf - cropped"
Summary: LibO should propose an "export to pdf - cropped"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Import-Draw
  Show dependency treegraph
 
Reported: 2011-03-26 03:30 UTC by Paul Cazottes
Modified: 2016-05-09 14:59 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example (38.29 KB, application/zip)
2011-03-26 03:30 UTC, Paul Cazottes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Cazottes 2011-03-26 03:30:41 UTC
Created attachment 44883 [details]
Example

LibO proposes to export to pdf. It exports the full page or the selected area.

However sometimes we only want the used area (as if you want to include a pdf for pdfLaTeX). I usually export to pdf then use pdfcrop.

It would be very nice to add a crop option in the export dialog box (below "Files / Export to Pdf / General / Area").
Comment 1 Björn Michaelsen 2011-12-23 11:46:38 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Paul Cazottes 2012-01-03 14:00:01 UTC
The feature I was asking is still not in LO 3.5 beta 2
Comment 3 Joel Madero 2014-07-13 01:33:36 UTC
Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 Heiko Tietze 2016-05-09 14:45:58 UTC
Closing this feature request as WORKSFORME because a) dealing with tickets older than five years is necrophiliac, and b) cropping PDF is not in scope, IMHO. There is a good workaround (PDFCrop) and you could adjust the drawing beforehand accordingly.

However, the idea for enhancement is valid and goes into the sub meta therefore.
Comment 5 Heiko Tietze 2016-05-09 14:59:00 UTC
The bounding box feature could solve this issue too. Set to a value lower than the selection could mean to crop the output.